Contribute
Register

Psedog's Mod Pro. i7-8700K, Vega64, Gigabyte Z390 Aorus Pro Wifi

Joined
Oct 26, 2012
Messages
57
Motherboard
Gigabyte Z390 AORUS PRO WIFI
CPU
i5-9400F
Graphics
RX 580
Mac
iMac
Classic Mac
Apple, iMac
Mobile Phone
iOS
Joined
Nov 27, 2018
Messages
254
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Ok @psedog
I will be waiting for your reply on macOS sierra..
I couldn't get it to boot. I kept getting the circle with the line through it.

Edit, turns out that disk has Mavericks on it. Of course it wouldn't boot, lol. App store won't let me download Sierra anymore.

If you have access to a Sierra disk or install, try changing your SMBIOS to iMac 17,1
 
Last edited:
Joined
Nov 27, 2018
Messages
254
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
@chanster I have a beta version (The only one the App store would let me download) that I'm installing on an external drive with my Macbook Air. I'll test it on the Hackintosh in the next couple of days. I was able to get the installer to start (with SMBIOS iMac17,1), but it froze on the Apple logo. I didn't feel like troubleshooting it. I'd rather get it working on another drive and then mess with Clover to get it to boot.
 
Joined
Nov 27, 2018
Messages
254
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Ok @psedog
I will be waiting for your reply on macOS sierra..

Thanks for the reply @psedog
Got it working. You need to be on the latest update on Sierra (10.12.6). Video card isn't quite right, but your RX580 may work. Everything seems to be working (even though I booted the hard drive off of USB2.0 port).
Clover folder attached.

Sierra Screen Shot 2019-04-23 at 9.57.09 PM.png
 

Attachments

Joined
Oct 26, 2012
Messages
57
Motherboard
Gigabyte Z390 AORUS PRO WIFI
CPU
i5-9400F
Graphics
RX 580
Mac
iMac
Classic Mac
Apple, iMac
Mobile Phone
iOS
Got it working. You need to be on the latest update on Sierra (10.12.6). Video card isn't quite right, but your RX580 may work. Everything seems to be working (even though I booted the hard drive off of USB2.0 port).
Clover folder attached.

View attachment 401266
Thanks for the reply @psedog

Is Usb 3.0 working and also shutdown is working? When any device is connected to usb 3.0
As when I tried earlier audio from hdmi port is getting delay of my graphic card
 
Joined
Nov 27, 2018
Messages
254
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Thanks for the reply @psedog

Is Usb 3.0 working and also shutdown is working? When any device is connected to usb 3.0
As when I tried earlier audio from hdmi port is getting delay of my graphic card
When I posted yesterday, I had just gotten it working. I hadn't messed with it. On my own rig, I do have USB 3.0 working now as well as Bluetooth. I'm going to try and get the graphics card working correctly and I'll post in a couple of hours whether I was successful or not.

Edit:
Crashed the OS playing too much . Restoring it on my laptop now.

Anyway, use the SSDT from the first page of this thread and your USB3.0 ports will work.
 
Last edited:
Joined
Nov 28, 2018
Messages
54
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i7-8700
Graphics
RX 570
Mac
MacBook Pro
Mobile Phone
iOS
Random (long interval over 3hrs from being put to sleep) "wake" from sleep? So I'm not sure if my hackentosh is "actually" waking from sleep or if this has something to do with clover. My hackentosh is in my bedroom and as such I find that sometimes the LED's on it will turn on at night (there is no set internal I am aware of). I could be wrong on this but, when my monitors are left on and the LED lights turn on, no signal/image is sent to wake the monitors hence why I am not sure OSX is actually "waking" as much as maybe clover is doing something to keep the OSX from shutting down? Any one else find this occurring?
 
Joined
Nov 27, 2018
Messages
254
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Random (long interval over 3hrs from being put to sleep) "wake" from sleep? So I'm not sure if my hackentosh is "actually" waking from sleep or if this has something to do with clover. My hackentosh is in my bedroom and as such I find that sometimes the LED's on it will turn on at night (there is no set internal I am aware of). I could be wrong on this but, when my monitors are left on and the LED lights turn on, no signal/image is sent to wake the monitors hence why I am not sure OSX is actually "waking" as much as maybe clover is doing something to keep the OSX from shutting down? Any one else find this occurring?
The LED's turning off is setup in BIOS. Clover doesn't do anything after boot. It just tricks OSX into thinking it's using legitimate Apple hardware. If you are having sleep issues, try loading osxaptiofix 2000
 
Joined
Nov 2, 2011
Messages
83
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i7-8700K
Graphics
UHD 630
Psedog, I have questions. Your new configiGpu.plist has the following device:

"PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)" under Devices. What is this for?

Also,

How are you handling the USB's now?

Thanks.
 
Joined
Nov 27, 2018
Messages
254
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Psedog, I have questions. Your new configiGpu.plist has the following device:

"PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)" under Devices. What is this for?

Also,

How are you handling the USB's now?

Thanks.
That is to setup the Vega64. It adjusts the fan profile as well as provide a slight overclock. Now that I've identified updated OSX to build 18E2034 and set my Mac to iMac 19,1. I want to test it without this fix as I've heard the new build supports Vega graphics cards (but the system is stable, so I'm hesitant as well ;) ).

I'm still running my SSDT with the USB port patches that are included with the latest Clover Configurator.

Screen Shot 2019-05-07 at 8.24.50 PM.png
 
Top