Contribute
Register

PSA: Gigabyte F20B BIOS changes

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,528
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
I've enabled KernelPM and APIC patch but get this kernel panic.. my bios settings seem to match up with the recommended settings.
DVMT Pre-Allocated setting in BIOS is likely set incorrectly. Required: 64mb or larger (128mb usually works well).
 
Joined
Nov 26, 2012
Messages
1,522
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I've been attempting to flash BIOS with multiple updates since building this rig without success using the instructions in post #1 (https://www.tonymacx86.com/threads/psa-gigabyte-f20b-bios-changes.207965/). I Formatted a 32gb USB3 pen drive to FAT32, copied the files to the drive and then booted into BIOS Flash (END key). Every update I have tried gives me the same "Cannot Read File". See the latest zip attached. The BIOS presently is f20. Any help would be appreciated.
 

Attachments

Joined
Mar 23, 2011
Messages
120
Motherboard
Acer Aspire 5 A515
CPU
i5 8265U
Graphics
Intel UHD 620
Mobile Phone
Android
I have this hardware now:
GA-Z170XP-SLI with Bios F6

Someone have success with solve this huge entries in UEFI/Bios?
I have 94 entries!! :banghead:

Now in the Gigabyte website we have the F20, F21, F22a and F22c UEFI/BIOS releases, I want to know if someone have this issues solved with this motherboard.

Thank you guys. ;)
 
Joined
Sep 4, 2011
Messages
116
Motherboard
El Capitan 10.11.6
CPU
Intel i5 2310
Graphics
AMD Radeon 6670
Mac
iMac
Mobile Phone
I have this hardware now:
GA-Z170XP-SLI with Bios F6

Someone have success with solve this huge entries in UEFI/Bios?
I have 94 entries!! :banghead:

Now in the Gigabyte website we have the F20, F21, F22a and F22c UEFI/BIOS releases, I want to know if someone have this issues solved with this motherboard.

Thank you guys. ;)
You just have to update the BIOS to the latest one, all entries will be gone and won't appear again. You might need your USB installer to boot the system after the update, and then reinstall Clover. But sometimes it isn't necessary.
 
Joined
Mar 23, 2011
Messages
120
Motherboard
Acer Aspire 5 A515
CPU
i5 8265U
Graphics
Intel UHD 620
Mobile Phone
Android
That's true. I has updated my UEFI/BIOS and all entries are gone.

;)
 
Joined
May 31, 2016
Messages
760
Motherboard
Z170X-UD5 TH
CPU
i7-6700K
Graphics
GTX 1080
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
PowerBook, Quadra
Mobile Phone
iOS
You just have to update the BIOS to the latest one, all entries will be gone and won't appear again. You might need your USB installer to boot the system after the update, and then reinstall Clover. But sometimes it isn't necessary.
Technically you won’t need to reinstall clover, you’ll need to go through your bios settings and change them back to what they need to be for hackintosh; the bios update will reset the bios to default settings.
 
Joined
Apr 29, 2017
Messages
47
Motherboard
GA-Z170N-WIFI
CPU
Intel i7 6700K
Graphics
AMD RX570
I have had a stable working hackintosh for several months now. This afternoon I update bios from F7 to F20f. The system will post and I got into the BIOS and changed all my setting to the correct ones but when I try to boot into MacOS the apple logo shows up and the loading bar pops up but never load. It just stays there forever. My MacOS drive is a Samsung NVME M.2 SSD.

I tried...
However in both my cases clover would NOT boot macOS at all until I checked/enabled both "Patch APIC" and "KernelPM" options in clover.
I also tried this...
Try this :
At the Clover Boot Screen select Options > PCI devices > USB Ownership and USB Injection
Nothing is working. Any ideas?
 
Joined
Apr 13, 2016
Messages
64
Motherboard
GA-H170N-WIFI-22e
CPU
i3-6100
Graphics
HD 530
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
LC, Power Mac, PowerBook
Mobile Phone
iOS
I had similar behavior, with rotating hd drive, and the fix of USB ownership and USB injection helped me. There are also video fixes needed if using intel graphics. Finally, the NVME drives have a special issue you might need to look up. But first, can you try booting from an external drive?
 
Joined
Mar 25, 2011
Messages
4
Motherboard
GA-Z170N-WIFI (rev 2.0)
CPU
Core i5-6500
Graphics
EVGA GeForce GT 740
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Mobile Phone
Android, iOS
First, I will chime in on PLEASE DON'T EVER TRY TO UPGRADE BIOS WITHOUT READING THESE FORUMS. I suppose there are some rare cases where BIOS upgrades are good for Hackintoshes but in general it looks like they are bad unless you need new processor support (e.g. Kaby Lake).

I foolishly did this. Never again. And I got VERY lucky with my High Sierra Z170N-WIFI.

Even though I supposedly have a Rev 1.0 board, it has only taken Rev 2.0 BIOS so I upgraded from FA to F22c (so it must be a Rev 2.0 board). Anyway, I ran into all of the problems mentioned here and so I followed the instructions below for BIOS settings BUT I have an EVGA GT 740 in my system. For the hell of it I did the settings exactly as below and Enabled the Internal Graphics and set Initial Display Output to IGFX - except that I did not have the DVMT settings available in the BIOS at that point.

It turns out that after a reboot or two, the DVMT settings showed up in the BIOS (already set as below), then I reset the Initial Display Output to PCI-E, Internal Graphics to Auto, and son-of-a-gun it booted and came up fine.

I'm running a fairly old version of Clover and I did not change any settings like Emu64 or anything. It just ended up working.

As always, your mileage may differ.

GIGABYTE H170N-WIFI / BIOS version: F20

I just upgraded my BIOS to version F20. It seems to work now. Hier is what I needed to do in the BIOS to get the hackintosh to boot and work properly.

After the BIOS upgrade I did reset the BIOS (on the motherboard with a jumper on the BIOS reset pins for a second by disconnected power cable).

After reboot I opened the BIOS settings and did the following changes:

Save & Exit

--> Load Optimized Defaults

BIOS
Full Screen LOGO Show -- Enabled
Fast Boot -- Disabled
Window 8/10 Features -- Other OS
LAN PXE Boot Option ROM -- Disabled
Storage Boot Option Control -- UEFI

Peripherals
Initial Display Output -- IGFX

Peripherals /Network Stack Configuration
Network Stack -- Disabled

Peripherals / USB Configuration
Legacy USB Support -- Enabled
XHCI Hand-Off -- Enabled

Chipset
VT-d -- Disabled
Internal Graphics -- Enabled
DVMT Pre-Allocated -- 64M
DVMT Total Gfx Mem -- 256M

Power
Platform Power Management -- Disabled
 
Top