Contribute
Register

PS4 controller causing Kernel Panic in lapic

Joined
Jun 15, 2012
Messages
465
Motherboard
Gigabyte Z370 AORUS Gaming 7-F13
CPU
i7-8700K OC @ 5.1Ghz
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
On 11.5.1 on a system that's otherwise pretty stable, but one issue remains. PS4 controller plugged into UPS sporatically causes kernel panic. I had a dev symbolize and debug panic and said it's being caused in a specific call.

I've attached his analysis, his analysis came from the full .panic file and seeing lapic_interrupt in the call stack then seeing that the specific paniced thread was not symbalaized and exactly tw ofunctions in source code of lapic_interrupt aren't symbalized so it has to be panicing on one of those two calls.

I can pretty much get panic within an hour using PS4 controller or if i unplug it, stable for 2 weeks straight. The obvious solution to some would be "well just don't use controller" but I play a lot of openemu and other games with it. I've reviewed patches and opencore config 10x over and bios settings and didn't find solution there.

What's been Tried:
Different system defs: imac19,1, imac19,2, imacpro,1,1
Toggling bios setting IOAPIC Entries 24-119 on and off, neither setting results in panic going away.

Using Gigabyte Aorus Gaming 7 motherboard, which is a "fake" 370 (which is why some of the quirks don't make sense for 370.
CPU is 8700K.
If wondering why using imacpro instead of imac19 at moment. I have igpu disabled and getting full hardware encode/decode and DRM working on 6900XT favors imacpro sys, and issue occurs on imac18, igpu on or off so I prefer the imacpro even if it kind of hoses cpu power management. On that note I also tried removing PLUG ssdt and that doesn't matter either way.

I just wonder if I need a specific patch or another usb/bios setting i missed to make it behave right, or If I just just throw "lapic_dont_panic=1" in boot args and call it a day?


EDIT: Just now noticing the LapicKernelPanic kernel quirk that literally disables this type of panic. doesn't solve why it happens. Also googling it shows it's typically a quirk an HP laptop needs, not something a gigabyte golden desktop build should need, especially since PS4 controller worked fine on 10.13.6 and every version of OS prior to it. Granted apple added golden drivers for it in i think catalina and later and I only just went to 11.4 and now 11.5.1 because of 6900xt so i had software and hardware changes, and technically system def changes too since on 10.13.6 even though i had a 8700k i had to use imac18 since 19 didn't exist yet. So I'll try this quirk out unless other suggests come forth and give feedback if this quirk "solves" issue for me.
 

Attachments

  • Screen Shot 2021-08-07 at 10.00.44 AM.jpeg
    Screen Shot 2021-08-07 at 10.00.44 AM.jpeg
    556.7 KB · Views: 15
  • config.plist
    28.1 KB · Views: 11
Last edited:
Top