Contribute
Register

<< Solved >> Prohibitory sign - macOS Mojave

Status
Not open for further replies.
Joined
Jan 8, 2019
Messages
7
Motherboard
Gigabyte H370 HD3
CPU
i5-8600K
Graphics
RX 570
May require USBInjectAll.kext in /EFI/CLOVER/kexts/Other/.
May require XHCI-unsupported.kext in EFI/CLOVER/kexts/Other/. (Click download repository).

I did that already before and still get those errors popping up! Ill attach my clover folder so maybe someone can figure out whats wrong.

Did you forget to edit your CLOVER and config.plist properly?
It was underlined to get your attention.
Make sure you're config.plist_Devices_USB is edited with [√]Inject [√]FixOwnership in addition to adding USB support kexts in /EFI/CLOVER/kexts/Other

No I did that as you said, but for some reason when I boot into clover those settings dont apply! There are still 5 disks to boot from, and also might be worthy to mention, those settings under Devices/USB -> Inject and Fix Ownership...when I check those in clover settings they are not marked...dunno how.

Keep in mind that I had the exact same clover folder as this one. I downloaded this one here from the forums when someone had the exact same problem as me, although this folder worked for him and unfortunately for me it didnt.
 

Attachments

  • CLOVER.zip
    2.9 MB · Views: 65
Joined
Jul 25, 2012
Messages
6,714
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I did that already before and still get those errors popping up! Ill attach my clover folder so maybe someone can figure out whats wrong.



No I did that as you said, but for some reason when I boot into clover those settings dont apply! There are still 5 disks to boot from, and also might be worthy to mention, those settings under Devices/USB -> Inject and Fix Ownership...when I check those in clover settings they are not marked...dunno how.

Keep in mind that I had the exact same clover folder as this one. I downloaded this one here from the forums when someone had the exact same problem as me, although this folder worked for him and unfortunately for me it didnt.

I downloaded this one here from the forums when someone had the exact same problem as me, although this folder worked for him and unfortunately for me it didnt.

  • Is the attached CLOVER.zip, one that is compressed from your macOSMojave USB Installer?
  • Did you mount your macOSMojave USB Installer flash disk on a Mac and mount its EFI partition to browse to CLOVER Folder and compress it to attach to this post?
    • If it is so, that CLOVER does NOT contain the kexts recommended by P1LGRIM and cmn699
  • Did you check the contents of your CLOVER/kexts/Other BEFORE you booted that USB Installer?

  • Your currently uploaded CLOVER.zip when unzipped and checked shows it
    • does NOT have needed XHCIunsupported .kexts , Whatevergreen.kexts.
    • It has several unwanted kexts .
    • I have uploaded image to show the needed to be pasted and unwanted kexts to be removed.
  • The /CLOVER/drivers64UEFI folder contents may be OK, if using that does not cause a Memory mapping error.
  • I have uploaded config.plist SECTIONS as viewed in Clover Configurator Global Clover Configurator (Global Edition)which can mount the EFI and edit config.plist
  • The config.plist is set to use the Intel HD Graphics 530 NOT AMD Radeon Rx570.
  • If the Monitor is connected to Radeon Rx570, this Mojave USB Installer won't Boot.
 

Attachments

  • 1.png
    1.png
    86.1 KB · Views: 118
  • 2..png
    2..png
    351.3 KB · Views: 120
  • 3..png
    3..png
    344.8 KB · Views: 113
  • 4..png
    4..png
    335.8 KB · Views: 97
  • 5..png
    5..png
    280.5 KB · Views: 107
  • 6..png
    6..png
    279.7 KB · Views: 104
  • 7..png
    7..png
    268.8 KB · Views: 108
  • 8.png
    8.png
    262.6 KB · Views: 90
  • 9.png
    9.png
    315.3 KB · Views: 85
  • 10..png
    10..png
    321.7 KB · Views: 94
  • 11.png
    11.png
    312.5 KB · Views: 83
Joined
Oct 20, 2012
Messages
158
Motherboard
Gigabyte GA-Z270X-Ultra Gaming - 32G Ram
CPU
Core i7-7700k
Graphics
Internal - HD630
Use a USB 2.0 port on your motherboard. Just had this issue. Loaded up Mojave on a USB 3 stick and plugged into a USB 3 port and got the big old STOP sign half way thru installation. Plugging he same stick into a USB 2.0 port works like a charm.
 
Joined
Jan 8, 2019
Messages
7
Motherboard
Gigabyte H370 HD3
CPU
i5-8600K
Graphics
RX 570
  • Is the attached CLOVER.zip, one that is compressed from your macOSMojave USB Installer?
  • Did you mount your macOSMojave USB Installer flash disk on a Mac and mount its EFI partition to browse to CLOVER Folder and compress it to attach to this post?
    • If it is so, that CLOVER does NOT contain the kexts recommended by P1LGRIM and cmn699
  • Did you check the contents of your CLOVER/kexts/Other BEFORE you booted that USB Installer?

  • Your currently uploaded CLOVER.zip when unzipped and checked shows it
    • does NOT have needed XHCIunsupported .kexts , Whatevergreen.kexts.
    • It has several unwanted kexts .
    • I have uploaded image to show the needed to be pasted and unwanted kexts to be removed.
  • The /CLOVER/drivers64UEFI folder contents may be OK, if using that does not cause a Memory mapping error.
  • I have uploaded config.plist SECTIONS as viewed in Clover Configurator Global Clover Configurator (Global Edition)which can mount the EFI and edit config.plist
  • The config.plist is set to use the Intel HD Graphics 530 NOT AMD Radeon Rx570.
  • If the Monitor is connected to Radeon Rx570, this Mojave USB Installer won't Boot.

WOW man excuse me for wasting your time for such stupid mistakes of mine, but you really helped me a lot and I cant thank you enough. I tossed away the 3.0 USB after it constantly had some errors when booting and decided to format 2.0 usb drive and use it again with all the things you and this other dude suggested and FINALLY I installed Mojave successfully. The only problem I got is that my hackintosh wont shut down...it just restarts. Ill attach a config.plist here...if you need a log file Ill attach that too.
 

Attachments

  • config.plist
    5.8 KB · Views: 127
Joined
Jul 25, 2012
Messages
6,714
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
WOW man excuse me for wasting your time for such stupid mistakes of mine, but you really helped me a lot and I cant thank you enough. I tossed away the 3.0 USB after it constantly had some errors when booting and decided to format 2.0 usb drive and use it again with all the things you and this other dude suggested and FINALLY I installed Mojave successfully. The only problem I got is that my hackintosh wont shut down...it just restarts. Ill attach a config.plist here...if you need a log file Ill attach that too.
  • Glad you finally installed macOSMojave on your listed hardware in your profile
  • The Reboot on Shut Down is a difficult problem to tackle as it is related to:
    • BIOS Chipset & Power Management choices and to some extent on
    • ACPI fixes in CLOVER_config.plist.
  • You have uploaded your config.plist.
  • I have edited its ACPI (1) with [√]Shutdown
  • Try the above ACPI fix in your config.plist and test a Shut Down to see if it fixes the issue.
  • If ACPI fix alone does not work by itself, as an add-on BIOS troubleshoot, check the uploaded BIOS screen shots and select those options shown and Save and reboot and then try Shut Down to see if the combined troubleshot fixes the issue.
  • If that does not solve, you may need to troubleshoot your USB ports with SSDT patches which is beyond this section of fixes and I would suggest RehabMan's Guide on the topic as the Bible.
 

Attachments

  • 1.config.pliust_ACPI.png
    1.config.pliust_ACPI.png
    305.3 KB · Views: 131
  • 3.BIOS_Power.png
    3.BIOS_Power.png
    259.7 KB · Views: 132
  • 2.BIOS_Chipset.png
    2.BIOS_Chipset.png
    254.1 KB · Views: 136
Joined
Jan 8, 2019
Messages
7
Motherboard
Gigabyte H370 HD3
CPU
i5-8600K
Graphics
RX 570
WOW!! It worked...not just by changing the config.plist file though I had to apply those settings in BIOS aswell.

During this process of building my first hackintosh I really did learn A LOT, and also I really got interested more and more in this process...especially when I saw how much really I dont know so I will do a research on the third option you suggested even though my hackintosh works properly.

A HUGE thank you to everybody for their help and sorry again for wasting your guyss time on my stupid noob mistakes. This community is really awesome and I will recommend it 100% to everybody! Peace.
 
Joined
Jul 25, 2012
Messages
6,714
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
WOW!! It worked...not just by changing the config.plist file though I had to apply those settings in BIOS aswell.

During this process of building my first hackintosh I really did learn A LOT, and also I really got interested more and more in this process...especially when I saw how much really I dont know so I will do a research on the third option you suggested even though my hackintosh works properly.

A HUGE thank you to everybody for their help and sorry again for wasting your guyss time on my stupid noob mistakes. This community is really awesome and I will recommend it 100% to everybody! Peace.

  • Congratulations :clap:.
  • Glad you have SuccessfullyInstalled macOS Mojave on your H370HD3 + i5-8600K with AMD Radeon 570 and solved the last problem of Reboot on Shut Down.
  • I know you have taken twists and turns to reach here but your hard work and persistence finally paid off to SOLVE all the problems you have encountered.
  • There are two things you can do for this Forum for the help you got.
    • Prefix the TITLE of your post [SOLVED] to serve as a Search Term for others to find your post to help them fix their own similar issue in the same or similar hardware in Hackintosh Mojave .
    • Write up an Illustrated Post about Mojave Installation on GA-H370 HD3 CPU i5-8600K Graphics: RX 570 combining all the correct steps and removing all the errors made to serve as a Manual or GUIDE.
 
Status
Not open for further replies.
Top