Contribute
Register

ProBook 4530s ... Display dims on startup...

Status
Not open for further replies.
Joined
Apr 25, 2015
Messages
3
Motherboard
HP Probook 4530s
CPU
i3 2.1 GHz
Graphics
Intel HD
Mac
Classic Mac
Mobile Phone
I have successfully installed OSX Yosemite on my Probook 4530s, at beginning the display brightness was fine but after running ProBook installer the display dims on startup... I guess i have installed some extra feature either through Probook Installer or Multibeast.

Help me here guys how can i restore my brighter screen.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have successfully installed OSX Yosemite on my Probook 4530s, at beginning the display brightness was fine but after running ProBook installer the display dims on startup... I guess i have installed some extra feature either through Probook Installer or Multibeast.

Help me here guys how can i restore my brighter screen.

Press your brightness up key or use the slider in SysPrefs->Displays.

Brightness is saved in NVRAM and restored across reboot.
 
Joined
Apr 25, 2015
Messages
3
Motherboard
HP Probook 4530s
CPU
i3 2.1 GHz
Graphics
Intel HD
Mac
Classic Mac
Mobile Phone
I know that might be an easy solution, but neither my functional keys(Brightness UP and Brightness DOWN) are working, nor my system show brightness slider in display preferences ...
 
Joined
Nov 27, 2013
Messages
13
Mac
Classic Mac
Mobile Phone
I have similar problem. I have Yosemite Clover EFI installed on ProBook 4540s for the last 5 months. This past week, right after Clover bootscreen, the screen dims to almost dark. I can still see a faint outline of the apple logo and the login screen., so I can tell that the OS is booting fine.

If I boot from EFI on USB to Clover bootscreen and then select "Boot Mac OS X from MacHD", it boots just fine without dimming the display.

I tried reinstalling Clover UEFI bootloader and kexts from ProBook Installer and rebuild cache with kext wizard but all that did not help. My display still dims to total dark after the Clover boot screen.

I have attached my IOReg. View attachment HP ProBook.ioreg. Any and all help is appreciated. Thank you
 
Joined
Nov 27, 2013
Messages
13
Mac
Classic Mac
Mobile Phone
Here is a video of my boot process. You can see the screen goes dark and stays that way ... but in the background the OS is continuing to boot.
 

Attachments

  • BootVideo.zip
    1.3 MB · Views: 85

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have similar problem. I have Yosemite Clover EFI installed on ProBook 4540s for the last 5 months. This past week, right after Clover bootscreen, the screen dims to almost dark. I can still see a faint outline of the apple logo and the login screen., so I can tell that the OS is booting fine.

If I boot from EFI on USB to Clover bootscreen and then select "Boot Mac OS X from MacHD", it boots just fine without dimming the display.

I tried reinstalling Clover UEFI bootloader and kexts from ProBook Installer and rebuild cache with kext wizard but all that did not help. My display still dims to total dark after the Clover boot screen.

I have attached my IOReg. View attachment 137923. Any and all help is appreciated. Thank you

You did not follow the guide.

http://www.tonymacx86.com/hp-proboo...-install-yosemite-hp-laptops-clover-uefi.html
 
Joined
Nov 27, 2013
Messages
13
Mac
Classic Mac
Mobile Phone
I have been using Yosemite and it has been working for the last five months! Why do you say that I did not follow the instructions? If I did not follow instructions how did it work for the last five months?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have been using Yosemite and it has been working for the last five months! Why do you say that I did not follow the instructions?

Your ioreg shows everything.

DSDT is not patched for brightness control (no PNLF in ioreg, display is AppleDisplay instead of AppleBacklightDisplay).. thus no brightness slider. No brightness controls. Given that you're reporting a problem with internal screen backlight... seems relevant that you haven't implemented it correctly.

DSDT is not patched for IGPU PM (device is still GFX0 instead of IGPU).

GenericUSBXHCI.kext is loaded instead of AppleUSBXHCI.kext. The guide here does not use GenericUSBXHCI.kext on the 4540s.

Patches are not in place for HDMI-audio. The guide here includes patches to make HDMI-audio work.

No DSDT patches for battery, thus no battery status.

Bootlog extracted from ioreg shows no DSDT in ACPI/patched.

There is a guide, that if followed, will work and fix all of the above and probably more problems that I didn't bother looking at.

The guide is here: http://www.tonymacx86.com/hp-proboo...-install-yosemite-hp-laptops-clover-uefi.html

If I did not follow instructions how did it work for the last five months?

I suspect you never tested all the functionality, and therefore didn't realize all that was broken.
 
Joined
Nov 27, 2013
Messages
13
Mac
Classic Mac
Mobile Phone
Thank you for the direction.

I will try to patch DSDT and see if that fixes the issues ... thank you ... appreciate you taking the time to look through the IOReg.

Thank you.
 
Status
Not open for further replies.
Top