Contribute
Register

problems, workarounds and more on Lenovo Legion y530 for 10.13 and 10.14

Joined
Jun 7, 2015
Messages
31
Motherboard
XPS 9570
CPU
i5-8400H
Graphics
HD630
Mac
MacBook Air
Mobile Phone
Android
I fixed a while ago but I didn't post it.

The usb gave me a lot of problems but I was capable to boot without the usb.
1. install clover and check. Themes are Black green Moody
View attachment 349748
View attachment 349749
View attachment 349750
2. After Clover Installation Merge the Clover Folder from USB installer to your System(partition EFI) Clover Folder
3. Add HFS+.efi or Apfs.efi to UEFI64 to be able to read your SSD or USB (depending whether you above the APFS or not)
3. Install Kext needed on L/E (you might need install FAKE SMC and VodooController.kext (green=kext needed to spoof to KBL, gray = kext needed to your System)
View attachment 349751
4. To spoof your CFL to KBL read> https://www.tonymacx86.com/threads/...heeelp-legion-y530.259105/page-8#post-1803635

NOTE> You may also want (I recommended) not use USB to install OSX, better use SSD. NVMe gave me a lot of problems too.
Hey, glad you sorted out the thing!
Could you maybe post a summary of what is working and what is not for users who want to Hackintosh their Y530?
Could you also tell about Wi-Fi card. Did you replace yours? Does BIOS have card whitelist or no whitelist as in Y520?
Thanks in advance
 
Joined
Sep 20, 2012
Messages
50
Motherboard
MSI GE72 2QF
CPU
i7-5700HQ
Graphics
HD 5600, FHD
Mobile Phone
Android, iOS
I fixed a while ago but I didn't post it.

The usb gave me a lot of problems but I was capable to boot without the usb.
1. install clover and check. Themes are Black green Moody
View attachment 349748
View attachment 349749
View attachment 349750
2. After Clover Installation Merge the Clover Folder from USB installer to your System(partition EFI) Clover Folder
3. Add HFS+.efi or Apfs.efi to UEFI64 to be able to read your SSD or USB (depending whether you above the APFS or not)
3. Install Kext needed on L/E (you might need install FAKE SMC and VodooController.kext (green=kext needed to spoof to KBL, gray = kext needed to your System)
View attachment 349751
4. To spoof your CFL to KBL read> https://www.tonymacx86.com/threads/...heeelp-legion-y530.259105/page-8#post-1803635

NOTE> You may also want (I recommended) not use USB to install OSX, better use SSD. NVMe gave me a lot of problems too.
Thank you for this. Can you share your clover folder?
 
Joined
May 20, 2017
Messages
438
Motherboard
HP ENVY TS 14
CPU
i5-4200u
Graphics
HD 4400
Mobile Phone
Android
Hey, glad you sorted out the thing!
Could you maybe post a summary of what is working and what is not for users who want to Hackintosh their Y530?
Could you also tell about Wi-Fi card. Did you replace yours? Does BIOS have card whitelist or no whitelist as in Y520?
Thanks in advance

Hi. Yes
Working
graphics
Keyboard
USB
Charger
Appstore
Dual booting
Ethernet

Not working
Back light. The screen light is very very low. To see something you must use an HDMI (If yours work) or Remote desktop (I use Apple's remote desktop).
HDMI
battery icon
Bluetooth
WiFi (I used a WiFi USB)
Trackpad / touchpad

//////

I don't understand this
Does BIOS have card whitelist or no whitelist as in Y520?
You should read very carefully this
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Last edited:
Joined
Jan 23, 2019
Messages
166
Motherboard
LENOVO Legion-Y530
CPU
i5-8300H/HM370
Graphics
GTX 1050, UHD 630 1920 x 1080
Mobile Phone
Android
Hi. Yes
Working
graphics
Keyboard
USB
Charger
Appstore
Dual booting
Ethernet

Not working
Back light. The screen light is very very low. To see something you must use an HDMI (If yours work) or Remote desktop (I use Apple's remote desktop).
HDMI
battery icon
Bluetooth
WiFi (I used a WiFi USB)
Trackpad / touchpad

//////

I don't understand this


You should read very carefully this
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Hello,
I have EXACTLY SAME configuration like you. (Lenovo Legion y530)
Everything is same, except have 128 GB SSD + 1 TB HDD.

I have Windows installed on SSD.
Can you tell me, which steps did you follow to get this working?
Actually, I am new to this world, so....

Thanks.
 
Joined
May 20, 2017
Messages
438
Motherboard
HP ENVY TS 14
CPU
i5-4200u
Graphics
HD 4400
Mobile Phone
Android
Hello,
I have EXACTLY SAME configuration like you. (Lenovo Legion y530)
Everything is same, except have 128 GB SSD + 1 TB HDD.

I have Windows installed on SSD.
Can you tell me, which steps did you follow to get this working?
Actually, I am new to this world, so....

Thanks.
Hello, i haven't fix it yet. i am waiting to see if a new update from @RehabMan can help me whit it.
 
Joined
Jan 23, 2019
Messages
166
Motherboard
LENOVO Legion-Y530
CPU
i5-8300H/HM370
Graphics
GTX 1050, UHD 630 1920 x 1080
Mobile Phone
Android
@RaviKavaiya Are you trying to install 10.13 or 10.14?
High Sierra. Because, I heard that Mojave doesn't work well with nVIDIA.
I don't want to face problems regarding this.

BTW, what about you? HS or mojave?
 
Joined
Jan 23, 2019
Messages
166
Motherboard
LENOVO Legion-Y530
CPU
i5-8300H/HM370
Graphics
GTX 1050, UHD 630 1920 x 1080
Mobile Phone
Android
Top