Contribute
Register

Problems with z87n - low geekbench no sleep no ethernet

Status
Not open for further replies.
Joined
Aug 20, 2010
Messages
100
Motherboard
Z370N
CPU
i7-8700K
Graphics
RX 580
Hi everyone,

I was hoping this would be an easy install but there are lots of issues.

Hardware:
Z87N
i7-4771
GTX 670

install:
unibeast 2.1.1, multibeast 5.5.3

Issues:
-intel ethernet not working, not recognized at all. oddly it does work on first entering desktop after install, after that nothing I do can get it back. tried atheros ethernet, works fine.
-sleep not working (display turns off but fans keep spinning, can't wake)
-boot issues. hanging on [PCI configuration begin] or FakeSMC loaded. after experimenting fixed this with boot flag npci=0x3000
-low geekbench score. 3.6ghz i7-4771 scores ~8300 the same as my sandy bridge i5-2400 at 3.2 ghz. tried mac pro 3,1 and imac 12,2 smbios. Can see turbo up to 3.8

Should I try a DSDT? Or should I wait for an updated SMBIOS from the newer haswell imacs? I noticed iMac 14,2 has the same CPU. Otherwise I'm not sure where to begin to try to fix these things.

thanks in advance for any help!

UPDATE:
updated to Mavericks, smbios iMac 14,2
geekbench ~10000, seems more appropriate, although still a bit low. didn't try sleep. ethernet still not working, doesn't show up as connected in BIOS so i'm suspecting bad hardware. it does show up in DCPImanager though, just cant get the machine to use it in any way.
anyway, glad this build is shaping up!

UPDATE 2:
EVERYTHING WORKS NOW!! yayyyy!
wiped everything. reset BIOS. re-created Mavericks Unibeast stick. reinstalled. everything was up and running in 30 minutes! Sleep, ethernet, Geekbench of 14000 (same as iMac with same CPU - i7-4771)
 
Joined
Oct 29, 2013
Messages
5
Motherboard
MacBook Pro
CPU
i7
Graphics
onboard
Mac
Classic Mac
Mobile Phone
I'm attempting a very similar build. Gigabyte Z87N-WIFI motherboard with Intel i7-4471 processor, built in graphics.

My plan is to build 6 of these as a small render farm. This is my first mackintosh to build and I'm not fearing I bit off too much to understand. The Z87n BIOS doesn't use the same terminology as most of the information on this website.

I was hoping to run Mountain Lion, but could also run Mavericks if that is the only way to get this to work. But there are currently issues running C4D on Mavericks and wanted to avoid that.

Could you please post detailed instructions on what you did to make it work? Especially the BIOS settings?

Thanks in advance,
Terry
 
Joined
Dec 26, 2013
Messages
71
Motherboard
GA-Z87N-WIFI 10.9.4
CPU
3.8 GHz Intel Core i5 4670k
Graphics
NVIDIA GeForce GTX 660 2047 MB
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
What did you select in MB for your sleep to work? My computer sleeps fine but wake will freeze everything and when I leave my comp alone it will execute sleep (with preferences off) and shut down
 
Status
Not open for further replies.
Top