Contribute
Register

Problem with Asus X99-A-USB3.1 Mobo + Clover setup

Joined
Jan 19, 2015
Messages
94
Motherboard
Asus X99A-USB3
CPU
Intel Core i7-6850K
Graphics
Asus Strix 970
Sorry that I made a mistake to post here, please help me to move this thread to yeosemeti support forum outside.

Greetings.I've started a new build for my next Hackintosh workstation. For my last build went very well with Clover, so I decide to stick to it as well.My spec:
  • Xeon E5-v3 2670 12 Cores
  • Asus X99-A-USB31
  • Kingston Fury DDR4 2133 8GB x 4
  • Asus Geforce 970 Strix
  • Samsung SM951 AHCI 256GB
What I've done:1. install clover to USB installer's EFI partiion.2. use basic config.plist3. boot and try to install via USB installerProblem 1: always `PCI configuration begins` even with `npci=0x2000`, solved with `cpus=1`Problem 2: `AppleUSBEHCI:: unable to get filterInterruptEventSource`Attempt 1: I've tried to boot with `GenericUSBXHCI.kext`, however the problem persists.Attempt 2: Tried all usb options provided by Clover, but no luck.Attempt 3: Googled about the usb error and found out it's about IRQ. ; Althought it's suggested to use custom DSDT.aml, it seems difficult to extract and modify DSDT before booting to the desktop. Or is it the only solution?I understand there will be a lot of troubles with X99 build, but still cannot help to challenge it and save a lot money by not buying the expensive and out-dated MacPro. Any help is appreciated. Thanks!

View attachment config.plist
 
Joined
Jan 26, 2014
Messages
1,348
Motherboard
Asus P5LP-LE
CPU
Core 2 Duo
Graphics
Nvidia GeForce GT 640
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Greetings.

I've started a new build for my next Hackintosh workstation. For my last build went very well with Clover, so I decide to stick to it as well.

My spec:

  • Xeon E5-v3 2670 12 Cores
  • Asus X99-A-USB31
  • Kingston Fury DDR4 2133 8GB x 4
  • Asus Geforce 970 Strix
  • Samsung SM951 AHCI 256GB


What I've done:

1. install clover to USB installer's EFI partiion.
2. use basic config.plist
3. boot and try to install via USB installer


Problem 1: always `PCI configuration begins` even with `npci=0x2000`, solved with `cpus=1`

Problem 2: `AppleUSBEHCI:: unable to get filterInterruptEventSource`

Attempt 1: I've tried to boot with `GenericUSBXHCI.kext`, however the problem persists.
Attempt 2: Tried all usb options provided by Clover, but no luck.
Attempt 3: Googled about the usb error and found out it's about IRQ. ; Althought it's suggested to use custom DSDT.aml, it seems difficult to extract and modify DSDT before booting to the desktop. Or is it the only solution?


I understand there will be a lot of troubles with X99 build, but still cannot help to challenge it and save a lot money by not buying the expensive and out-dated MacPro.

Any help is appreciated.

Thanks!

View attachment 140103
The problem is no has haswell-e support in the kernel clover can auto patch this for you edit your config plist on your installer with clover configurator and check the haswell-e kernel patch check box save it then try to boot up
 
Joined
Jan 19, 2015
Messages
94
Motherboard
Asus X99A-USB3
CPU
Intel Core i7-6850K
Graphics
Asus Strix 970
Of course I used haswell-e patch. See configure.plist
 
Joined
Sep 9, 2011
Messages
1
Motherboard
Asus X99-A-USB 3.1
CPU
Intel Core i7 5820k Haswell-E
Graphics
EVGA Geforce GTX 950
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Sorry that I made a mistake to post here, please help me to move this thread to yeosemeti support forum outside.

Greetings.I've started a new build for my next Hackintosh workstation. For my last build went very well with Clover, so I decide to stick to it as well.My spec:
  • Xeon E5-v3 2670 12 Cores
  • Asus X99-A-USB31
  • Kingston Fury DDR4 2133 8GB x 4
  • Asus Geforce 970 Strix
  • Samsung SM951 AHCI 256GB
What I've done:1. install clover to USB installer's EFI partiion.2. use basic config.plist3. boot and try to install via USB installerProblem 1: always `PCI configuration begins` even with `npci=0x2000`, solved with `cpus=1`Problem 2: `AppleUSBEHCI:: unable to get filterInterruptEventSource`Attempt 1: I've tried to boot with `GenericUSBXHCI.kext`, however the problem persists.Attempt 2: Tried all usb options provided by Clover, but no luck.Attempt 3: Googled about the usb error and found out it's about IRQ. ; Althought it's suggested to use custom DSDT.aml, it seems difficult to extract and modify DSDT before booting to the desktop. Or is it the only solution?I understand there will be a lot of troubles with X99 build, but still cannot help to challenge it and save a lot money by not buying the expensive and out-dated MacPro. Any help is appreciated. Thanks!

View attachment 140103


Did you ever get your setup to work properly? Mine is very similar to yours (except for the processor) and I'm still having tons of problems. Could you share your config.plist settings and efi driver setup? Thank you!
 
Joined
Mar 18, 2011
Messages
11
Motherboard
Asus Rampage IV Extreme
CPU
i7-3930k
Graphics
GTX 580 3 gigs
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Hello,

I have the same exact motherboard, here is what I type for the boot flags when booting using Unibeast USB installer.
It works perfectly, this is for 10.10.5, you may not need "debug=0x14e" when booting for 10.10.2.

Hope this helps:

nv_disable=1 npci=0x3000 kext-dev-mode=1 debug=0x14e
 
Top