Contribute
Register
Status
Not open for further replies.
Joined
Sep 6, 2013
Messages
61
Motherboard
Asus Z370-E Gaming
CPU
i7 8700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
For the purposes of this post, here are my current settings:

GPU (Vega 56) and IGPU (Intel HD 630) are enabled in BIOS
PCIE (Vega 56) is primary display (connected to monitor)
Inject Intel disabled in Clover (prevents use of IGPU in Final Cut Pro X)
Lilu and Whatevergreen kexts installed (previewing/opening jpegs)

When using Final Cut Pro X (FCPX), and Inject Intel is enabled in Clover, FCPX prioritizes the IGPU for rendering which drastically increases the rendering time. Having the IGPU enabled should also have the benefit for QuickSync encoding in Handbrake. The problem is, when the IGPU is active, it gets prioritized over the GPU.

Right now, I have to enable the IGPU in the BIOS, but have Inject Intel disabled to be able to open or preview jpegs (that I know of). I discovered this when trying to add movie title covers to ripped bluray files. The HD 630 shows up as a device, but does not function when performing benchmarks, etc. When I enable it, it overrides the Vega.

Is there a way to have both the GPU and IGPU active, but have the GPU be the first device or prioritized device? Would FCPX and other programs use both if both were active in this way? When I select to use my CPU and GPU in benchmarks, my results are improved, so hopefully the same benefit can be realized if the GPU and IGPU can be enabled and prioritized properly.
 
Joined
Mar 30, 2018
Messages
12
Motherboard
Gigabyte Z390 M Gaming
CPU
i7-8700K
Graphics
Vega 56
I used FCPX on an 8600k and RX580, iGPU enabled. Everything seems to work OK. It isn't super slow or super fast. I edit with proxys.
 

Attachments

  • 43283075_10101998135736809_7154624639858114560_o.jpg
    43283075_10101998135736809_7154624639858114560_o.jpg
    613.5 KB · Views: 137
Joined
Aug 23, 2012
Messages
23
Motherboard
Gigabyte GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
For the purposes of this post, here are my current settings:

GPU (Vega 56) and IGPU (Intel HD 630) are enabled in BIOS
PCIE (Vega 56) is primary display (connected to monitor)
Inject Intel disabled in Clover (prevents use of IGPU in Final Cut Pro X)
Lilu and Whatevergreen kexts installed (previewing/opening jpegs)

When using Final Cut Pro X (FCPX), and Inject Intel is enabled in Clover, FCPX prioritizes the IGPU for rendering which drastically increases the rendering time. Having the IGPU enabled should also have the benefit for QuickSync encoding in Handbrake. The problem is, when the IGPU is active, it gets prioritized over the GPU.

Right now, I have to enable the IGPU in the BIOS, but have Inject Intel disabled to be able to open or preview jpegs (that I know of). I discovered this when trying to add movie title covers to ripped bluray files. The HD 630 shows up as a device, but does not function when performing benchmarks, etc. When I enable it, it overrides the Vega.

Is there a way to have both the GPU and IGPU active, but have the GPU be the first device or prioritized device? Would FCPX and other programs use both if both were active in this way? When I select to use my CPU and GPU in benchmarks, my results are improved, so hopefully the same benefit can be realized if the GPU and IGPU can be enabled and prioritized properly.
Hi, were you able to solve the problem? I have the same issue on my old HW. Fcpx right now uses IGPU only during export. :( But it should use both GPU's. Thanks in advance for your help!
 
Status
Not open for further replies.
Top