Contribute
Register

Powercore PCI Mkii DSP cards & Mavericks 10.9.2

Joined
Aug 24, 2011
Messages
30
Motherboard
Sabertooth X79
CPU
i7-4820K
Graphics
NVIDIA GTX 760 2 ddr5
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Hi

Thanks to you guys again I have a customac Pro6.1

Powercore PCI MKII cards... no doubt most people have moved on from PCIx however if you want to use your non supported TC Powercore PCI MKII card under Mavericks its not as simple as rolling back ACPIPlantform.kext and there have been some changes in IOPCIFamily.kext.

If you install ACPIPlatform.kext from 10.8 or 10.7 the powercore controller panel can't connect to the card but the card is seen by the OS.

If you install IOPCIFamilykext from 10.8 or 10.7 the powercore controller panel can't connect to the card.

if you install SMC_PCI, SMBIOS, AHCI, IOPCI and related kext from 10.7 and 10.8 the powercore control panel can connect to the card. (i'm doing this from memory so the exact names of the kext aren't perfect but hit me up when i'm at home and ill zip them up and send them) I suspect its SMC_PCI and IOPCI where the changes are))

I've tried different Kext combinations from 10.7,8 and 9 and encountered "OS version not set" or a freeze during boot.

Still on the case but if anyone no's someone trying to get the card working, quick fix here... This is purely a driver issue which is no longer supported by TC electronics which is a shame.

cheers Jeff
-----------------------------------------------------
Asus Sabretooth X79 i7-4820 Ivy-bridge 3.7 Nvidia 760
CPU PWM, GPU PWM,Stepping, turbo etc working!!
 
Joined
Nov 16, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
Hi Jeff

Did you succeed in tweaking the kexts? Are there any news?
I've got my PCIe PC and 9.2 and I want my VSS3 back! )))

Andrei
 
Joined
Aug 24, 2011
Messages
30
Motherboard
Sabertooth X79
CPU
i7-4820K
Graphics
NVIDIA GTX 760 2 ddr5
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
No I tried but with not luck, only way to get it working was to roll back to ML kext relating to PCI. Major changes in IOPCIFamily...

all the best
 
Joined
Aug 24, 2011
Messages
30
Motherboard
Sabertooth X79
CPU
i7-4820K
Graphics
NVIDIA GTX 760 2 ddr5
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Hi attached a screen shot of powercore working. showing powercore control panel connected to both PCIx (PCI MkII) and PCIe (PCI Express) Version of OS and the powercore kext state as loaded. Also filtered bootlog..

ML PCIx Enabler :D kext list to your right

cheers
 

Attachments

  • Screen Shot 2014-05-17 at 01.50.59.jpg
    Screen Shot 2014-05-17 at 01.50.59.jpg
    254.6 KB · Views: 1,211
Joined
Nov 4, 2011
Messages
1
Motherboard
Mac OS X 10.6.8
CPU
2.67 GHz Intel Core 2 Duo
Graphics
nVidia GeForce GTX 285
Mac
Classic Mac
Mobile Phone
Hi muwookie! That's awesome! How could you determine which kexts are required for PowerCore to function correctly?
 
Joined
Jun 30, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
Can you provide us those kexts?
or at least tell us which version of ML they came from?

Thanx and Greetinz

Alex
 
Joined
Jul 21, 2014
Messages
6
Mac
Classic Mac
Mobile Phone
my Mk1 (PCI/Element) cards work under 10.9.4 but i have issues after wake (powercores show as "device not recognised" even after reboot and needs full power cycle. ie unplug power cable for a few seconds and reconnect

or when closing down projects and reopening eg in reaper, plugins sometimes not getting reloaded properly and appearing as disabled

any likely fix for that?

I know someone fixed Envy24 drivers so they inited properly on sleep/wake. maybe code there would be useful?

(Fogel's version works.. http://www.tonymacx86.com/audio/721...-mountain-lion-sleep-64-bit-4.html#post493156 . dragem's update doesnt.. causes system to freeze again)

thanks!
j
 
Joined
Oct 13, 2011
Messages
22
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7 4770K
Graphics
Nvidia GT610
Mac
  1. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hi attached a screen shot of powercore working. showing powercore control panel connected to both PCIx (PCI MkII) and PCIe (PCI Express) Version of OS and the powercore kext state as loaded. Also filtered bootlog..

ML PCIx Enabler :D kext list to your right

cheers

Hi
I'm on Mountain Lion and my PoCo PCIMK2's are not being seen but my PoCo firewire is and working perfectly.
Could you provide me with the correct kexts to get the cards working please?

Many thanks !
 
Joined
Oct 8, 2014
Messages
1
Motherboard
10.9.5
CPU
3.33Ghz 6 Core
Mac
Classic Mac
Mobile Phone
I have just upgraded my computer to a Mac Pro 3.33Ghz 6 Core running OSX 10.9.5 and I am having this issue with my powercore Mkii.

Can you give me clear instructions on how to fix it, so the card can be recognised? I am not savvy when it comes to going under the hood and would really appreciate the walk through and your help.

Many thanks.
 
Joined
Dec 7, 2011
Messages
11
Motherboard
GA-H270-HD3
CPU
i7-7700K
Graphics
HD 630
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi attached a screen shot of powercore working. showing powercore control panel connected to both PCIx (PCI MkII) and PCIe (PCI Express) Version of OS and the powercore kext state as loaded. Also filtered bootlog..

ML PCIx Enabler :D kext list to your right

cheers

Same problem in Yosemite... Please what kext did you used???
 
Top