Power Mac G4 Cube Intel Reloaded Edition - my 2nd Hackintosh Case Mod

Discussion in 'PowerMac G4 Cube' started by MacTester57, Nov 3, 2012.

  1. ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Dec 6, 2014 at 5:31 PM #241
    ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Thx for the input, minihack. I have tried over and over but no go. The azul kext may be the culprit, but at this point I'm not prepared to waste any more time on it. 10.10.2 is likely coming soon so will hope that solves it.


    Cheers!
     
  2. minihack

    minihack

    Joined:
    May 27, 2010
    Messages:
    2,384
    Mobo:
    Zotac Z77-ITX
    CPU:
    i5 2500k
    Graphics:
    Integrated HD 3000 + MSI Twin Frozr GTX 660
    Mac:
    MacBook Air
    Classic Mac:
    iMac
    Mobile Phone:
    Other
    Dec 7, 2014 at 1:39 PM #242
    minihack

    minihack

    Joined:
    May 27, 2010
    Messages:
    2,384
    Mobo:
    Zotac Z77-ITX
    CPU:
    i5 2500k
    Graphics:
    Integrated HD 3000 + MSI Twin Frozr GTX 660
    Mac:
    MacBook Air
    Classic Mac:
    iMac
    Mobile Phone:
    Other
    :)

    No prob.s.

    Just as reference, I am currently using the alternative frame buffer for the Azul kext ( 0x0A, 0x00, 0x26, 0x0A) not the default (0x03, 0x00, 0x22, 0x0D ). This alternative is 'officially' an HD 5000 frame buffer, whereas the default one is an HD 4600 frame buffer - whether that makes any difference I don't really know as once I have found something that works for my situation I tend to stop looking....
     
  3. MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    Dec 9, 2014 at 4:26 PM #243
    MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    Hi ersterhernd,

    My ACD 27" works fine with 10.10.1 and the stock framebuffer. Is your Video Memory set to 64MB in the BIOS? I guess that your DSDT may be the culprit. My DSDT has the following patches:
    Toleda:
    -AMI-Clean_Compile-7-series

    PJALM:
    -SMBUS

    Sourceforge:
    -DTGP
    -HD4k GFX

    RehabMan:
    -[usb] 7-series/8-series USB
    -[usb] 7-series USB3 Multiplex

    Good luck

    MacTester
     
  4. ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Dec 11, 2014 at 6:48 PM #244
    ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Can u post the dsdt MacTester ?

    Maybe it will work.


    Cheers!
     
  5. MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    Dec 11, 2014 at 8:20 PM #245
    MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    Hi Ersterhernd

    Here are my DSDT & SSDT. Good luck.

    Gruss
    MacTester
     

    Attached Files:

  6. ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Dec 12, 2014 at 1:20 PM #246
    ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Thanks MacTester, will give this a try on the weekend.


    Cheers!
     
  7. MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    Dec 16, 2014 at 8:03 PM #247
    MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    Hi ersterhernd,

    I hope it did work?

    On another note. My Magic Mouse does now work much smoother, after I've removed GenericUSBXHCI.kext and applied RehabMan's USB fixes in my DSDT.

    Cheers!
     
  8. ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Dec 23, 2014 at 3:56 AM #248
    ersterhernd

    ersterhernd

    Joined:
    Nov 25, 2010
    Messages:
    1,201
    Mobo:
    MSI Z77MA-G45
    CPU:
    i7-3770k @ 4.3 GHz
    Graphics:
    Gigabyte R9 280X Windforce 3GB
    Mobile Phone:
    Android
    Nope, Mactester it did not. I didn't update to 10.10.1 but rather just tried booting to a 10.10.1 USB installer stick. It hung, no matter what I tried...

    Alas.
     
  9. pep_one

    pep_one

    Joined:
    Mar 29, 2011
    Messages:
    39
    Mobo:
    10.6.8
    CPU:
    Core 2 Duo T5550
    Graphics:
    Intel X3100
    Mac:
    MacBook, Mac Pro
    Classic Mac:
    Classic, iMac, LC, Power Mac
    Mobile Phone:
    iOS
    Jan 7, 2015 at 10:39 AM #249
    pep_one

    pep_one

    Joined:
    Mar 29, 2011
    Messages:
    39
    Mobo:
    10.6.8
    CPU:
    Core 2 Duo T5550
    Graphics:
    Intel X3100
    Mac:
    MacBook, Mac Pro
    Classic Mac:
    Classic, iMac, LC, Power Mac
    Mobile Phone:
    iOS
    Hi MacTester57,
    I've tried to install Yosemite with clover boot manager, but I have many issues and, last but not least ,a problem to my 2TB data hardisk :( Now I try to rescue data (with ddrescue) to new hdd.
    So, I reinstall Yosemite with unibeast approach. I have an Intel core i3-3225, so your DSDT cause me KP, then I've recreated it with the same patch you have selected. I resolve graphics glitch with ersterhernd method.
    Now I have too many problems with SSDT! When I put "DropSSDT=Yes" option in org.chamaleon.boot.plist, the boot hang on immediately at "Decompressing Kernel using lzvn" line

    I tried to remove "UseKernelCache=Yes" from org.chamaleon.boot.plist, and the boot goes beyond last error, but give me KP

    If I remove "DropSSDT" option, the system boot normally but I think that power management is not optimal, even if hwsensor reveal frequency change.
    I don't understand very well the XCPM matter... I have the 0051 patched bios from the beginning and I've patched the AppleIntelCPUPowerManagement.kext too.
    Can you help me with these issues?
    Thank you so much!
     
  10. MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    Jan 7, 2015 at 8:07 PM #250
    MacTester57

    MacTester57

    Joined:
    Dec 15, 2011
    Messages:
    907
    Mobo:
    Z68MX-UD2H-B3, DQ77KB, NUC DC53427HYE, NUC D54250WYKH
    CPU:
    i5-2500K, i3-3225, i7-3770S
    Graphics:
    HD 3000, HD 4000, HD 5000
    Classic Mac:
    iMac, Power Mac
    Mobile Phone:
    iOS
    The DSDT is CPU independent.

    My cube runs perfectly on Yosemite. Clover is installed in legacy mode. No XCPM is activated. I would suggest to start in save mode, with my last posted DSDT. Then generate a new SSDT with: https://github.com/Piker-Alpha/ssdtPRGen.sh

    Try the attached Clover config.plist

    Good luck
    MacTester
     

    Attached Files:

Share This Page