Contribute
Register

Power Consumption

Joined
Dec 10, 2013
Messages
150
Motherboard
Huawei Matebook D 2017
CPU
i5-7200U
Graphics
HD 620
Hi guys,
here is the issue :

After a fresh boot my laptop power consuming according to Intel Power Gadget at idle PKG 0.8 as showed in the screenshot i took attached to this post.
But after the laptop goes to sleep and wake up the Intel Power Gadget shows PKG at idle is 1.3 and never goes lower than that.
I don't see any processes after sleep that are using more cpu than before sleep. I tried to disable most of my kext (AppleALC, bluetooth , wifi etc) but i've always the same result. Could be some CPU power state that got "broken" after sleep ?

Could someone point me in the right direction ?

Thanks
Mattia
 

Attachments

Joined
Dec 10, 2013
Messages
150
Motherboard
Huawei Matebook D 2017
CPU
i5-7200U
Graphics
HD 620
Hi guys,
just to inform you i've solved my issue. I was using platform id : 0x59260002 to solve HiDPI graphical glitches after sleep and this was causing the problem. I've solved it spoofing Skylake platform id as per rehabman config.plist (platform id 0x19260002). Now everything is ok.
Mattia
 
Joined
Apr 6, 2019
Messages
1
Motherboard
Huawei Matebook D 2018
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
iMac
Mobile Phone
Android
Hi guys,
just to inform you i've solved my issue. I was using platform id : 0x59260002 to solve HiDPI graphical glitches after sleep and this was causing the problem. I've solved it spoofing Skylake platform id as per rehabman config.plist (platform id 0x19260002). Now everything is ok.
Mattia
Hi Mattia
I've the same laptop than you.
Could you share your efi folder?
Thank you in advance
 
Joined
Dec 10, 2013
Messages
150
Motherboard
Huawei Matebook D 2017
CPU
i5-7200U
Graphics
HD 620
Hi Mattia
I've the same laptop than you.
Could you share your efi folder?
Thank you in advance
Hi, i can share it without problems but you've the 2018 model which has an i5 8th generation cpu while i've an i5 7th generation cpu so i don't think it's a good idea... Also all my kexts are in /Library/Extensions folder and not in /Clover/kext/Other .. maybe is a better idea to check what's not working in your hackintosh and fix it ?
 
Joined
Dec 10, 2013
Messages
150
Motherboard
Huawei Matebook D 2017
CPU
i5-7200U
Graphics
HD 620
I am also facing an increase in CPU power consumption after sleep in addition to no sound after sleep. I have changed the ig-platform id, but that did not help. If anyone can help I would be grateful.
Hi,
first of all i'm not an expert ... that said ...

About the audio issue maybe you need CodecCommander + the correct aml (it depends on your audio chip) from codecCommander repository. Also you're injecting Layoutid 1. Are you sure about that value ? You could try some other id for your audio codec. Usually if the Layout id is not correct AppleALC use more resources after sleep and that could lead you to the cpu power consumption. If you tell me your audio codec model i can check for you which id you can use.

About the CPU power consumption you should check Activity monitor if you can see the process who is consuming more than before the sleep.

Mattia
 
Joined
Jan 20, 2011
Messages
101
Motherboard
HP Envy X360 15m-CN00xx
CPU
i5-8250U
Graphics
HD 620
Mobile Phone
iOS
Hi Mattia,
I am using appleALC for audio, the latest appleALC kext has codeccommander sleep fix per toledo.
AppleALC includes the CodecCommander sleep fix.
as for the layout-id, I did use a couple different ones to no avail.
I did look at devices that were consuming energy from activity monitor, found nothing out of the ordinary after sleep. I will try to resolve the sound after sleep issue to see if that has any effect on the power consumption after sleep.

thank you for your help.
 
Top