Contribute
Register

PostSetup Lenovo ideapad 310-15ISK questions

Joined
Apr 9, 2020
Messages
18
Motherboard
Lenovo ideapad 310-15ISK - 2.8 - Clover UEFI
CPU
i3-6006U
Graphics
Intel HD Graphics 520 1366 x 768
Hello tonymacx86 community!
I'm new to hackintosh and really into it, so I decided to install it on my laptop. I was searching a proper variant of config.plist for ages) (maby). Finally I managed to install it and boot. (ya h oooo!!!!!) But I am stuck now into another problems) Firstly I went with plist, provided by ideapad user, installed kexts for battery, voodooHDA, graphics fix for intel and so on. And at this time I have only ehernet (realtek 8111) working. To fix graphics (only 4 mb and artefacts) I tried a special plist for HD520, tried to make injects if IDs. Now Im trying to sort out what Ive done wrong. All is mixed up in my head. Please, be so kind, help me with post install routine, I just cant choose the correct variant of solving my problems. debug files are attached to post. Thank YOU in advance! Best regards.
 

Attachments

  • debug_16409.zip
    3.3 MB · Views: 10

Feartech

Moderator
Joined
Aug 3, 2013
Messages
19,500
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello tonymacx86 community!
I'm new to hackintosh and really into it, so I decided to install it on my laptop. I was searching a proper variant of config.plist for ages) (maby). Finally I managed to install it and boot. (ya h oooo!!!!!) But I am stuck now into another problems) Firstly I went with plist, provided by ideapad user, installed kexts for battery, voodooHDA, graphics fix for intel and so on. And at this time I have only ehernet (realtek 8111) working. To fix graphics (only 4 mb and artefacts) I tried a special plist for HD520, tried to make injects if IDs. Now Im trying to sort out what Ive done wrong. All is mixed up in my head. Please, be so kind, help me with post install routine, I just cant choose the correct variant of solving my problems. debug files are attached to post. Thank YOU in advance! Best regards.
 
Joined
Apr 9, 2020
Messages
18
Motherboard
Lenovo ideapad 310-15ISK - 2.8 - Clover UEFI
CPU
i3-6006U
Graphics
Intel HD Graphics 520 1366 x 768
Thank you!

I started with fixing my video(LILU+WEG)
I cant find the exact SMBIOS ID to do patching, so I have chosen the closest to mine (as in guide) - HD530 MacBookPro13,3 - screenshot attached
then generated a patch for configWEG plist. (config plist is my original and booting one)
if I insert only SMBIOS model it boots - but no luck.
if I insert SMBIOS ID and Patch (from hackintool) it is not booting at all (apple logo turns on, progress bar goes to appr. 60% and the laptop restarts.

any ideas?
 

Attachments

  • 2020-04-11 в 18.50.38.png
    2020-04-11 в 18.50.38.png
    111 KB · Views: 25
  • 2020-04-11 в 18.52.52.png
    2020-04-11 в 18.52.52.png
    123.5 KB · Views: 31
  • debug_11745.zip
    4.7 MB · Views: 12

Feartech

Moderator
Joined
Aug 3, 2013
Messages
19,500
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thank you!

I started with fixing my video(LILU+WEG)
I cant find the exact SMBIOS ID to do patching, so I have chosen the closest to mine (as in guide) - HD530 MacBookPro13,3 - screenshot attached
then generated a patch for configWEG plist. (config plist is my original and booting one)
if I insert only SMBIOS model it boots - but no luck.
if I insert SMBIOS ID and Patch (from hackintool) it is not booting at all (apple logo turns on, progress bar goes to appr. 60% and the laptop restarts.

any ideas?
MacBookPro13,1 would be a better choice
 
Joined
Apr 9, 2020
Messages
18
Motherboard
Lenovo ideapad 310-15ISK - 2.8 - Clover UEFI
CPU
i3-6006U
Graphics
Intel HD Graphics 520 1366 x 768
MacBookPro13,1 would be a better choice
thx, i will try 13,1 in smbios.
is the patch correct? 13,1 have iris 540... what should I choose in hackingtool when ticking spoof video
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
19,500
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
thx, i will try 13,1 in smbios.
is the patch correct? 13,1 have iris 540... what should I choose in hackingtool when ticking spoof video
this:
Code:
<key>Fixes</key>
            <dict>
                <key>AddDTGP_0001</key>
                <true/>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixRegions_10000000</key>
                <true/>
                <key>FixTMR</key>
                <false/>
                <key>NewWay_80000000</key>
                <true/>
            </dict>

should be:
Code:
<key>Fixes</key>
            <dict>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixTMR</key>
                <true/>
                <key>FixRTC</key>
                <true/>
                <key>FixIPIC</key>
                <true/>
                <key>FixHPET</key>
                <true/>
            </dict>
no need for this:
Code:
    <key>Arbitrary</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>Inject Intel HD properties</string>
                <key>CustomProperties</key>
                <array>
                    <dict>
                        <key>Key</key>
                        <string>subsystem-id</string>
                        <key>Value</key>
                        <data>
                        hoAAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>subsystem-vendor-id</string>
                        <key>Value</key>
                        <data>
                        axAAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>AAPL,ig-platform-id</string>
                        <key>Value</key>
                        <data>
                        AAAWGQ==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>graphic-options</string>
                        <key>Value</key>
                        <data>
                        DAAAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>device-id</string>
                        <key>Value</key>
                        <data>
                        FhkAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>model</string>
                        <key>Value</key>
                        <string>Intel HD Graphics 520</string>
                    </dict>
                </array>
                <key>PciAddr</key>
                <string>00:02.00</string>
            </dict>
        </array>
 
Joined
Apr 9, 2020
Messages
18
Motherboard
Lenovo ideapad 310-15ISK - 2.8 - Clover UEFI
CPU
i3-6006U
Graphics
Intel HD Graphics 520 1366 x 768
this:
Code:
<key>Fixes</key>
            <dict>
                <key>AddDTGP_0001</key>
                <true/>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixRegions_10000000</key>
                <true/>
                <key>FixTMR</key>
                <false/>
                <key>NewWay_80000000</key>
                <true/>
            </dict>

should be:
Code:
<key>Fixes</key>
            <dict>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixTMR</key>
                <true/>
                <key>FixRTC</key>
                <true/>
                <key>FixIPIC</key>
                <true/>
                <key>FixHPET</key>
                <true/>
            </dict>
no need for this:
Code:
    <key>Arbitrary</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>Inject Intel HD properties</string>
                <key>CustomProperties</key>
                <array>
                    <dict>
                        <key>Key</key>
                        <string>subsystem-id</string>
                        <key>Value</key>
                        <data>
                        hoAAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>subsystem-vendor-id</string>
                        <key>Value</key>
                        <data>
                        axAAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>AAPL,ig-platform-id</string>
                        <key>Value</key>
                        <data>
                        AAAWGQ==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>graphic-options</string>
                        <key>Value</key>
                        <data>
                        DAAAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>device-id</string>
                        <key>Value</key>
                        <data>
                        FhkAAA==
                        </data>
                    </dict>
                    <dict>
                        <key>Key</key>
                        <string>model</string>
                        <key>Value</key>
                        <string>Intel HD Graphics 520</string>
                    </dict>
                </array>
                <key>PciAddr</key>
                <string>00:02.00</string>
            </dict>
        </array>
Thank you, but you revised config plis - this is my backup)
I am now booting with configWEG - IT IS IN THIS POST
sorry for messing you up( my fault

now I inserted 13,1 in smbios, corrected fixes like in your post, there is no arbitrary in it.

when booting the attached plist - no luck (the hackingtool patch is commented)
when I remove the comment from patch - no booting(
so is the patch correct?
 

Attachments

  • configWEG.plist
    7.8 KB · Views: 18

Feartech

Moderator
Joined
Aug 3, 2013
Messages
19,500
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thank you, but you revised config plis - this is my backup)
I am now booting with configWEG - IT IS IN THIS POST
sorry for messing you up( my fault

now I inserted 13,1 in smbios, corrected fixes like in your post, there is no arbitrary in it.

when booting the attached plist - no luck (the hackingtool patch is commented)
when I remove the comment from patch - no booting(
so is the patch correct?
i only look at config.plist as that is what clover boots from
 
Joined
Apr 9, 2020
Messages
18
Motherboard
Lenovo ideapad 310-15ISK - 2.8 - Clover UEFI
CPU
i3-6006U
Graphics
Intel HD Graphics 520 1366 x 768
i only look at config.plist as that is what clover boots from
I renamed plist with the latest differences into configWEG, and during boot options in clover I can choose a configWEG plist to use for booting.
I made it to boot from config plist if I cant boot from configWEG...
________________
nevermind.

now I use config from attachment to this post.
what is wrong with it?
if I remove comments from hackintool patch - the system becomes unbootable...
 

Attachments

  • config.plist
    7.8 KB · Views: 22

Feartech

Moderator
Joined
Aug 3, 2013
Messages
19,500
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I renamed plist with the latest differences into configWEG, and during boot options in clover I can choose a configWEG plist to use for booting.
I made it to boot from config plist if I cant boot from configWEG...
________________
nevermind.

now I use config from attachment to this post.
what is wrong with it?
if I remove comments from hackintool patch - the system becomes unbootable...
you have this disabled:
#Properties

remove the #
 
Top