Contribute
Register

possible to enable HD630 with iMacPro1,1 in order to use sidecar?

Status
Not open for further replies.
Joined
Nov 8, 2011
Messages
117
Motherboard
Z390M-ITX/ac
CPU
i7-9700K
Graphics
Vega 64
I have a vega64 and a 9700k on an asrock z390M itx/ac motherboard.

For the last year I have run with igpu (HD630) disabled in bios and it has been good.

Now I have an ipad and I want to use sidecar. When I connect sidecar, it shows only a black screen on ipad.

So I believe need to enable igpu. Whenever I do so, macos 10.15.5 gets stuck on boot.

I have tried injecting ig-platform-id but no change.

Any advice?

debug files attached
 

Attachments

  • debug_2118.zip
    613 KB · Views: 21
Joined
May 29, 2012
Messages
571
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Yes, sidecar won't work correctly with the iGPU disabled.

I had this same problem and I had to patch the framebuffer with my motherboard. Fortunately, a patch for your mobo is listed in CaseySJ's awesome guide! Just scroll to the bottom and he has instructions how to patch it and the patch for your mobo:




I have a vega64 and a 9700k on an asrock z390M itx/ac motherboard.

For the last year I have run with igpu (HD630) disabled in bios and it has been good.

Now I have an ipad and I want to use sidecar. When I connect sidecar, it shows only a black screen on ipad.

So I believe need to enable igpu. Whenever I do so, macos 10.15.5 gets stuck on boot.

I have tried injecting ig-platform-id but no change.

Any advice?

debug files attached
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,700
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
If you want to use Sidecar, change to iMac19,1 and enable IGPU.
 
Status
Not open for further replies.
Top