Contribute
Register

Poor FCPX Performance on My New Build

Joined
Sep 25, 2017
Messages
5
Hi all,

I got my second Hackintosh up and running, and over all it's great! But I just discovered that it's not doing so hot with FCPX. Any ideas?

CPU: Intel i9 9900k 3.6 Ghz (8 cores)
GPU: Sapphire AMD Radeon VII (16 GB VRAM)
Motherboard: Gigabyte Aorus Z390 Master
Power supply: Corsair RM 750x (Purchased months ago when the old supply failed on my old build)
Main system drive: Samsung 850 Evo Pro 256GB (additional SSDs for storage)
OS: 10.14.5 Mojave

Geekbench Results:
411608


And here's what Activity Monitor is displaying when trying to transcode ProRes Raw (6k) proxies:
411609


My old system used an i7 377k, and FCPX was using 80% of it for the same task. It was also performing better than what I'm seeing now.

I've attached my config.plst if anyone wants to take a look.

Kexts:
AppleALC.kext
IntelMausiEthernet.kext
Lilu.kext
SMCBatteryManager.kext
SMCLightSensor.kext
SMCProcessor.kext
SMCSuperIO.kext
USBMap.kext (Created by Carl Mercier for the Aorus Z390 Master)
VirtualSMC.kext
WhateverGreen.kext

Thanks in advance!
 

Attachments

Joined
Nov 3, 2018
Messages
307
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
why did u use shikigva=40? do you know what it means? it changes your iMac19.1 board-id to iMac14,2, you may lose lots of features that iMac19,1 brings.

updated the config.plist, try this one and test again. if you see "++++++++++++" or panic during boot. you have 2 options (only choose one of them)

1. Disable CFG LOCK from BIOS (best choice)
2. Edit the config.plist, check the "KernelPM" box, under kernel and kext Patches. If it boots fine, then you don't need this option.

cheers
 

Attachments

Joined
Sep 25, 2017
Messages
5
Thank you for your help, @justinhe
why did u use shikigva=40? do you know what it means? it changes your iMac19.1 board-id to iMac14,2, you may lose lots of features that iMac19,1 brings.
I did not know that! I probably saw it in a tutorial where it wasn't explained.

I'll circle back with results from using your .plist. My original response had some false info.
 
Joined
Sep 25, 2017
Messages
5
@justinhe Ok! Now I can confirm some things.

I was unable to boot with your .plist.
There doesn't seem to be a CFG LOCK setting in my BIOS. Unfortunately, the internet hasn't been any help in figuring that out.
I tried checking off "KernelPM", and this was the result:
412002


I also tried removing shikivga=40, adding "Change PEGP to GFX0" and "Change GFX0 to IGPU" to my original .plst. No changes to FCPX's rendering performance.
412003


I really appreciate your help! This is my second build, but the first one where I've really had to dive into Clover. Multibeast really did the trick for me 6 years ago.
So much to learn!
 
Joined
Nov 3, 2018
Messages
307
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
Sorry. I think KernelPM is not enough.

I’ve seen another post saying that FCPX performs worse on 10.14.5 than previous build.
 
Joined
Sep 25, 2017
Messages
5
I heard that as well. But this seems a little extreme. Next test will be Adobe software.
 
Top