Contribute
Register

Please help finalize ASUS N551JX-CN043T Intel i7 4720HQ With Mac OS Catalina 10.15.4

Joined
Apr 12, 2016
Messages
15
Motherboard
ASUS N551JX-CN043T
CPU
i7-4720HQ
Graphics
HD 4600 + GTX 950M, 1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android, iOS
I everyone, I'm here asking for help, I have installed Mac os Catalina 10.15.4 on my laptop with the necessary kexts (I believe... I mean.. I'm not 100% sure)

I created a dsdt, I think that I did it the right way, somehow.

I worked around my config with graphics injected from the proprieties tab and boot args.

All looks good after all.

still, I have a couple of issues, so let's get through this together!!!

QUICK LAPTOP INFO:

Product Type: Notebook

Brand: ASUS

Model: N551JX-CN043T

Year Manufacture: 2015

Processor: Intel Core i7 4720HQ

Graphics: Intel HD 4600 mobile (Haswell) + Nvidia GeForce GTX 950m

Audio: Realtek alc668

Wifi/Bluetooth: Qualcomm Atheros ar9485

Ram: 8gb (Extended to 16gb by me)

Hard Drive: 1TB HDD (Replaced by me with 1TB SSD)


CHECK MORE SPECIFIC INFO AT THIS LINK: https://icecat.us/prefere/us/p/vendorName/mpn/desc-30348719.html


PROBLEMS REPORT:

1) When I disconnect the ac adapter from the laptop, everything that is connected to my 3.0 USB port with the bolt icon, so with charge supply option, stops to work for a few seconds.
Which is ok for a Wireless USB mouse, but not good for an external hard drive.

2) The overall performance seems a bit slower than what I was used to when I had Mac os sierra 10.12.6 installed, especially on boot.

3) I have graphic glitches on boot that force me to connect an HDMI cable or wait for the screen to shut off to fix it.
I got rid of this issue with the GUI screen resolution set to 1024x768 but I'm not happy with it.
I didn't have to do this in Sierra, the issue was there on the boot screen for a few seconds and then everything returned to normal right before the login screen popped up.

4) Wifi is weak and Bluetooth is not showing up, not even in the preferences pane but I have a damaged cable that is related to it that it needs to be fixed or replaced so we'll save it for later.

GENERAL HELP REQUEST:
Can you check my EFi and help me diagnose what is causing the problems listed above?
It would be great

SIDE NOTES:

1) Nvidia graphic is not enabled because someone told me that it is not necessary. I don't know, tell me your opinion.

2) I leave my EFI, ioreg file, and dcpi manager screenshots down below. Thanks!!!
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,824
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I everyone, I'm here asking for help, I have installed Mac os Catalina 10.15.4 on my laptop with the necessary kexts (I believe... I mean.. I'm not 100% sure)

I created a dsdt, I think that I did it the right way, somehow.

I worked around my config with graphics injected from the proprieties tab and boot args.

All looks good after all.

still, I have a couple of issues, so let's get through this together!!!

QUICK LAPTOP INFO:

Product Type: Notebook

Brand: ASUS

Model: N551JX-CN043T

Year Manufacture: 2015

Processor: Intel Core i7 4720HQ

Graphics: Intel HD 4600 mobile (Haswell) + Nvidia GeForce GTX 950m

Audio: Realtek alc668

Wifi/Bluetooth: Qualcomm Atheros ar9485

Ram: 8gb (Extended to 16gb by me)

Hard Drive: 1TB HDD (Replaced by me with 1TB SSD)


CHECK MORE SPECIFIC INFO AT THIS LINK: https://icecat.us/prefere/us/p/vendorName/mpn/desc-30348719.html


PROBLEMS REPORT:

1) When I disconnect the ac adapter from the laptop, everything that is connected to my 3.0 USB port with the bolt icon, so with charge supply option, stops to work for a few seconds.
Which is ok for a Wireless USB mouse, but not good for an external hard drive.

2) The overall performance seems a bit slower than what I was used to when I had Mac os sierra 10.12.6 installed, especially on boot.

3) I have graphic glitches on boot that force me to connect an HDMI cable or wait for the screen to shut off to fix it.
I got rid of this issue with the GUI screen resolution set to 1024x768 but I'm not happy with it.
I didn't have to do this in Sierra, the issue was there on the boot screen for a few seconds and then everything returned to normal right before the login screen popped up.

4) Wifi is weak and Bluetooth is not showing up, not even in the preferences pane but I have a damaged cable that is related to it that it needs to be fixed or replaced so we'll save it for later.

GENERAL HELP REQUEST:
Can you check my EFi and help me diagnose what is causing the problems listed above?
It would be great

SIDE NOTES:

1) Nvidia graphic is not enabled because someone told me that it is not necessary. I don't know, tell me your opinion.

2) I leave my EFI, ioreg file, and dcpi manager screenshots down below. Thanks!!!
MacBookPro11,1 would be a better choice

remove:
AppleIntelKBLGraphicsFramebufferInjector_3e9x.kext
SMCHelper.efi

what patches did you do in your config.plist?

in terminal:
Code:
sudo kextcache -i /
and copy and paste the results here

next time just upload your zipped clover folder
 
Joined
Apr 12, 2016
Messages
15
Motherboard
ASUS N551JX-CN043T
CPU
i7-4720HQ
Graphics
HD 4600 + GTX 950M, 1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android, iOS
MacBookPro11,1 would be a better choice

remove:
AppleIntelKBLGraphicsFramebufferInjector_3e9x.kext
SMCHelper.efi

what patches did you do in your config.plist?

in terminal:
Code:
sudo kextcache -i /
and copy and paste the results here

next time just upload your zipped clover folder
Hi, thanks for coming.

I just removed what you said.

I'm not a super expert, which patch do you mean?
Which config tab?


This is the command result.

Last login: Mon Apr 13 12:05:58 on console


ipn@IPNs-MBP ~ % sudo kextcache -i /


Password:


Kext with invalid signature (-67030) allowed: <OSKext 0x7ff0f66f6950 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/", ID = "com.apple.driver.AirPort.Atheros40" }


Kext with invalid signature (-67030) allowed: <OSKext 0x7ff0f66f0000 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/", ID = "com.apple.iokit.IO80211Family" }


KernelCache ID: F0CDDF13875C0C398AA4E48A55EE324E


Kext with invalid signature (-67030) allowed: <OSKext 0x7fe7db618ab0 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/", ID = "com.apple.iokit.IO80211Family" }


Kext with invalid signature (-67030) allowed: <OSKext 0x7fe7db61f750 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/", ID = "com.apple.driver.AirPort.Atheros40" }


ipn@IPNs-MBP ~ %


Should I change the number in product name or search through model lookup?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,824
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi, thanks for coming.

I just removed what you said.

I'm not a super expert, which patch do you mean?
Which config tab?


This is the command result.

Last login: Mon Apr 13 12:05:58 on console


ipn@IPNs-MBP ~ % sudo kextcache -i /


Password:


Kext with invalid signature (-67030) allowed: <OSKext 0x7ff0f66f6950 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/", ID = "com.apple.driver.AirPort.Atheros40" }


Kext with invalid signature (-67030) allowed: <OSKext 0x7ff0f66f0000 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/", ID = "com.apple.iokit.IO80211Family" }


KernelCache ID: F0CDDF13875C0C398AA4E48A55EE324E


Kext with invalid signature (-67030) allowed: <OSKext 0x7fe7db618ab0 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/", ID = "com.apple.iokit.IO80211Family" }


Kext with invalid signature (-67030) allowed: <OSKext 0x7fe7db61f750 [0x7fff89e018c0]> { URL = "file:///System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/", ID = "com.apple.driver.AirPort.Atheros40" }


ipn@IPNs-MBP ~ %
sorry i meant what patches in your DSDT file
 
Joined
Apr 12, 2016
Messages
15
Motherboard
ASUS N551JX-CN043T
CPU
i7-4720HQ
Graphics
HD 4600 + GTX 950M, 1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android, iOS
no, i mean your DSDT.aml file you said you created
oh ok got, I don't remember really, it's been really tough to make it I would say
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,824
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
oh ok got, I don't remember really, it's been really tough to make it I would say
you only need a DSDT if you need to fix things, best to remove it then if you can't remember what you clicked on in macIASL under patched.....
 
Joined
Apr 12, 2016
Messages
15
Motherboard
ASUS N551JX-CN043T
CPU
i7-4720HQ
Graphics
HD 4600 + GTX 950M, 1920 x 1080
Mac
MacBook Pro
Mobile Phone
Android, iOS
you only need a DSDT if you need to fix things, best to remove it then if you can't remember what you clicked on in macIASL under patched.....
I used it to fix power management, battery percentage counter was unstable
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,824
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I used it to fix power management, battery percentage counter was unstable
do this:
 
Top