Contribute
Register

Pink screen on (shutdown / switch user) with HD4600

Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
Hi,
anyone else notice the following pink (in reality it is really pink, on the photo it looks more purple)
screen when you switch a user or shut down the system ?

At the moment I am using (until I know how to properly hack the ssdt) :

  • Lilu.kext (1.1.7)
  • IntelGraphicsFixup.kext (1.1.7)

  • FtFWDUx.jpg
 
Joined
Mar 10, 2016
Messages
39
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i7-8700
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
yeah once in a while
 
Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
Thank you , I am not the only one yeah ! Did you do anything to fix it or does it just disappear ? please?
 
Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
[stroke]
Today I removed my GTX780ti and uninstalled the Webdrivers,
Result: No more Pink Screens

Looks like it leads to errors when using the iGPU while having a Nvidia mounted and the Webdriver installed.
Later I will Try it this is also true if I just physically mount it and just do not install the Webdriver.
[/stroke]
Sidenote:
You might wonder why I use the iGPU and not the Nvidia, I use it because I have some things which do work better with the iGPU but I would love to use the Nvidia under Windows on the same hardware
 
Last edited:
Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
Still sometimes Pink even without Nvidia GPU
 
Joined
Sep 27, 2017
Messages
3
Motherboard
Gigabyte GA-78LMT-S2P
CPU
AMD FX 6100
Graphics
Nvidia GeForce 9600 GT
I'm currently using just a standard mac, not a hackintosh, and am experiencing the same issue, it happens more frequently when I switch user and shutdown, as I have two users on this machine, one for me and one for a family member, the family members account is the one the mac boots straight into so I usually straight away switch to my own, use the mac as usual and on shutdown I get the same pink screen you have shown, so I reckon its a high sierra issue, and not anything you are doing wrong with your hackintosh setup, I could be wrong as there is a possbility its just the intergrated graphics on this machine playing up, but from what I can find, its usually only when I shutdown after I have switched users.
 
Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
I'm currently using just a standard mac, not a hackintosh, and am experiencing the same issue, it happens more frequently when I switch user and shutdown, as I have two users on this machine, one for me and one for a family member, the family members account is the one the mac boots straight into so I usually straight away switch to my own, use the mac as usual and on shutdown I get the same pink screen you have shown, so I reckon its a high sierra issue, and not anything you are doing wrong with your hackintosh setup, I could be wrong as there is a possbility its just the intergrated graphics on this machine playing up, but from what I can find, its usually only when I shutdown after I have switched users.
Do you have a Nvidia Graphics Card in your Mac ?
 
Joined
Sep 27, 2017
Messages
3
Motherboard
Gigabyte GA-78LMT-S2P
CPU
AMD FX 6100
Graphics
Nvidia GeForce 9600 GT
Do you have a Nvidia Graphics Card in your Mac ?

I don't no, so I am not 100% sure if they are related, but mine is showing that same screen on shut down, so I'm not sure whether its a High Sierra issue or not
 
Joined
Oct 15, 2011
Messages
965
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
I don't no, so I am not 100% sure if they are related, but mine is showing that same screen on shut down, so I'm not sure whether its a High Sierra issue or not
What does About my Mac say ?
eg here mine :

Screen Shot 2017-10-06 at 17.10.07.png
 
Top