Contribute
Register

Photos App freezes the whole system

Joined
Apr 8, 2017
Messages
41
Motherboard
MSI Z170 Gaming Pro Carbon
CPU
I7-7700K
Graphics
RX 580
Mobile Phone
iOS
Hi, I set up my Hackintosh, all working but if I open the Photos app it freezes the whole system and only the arrow moves.
and if I try to open a photo took from an iPhone the Preview app doesn't respond and I have to force quit it.
I previously used integrated graphics before buying the GFX and it used to work (on High Sierra, now I have Mojave, don't know if it matters)
What can I do?
Thanks
P.S. I attach EFI folder
I don't use any kext for the graphics I only activated RadeonDeInit in config.plist which I read it works the same as WhateverGreen
 

Attachments

Joined
Sep 19, 2010
Messages
540
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7 4790K
Graphics
RX 480
Mac
iMac
Mobile Phone
iOS
It’s an issue with the AMD card. Hardware encoding/decoding is not functioning correctly with a discreet video card. If you enable the on-board graphics(iGPU), Photos app will function correctly. I have faced the exact same problem.
 
Joined
Dec 21, 2017
Messages
44
Motherboard
Gigabyte Z270 HD3
CPU
i7-6700
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
It’s an issue with the AMD card. Hardware encoding/decoding is not functioning correctly with a discreet video card. If you enable the on-board graphics(iGPU), Photos app will function correctly. I have faced the exact same problem.
Thank you very, very much. The problem has been solved!!!
Open internal GPU in bios, problem solving!
 
Top