Contribute
Register

pastrychef's build - Asus Maximus VIII Gene - i7-7700K - GTX 1080

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Are you using Shiki.kext ?? I am not using that. Also, I am going to update 10.13.2 today so let's see how it goes.
I am currently not using Shiki.kext.
 
Joined
Nov 23, 2010
Messages
520
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Wow! Cool! So all I need to do is add boot arg shikigva=60?
ok, thanks to @esetnik I'm using these bots args: shikigva=60 ngfxpatch=pikera
obviously with latest lily, shake, nvidiagraphicsfixup kexts.
so I can use multiple display and I have quick sync working

edit: one more thing, now even Netflix is working on safari
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
ok, thanks to @esetnik I'm using these bots args: shikigva=60 ngfxpatch=pikera
obviously with latest lily, shake, nvidiagraphicsfixup kexts.
so I can use multiple display and I have quick sync working

edit: one more thing, now even Netflix is working on safari
Wow! Awesome! Thanks for the info!!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I just updated to macOS High Sierra 10.13.2.

My first attempt was to update via the App Store but I encountered the dreaded "OSInstall.mpkg appears to be missing or damaged" error.
26903948-656f5bc6-4be8-11e7-9552-6b0ea1f961ef.png

I tried a few fixes I found on the internet but none of them worked for me. So, I just downloaded the full 10.13.2 High Sierra installer and ran that. This updated my system to 10.13.2 perfectly.
Screen Shot 2017-12-07 at 5.13.41 AM.png

Follow the directions here prior to updating: macOS 10.13.2 Update | tonymacx86.com

Recap:
  1. Update apfs.efi in /EFI/CLOVER/drivers64UEFI/.
  2. Update Lilu.kext to 1.2.1 if you use it.
  3. Update via App Store. (If you encounter the OSinstall.mpkg error, just download than run the full High Sierra installer.)
  4. After updating, the Nvidia web driver preference pane will pop up telling you it needs to be updated. Follow on screen instruction to update.
  5. Done.
 
Joined
Nov 23, 2010
Messages
520
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I just updated to macOS High Sierra 10.13.2.

My first attempt was to update via the App Store but I encountered the dreaded "OSInstall.mpkg appears to be missing or damaged" error.
View attachment 297772
I tried a few fixes I found on the internet but none of them worked for me. So, I just downloaded the full 10.13.2 High Sierra installer and ran that. This updated my system to 10.13.2 perfectly.
View attachment 297776
Follow the directions here prior to updating: macOS 10.13.2 Update | tonymacx86.com

Recap:
  1. Update apfs.efi in /EFI/CLOVER/drivers64UEFI/.
  2. Update Lilu.kext to 1.2.1 if you use it.
  3. Update via App Store. (If you encounter the OSinstall.mpkg error, just download than run the full High Sierra installer.)
  4. After updating, the Nvidia web driver preference pane will pop up telling you it needs to be updated. Follow on screen instruction to update.
  5. Done.

hi pastry.
i have just installed the combo 10.13.2 and I have os build number 17c89
the issue is that I can't install the new web driver, it says that Mac OS version is not compatible.
what's the hell? Nvidia 378.10.10.10.25.102


solved.

the issue was that I have upgraded trough combo update and it gives me a different os version number (17c89 instead of 17c88).

so I cannot use the driver.

i have fix it modifying the Nvidia web driver info.plist ;-)
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Yeah, it looks like Apple slipped in another release... The only alternative right now would be hack existing Nvidia web drivers to work with this release, at least until Nvidia catches up...

HERE is a script that can help.
 
Joined
Nov 23, 2010
Messages
520
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Joined
Nov 24, 2015
Messages
10
Motherboard
Asus Maximus VIII Gene
CPU
i7 7700K
Graphics
Nvidia 1070
Mobile Phone
iOS
"OSInstall.mpkg appears to be missing or damaged" error.
I have this problem unsolved for so much time. The update rarely works, I tried everything!
Now, for me, the solution seems to remove the file EmuVariableUefi-64.efi before upgrade. Than reboot, upgrade and replace the file EmuVariableUefi-64.efi.

I don't know what is this file. Is it for nvram ?

the best thing is to have a usb stick with clover without this file and use the stick only to update osx.
 
Top