Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD Vega 56

Joined
Dec 22, 2015
Messages
144
Motherboard
Asus ROG Strix Z370-G Gaming
CPU
i7 8700K
Graphics
Vega 64
Mac
MacBook Pro
Have you tried using the USB 3.1 gen 2 ports in the rear? They are the red ones.
No, a while back you had recommended not to use them because of something unrelated, will try it then.

If you want to enable one of the USB 2 ports and disable one of the USB 3 ports, you can try the following:
Code:
uia_exclude=HS08HS01;HS10;HS11;HS14;SS07;SS08;SS09;SS10;USR1;USR2
This will enable HS09 and disable USB 2 functionality of the USB 3 port next to it (directly below the PS/2 port). However, USB 3 functionality should remain on that USB 3 port.
I'll test the 3.1 gen2 port for a while, (the audio stuttering only happens occasionally) if it doesn't help I'll try changing the uia_exclude as you suggested, thanks so much for helping out. :thumbup:
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,273
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
No, a while back you had recommended not to use them because of something unrelated, will try it then.


I'll test the 3.1 gen2 port for a while, (the audio stuttering only happens occasionally) if it doesn't help I'll try changing the uia_exclude as you suggested, thanks so much for helping out. :thumbup:
The USB 3.1 gen 2 ports should always work fine. We don't even have to worry about them when configuring USB because they are on a separate controller.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,273
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
So I can now wake from sleep without crash but I now get random freezes after wake. I can sometimes go on quite long and then the screen freezes but cursor still moves. If I turn monitor off and then on it’s black and I have to reboot.
Are you testing with overclocks disabled (including multi-core enhancement) and XMP disabled?
 
Joined
May 22, 2011
Messages
979
Motherboard
GigaByte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@pastrychef DRM works with IGPU enabled from BIOS on SMBIOS 19,1 with these boot arguments;

shikigva=32
shiki-id=Mac-7BA5B2D9E42DDD94

But no Netflix on Safari. :cry:

Apple TV+ and Purchase movies work without any problem.

Is Netflix working on Safari with your SMBIOS iMacPro1,1?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,273
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
@pastrychef DRM works with IGPU enabled from BIOS on SMBIOS 19,1 with these boot arguments;

shikigva=32
shiki-id=Mac-7BA5B2D9E42DDD94

But no Netflix on Safari :cry:

Apple TV+ and Purchase movies work without any problem.

is Netflix working on Safari with your SMBIOS iMacPro1,1?
Are you streaming from the Apple TV app or are you downloading? Downloaded videos have always played. It's streaming that is the problem.

Netflix not working on Safari tells me that HDCP is still not working right.

With iMacPro1,1, Amazon Prime videos work fine in Safari (I don't have Netflix). Streaming videos also work fine in Apple TV app.
 
Joined
May 16, 2016
Messages
296
Motherboard
Asus Prime Z370-A II-1001
CPU
i9-9900K
Graphics
RX 5700
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Are you streaming from the Apple TV app or are you downloading? Downloaded videos have always played. It's streaming that is the problem.

Netflix not working on Safari tells me that HDCP is still not working right.

With iMacPro1,1, Amazon Prime videos work fine in Safari (I don't have Netflix). Streaming videos also work fine in Apple TV app.
I can add that with iMacPro1,1 (with or without iGPU enabled) Netflix works on Safari and Prime.
 
Joined
May 22, 2011
Messages
979
Motherboard
GigaByte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Are you streaming from the Apple TV app or are you downloading? Downloaded videos have always played. It's streaming that is the problem.

Netflix not working on Safari tells me that HDCP is still not working right.

With iMacPro1,1, Amazon Prime videos work fine in Safari (I don't have Netflix). Streaming videos also work fine in Apple TV app.
Yes, Apple TV+ App streaming works I didn't try downloading.
 
Top