Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD Vega 56

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
No, they are injected via Clover.



Sure and thanks again.
Code:
panic(cpu 0 caller 0xffffff801c4290b7): "AppleHDAHDMI_DPDriver::setPowerState(0xffffff8067cc9500 : 0xffffff7f9f365730, 0 -> 1) timed out after 10175 ms"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-6153.11.26/iokit/Kernel/IOServicePM.cpp:5302
Backtrace (CPU 0), Frame : Return Address
0xffffffa3ed56bb40 : 0xffffff801bd3f98b
0xffffffa3ed56bb90 : 0xffffff801be76c15
0xffffffa3ed56bbd0 : 0xffffff801be6861e
0xffffffa3ed56bc20 : 0xffffff801bce6a40
0xffffffa3ed56bc40 : 0xffffff801bd3f077
0xffffffa3ed56bd40 : 0xffffff801bd3f45b
0xffffffa3ed56bd90 : 0xffffff801c4d2d89
0xffffffa3ed56be00 : 0xffffff801c4290b7
0xffffffa3ed56be50 : 0xffffff801c428c79
0xffffffa3ed56be60 : 0xffffff801c44002e
0xffffffa3ed56bea0 : 0xffffff801c427a28
0xffffffa3ed56bec0 : 0xffffff801bd811d5
0xffffffa3ed56bf40 : 0xffffff801bd80d01
0xffffffa3ed56bfa0 : 0xffffff801bce613e

BSD process name corresponding to current thread: kernel_task
Boot args: shikigva=60 uia_exclude=HS03;HS04;HS09;HS11;HS12;SS03;SS04 dart=0 -alcbeta

Mac OS version:
19A583

Kernel version:
Darwin Kernel Version 19.0.0: Wed Sep 25 20:18:50 PDT 2019; root:xnu-6153.11.26~2/RELEASE_X86_64
Kernel UUID: 70EDD61F-86EE-3E1B-873F-98D909B78160
Kernel slide:     0x000000001ba00000
Kernel text base: 0xffffff801bc00000
__HIB  text base: 0xffffff801bb00000
System model name: iMac18,1 (Mac-4B682C642B45593E)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 3286504787909
last loaded kext at 521717035047: @filesystems.msdosfs    1.10 (addr 0xffffff7f9f1c9000, size 69632)
last unloaded kext at 217638303242: >!AFileSystemDriver    3.0.1 (addr 0xffffff7f9c695000, size 8192)
loaded kexts:
com.orderedbytes.driver.CMUSBDevices    4.9.0
com.orderedbytes.driver.!CMate!F    4.6.0
com.objective-see.lulu    1.2.0
com.intel.driver.EnergyDriver    3.6.1
com.insanelymac.!IMausiEthernet    2.5.0d0
as.vit9696.!AALC    1.4.2
as.vit9696.WhateverGreen    1.3.3
as.vit9696.Lilu    1.3.8
com.rehabman.driver.USBInjectAll    0.7.1
org.netkas.driver.FakeSMC    1802
@filesystems.msdosfs    1.10
@fileutil    20.036.15
@filesystems.ntfs    3.14.3
>AudioAUUC    1.70
@filesystems.autofs    3.0
|IO!BSerialManager    7.0.0f8
>!AGraphicsDevicePolicy    4.1.46
@AGDCPluginDisplayMetrics    4.1.46
>!AHV    1
|IOUserEthernet    1.0.1
>!AUpstreamUserClient    3.6.8
>pmtelemetry    1
>!AMCCSControl    1.12
@Dont_Steal_Mac_OS_X    7.0.0
>AGPM    111.1.18
>!APlatformEnabler    2.7.0d0
>X86PlatformShim    1.0.0
>!A!IKBLGraphics    14.0.0
>!AHDA    283.14
>!A!IPCHPMC    2.0.1
>AirPort.BrcmNIC    1400.1.1
>!A!ICFLGraphicsFramebuffer    14.0.0
>!A!ISlowAdaptiveClocking    4.0.0
@filesystems.apfs    1412.11.7
>!AVirtIO    1.0
@filesystems.hfs.kext    522.0.9
@!AFSCompression.!AFSCompressionTypeDataless    1.0.0d1
@BootCache    40
@!AFSCompression.!AFSCompressionTypeZlib    1.0.0
>!AAHCIPort    341.0.2
@private.KextAudit    1.0
>!AACPIButtons    6.1
>!ARTC    2.0
>!AHPET    1.8
>!AACPIEC    6.1
>!ASMBIOS    2.1
>!AAPIC    1.7
$!AImage4    1
@nke.applicationfirewall    302
$TMSafetyNet    8
@!ASystemPolicy    2.0.0
|EndpointSecurity    1
@kext.triggers    1.0
>!AGraphicsControl    4.1.46
|IOAVB!F    800.17
>!ASSE    1.0
>!ASMBus!C    1.0.18d1
@!AGPUWrangler    4.1.46
>DspFuncLib    283.14
@kext.OSvKernDSPLib    529
|IONDRVSupport    558.3
>!AHDA!C    283.14
|IOHDA!F    283.14
|IOAudio!F    300.2
@vecLib.kext    1.2.0
|IO80211!F    1200.12.2b1
>mDNSOffloadUserClient    1.0.1b8
>corecapture    1.0.4
@!AGraphicsDeviceControl    4.1.46
|IOAccelerator!F2    438.1.23
|IOGraphics!F    558.3
|IOSlowAdaptiveClocking!F    1.0.0
>X86PlatformPlugin    1.0.0
>IOPlatformPlugin!F    6.0.0d8
@plugin.IOgPTPPlugin    800.14
|IOEthernetAVB!C    1.1.0
|IOSkywalk!F    1
|IOAHCIBlock!S    316.0.5
|Broadcom!BHost!CUSBTransport    7.0.0f8
|IO!BHost!CUSBTransport    7.0.0f8
|IO!BHost!CTransport    7.0.0f8
|IO!B!F    7.0.0f8
|IO!BPacketLogger    7.0.0f8
>usb.IOUSBHostHIDDevice    1.2
>usb.networking    5.0.0
>usb.!UHostCompositeDevice    1.2
>usb.!UHub    1.2
|IOSerial!F    11
|IOSurface    269.6
@filesystems.hfs.encodings.kext    1
>usb.!UHostPacketFilter    1.0
|IOUSB!F    900.4.2
|IONVMe!F    2.1.0
|IOAHCI!F    290.0.1
>usb.!UXHCIPCI    1.2
>usb.!UXHCI    1.2
>!AEFINVRAM    2.1
>!AEFIRuntime    2.1
|IOSMBus!F    1.1
|IOHID!F    2.0.0
$quarantine    4
$sandbox    300.0
@kext.!AMatch    1.0.0d1
>DiskImages    493.0.0
>!AFDEKeyStore    28.30
>!AEffaceable!S    1.0
>!AKeyStore    2
>!UTDM    489.11.2
|IOSCSIBlockCommandsDevice    422.0.2
>!ACredentialManager    1.0
>KernelRelayHost    1
>!ASEPManager    1.0.1
>IOSlaveProcessor    1
|IOTimeSync!F    800.14
|IONetworking!F    3.4
|IOUSBMass!SDriver    157.11.2
|IOSCSIArchitectureModel!F    422.0.2
|IO!S!F    2.1
|IOUSBHost!F    1.2
>!UHostMergeProperties    1.2
>usb.!UCommon    1.0
>!ABusPower!C    1.0
|CoreAnalytics!F    1
>!AMobileFileIntegrity    1.0.5
@kext.CoreTrust    1
|IOReport!F    47
>!AACPIPlatform    6.1
>!ASMC    3.1.9
>watchdog    1
|IOPCI!F    2.9
|IOACPI!F    1.4
@kec.pthread    1
@kec.Libm    1
@kec.corecrypto    1.0
I'm not sure what to make of it... Have you tried downgrading AppleALC and WhateverGreen to a slightly older release?
 
Joined
Nov 6, 2017
Messages
44
Motherboard
Asus PRIME Z370-A
CPU
i7-8700K
Graphics
UHD 630
Mobile Phone
iOS
Joined
May 22, 2011
Messages
1,045
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@pastrychef here is my problem. Actually, I mention this problem before but I didn't show you how it looks. A couple of minutes ago, while working on the Desktop, screen turns grey and blinking. Normally, it's just solid grey but this time also starts blinking. Can you look at the video I attached what do you think about it?
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Yes I tried version 1.2.8 of AppleALC and although it fixes the kernel panic, I lose audio on wake.

It seems others are facing this issue as well:
https://www.tonymacx86.com/threads/help-applealc-kernel-panic-after-catalina-update.284654/

In any case, I filed a bug report on Github and we'll see how it goes.

Thanks for taking a look.
Try using older version of AppleALC and install CodecCommander.

None of the kexts from acidanthera will be verified for Clover compatibility anymore so I'm not sure filing a bug report will help.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
@pastrychef here is my problem. Actually, I mention this problem before but I didn't show you how it looks. A couple of minutes ago, while working on the Desktop, screen turns grey and blinking. Normally, it's just solid grey but this time also starts blinking. Can you look at the video I attached what do you think about it?
Are you using HDMI?
 
Joined
May 22, 2011
Messages
1,045
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Are you using HDMI?
Yes, my display just has HDMI and DVI. I tried DVI, the same thing happened with DVI too. I also tried different cables 1.2, 1.3,(Original Apple HDMI cable) and 2.0 none of them helped.

This is my ioreg everything looks ok. But this problem never gone.
 

Attachments

Last edited:
Joined
Aug 11, 2012
Messages
258
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i7-8700K
Graphics
RX 570
pastrychef....I'm having trouble getting power out my USB ports to charge my iPad. The iPad shows up but says "not charging". What's really weird is that I added SSDT-USBX.aml to my .../ACPI/patched/ last night. I was sure that it worked last night, and I was getting power. Today it doesn't. Maybe I'm losing my mind but I would like to get this fixed. I know you're no longer running my motherboard. Thanks in advance for any thoughts...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Yes, my display just has HDMI and DVI. I tried DVI, the same thing happened with DVI too. I also tried different cables 1.2, 1.3,(Original Apple HDMI cable) and 2.0 none of them helped.

This is my ioreg everything looks ok. But this problem never gone.
I don't know what can be causing the flicker. I know HDMI can be finicky, but DVI should work...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
pastrychef....I'm having trouble getting power out my USB ports to charge my iPad. The iPad shows up but says "not charging". What's really weird is that I added SSDT-USBX.aml to my .../ACPI/patched/ last night. I was sure that it worked last night, and I was getting power. Today it doesn't. Maybe I'm losing my mind but I would like to get this fixed. I know you're no longer running my motherboard. Thanks in advance for any thoughts...
I have the motherboard up and running. I'll test out iPad charging later and report back.
 
Joined
May 22, 2011
Messages
1,045
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I don't know what can be causing the flicker. I know HDMI can be finicky, but DVI should work...
But this time I got a grey screen with a flicker. After a couple of hours, I got one grey screen no flicker. DVI also doesn't work. I mean it's working but I am getting the same grey screen. The only solution force restart from the case.

BTW this is happening randomly you don't know when will it come. That's the most annoying part of this problem.
 
Top