Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD Vega 56

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
As some of you may know, I've been using a single USB macOS installer as my emergency booter for all my hacks. This worked beautifully when all my hacks essentially used the same Clover drivers. Directions on how to do this can be found here.

A problem arose when I added a Z390 system to the family... My Z390 system uses OsxAptioFix3Drv + EmuVarialbeUefi + Test2, drivers that none of my other hacks use.

To add support for my Z390 to my USB macOS Installer:
  1. Navigate to /EFI/CLOVER/drivers/UEFI/ on the USB flash drive.
  2. Copy the all the drivers that are used by all my hacks to this folder.
  3. Edit config.plists > Disable Drivers of each of my hacks and disable the Clover drivers not needed and/or incompatible with that particular system.

So, once again, I have a single USB macOS Installer that I can use to boot every one of my hacks in emergencies. :headbang:
 
Joined
May 22, 2011
Messages
1,045
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@pastrychef is your DRM fully works? I am using SMBIOS 19,1 and disabled IGPU on BIOS. My movies and extras working. But when I try to dramas free first episodes it doesn't show up. Just the first 30 sec (which is the ad before the show) shows than goes to the black screen. I thought it can be a regional block? Cause HBO, Straz, CBS, etc. does not work without a VPN normally, it’s due to rights issues.

BTW, Catalina works without WEG.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
@pastrychef is your DRM fully works? I am using SMBIOS 19,1 and disabled IGPU on BIOS. My movies and extras working. But when I try to dramas free first episodes it doesn't show up. Just the first 30 sec (which is the ad before the show) shows than goes to the black screen. I thought it can be a regional block? Cause HBO, Straz, CBS, etc. does not work without a VPN normally, it’s due to rights issues.

BTW, Catalina works without WEG.
Yes, DRM is working. I tested Amazon Prime videos and streaming Apple TV shows.

Mojave also worked without WhateverGreen, but you lose DisplayPort/HDMI audio and only one video out port will work.
 
Joined
Dec 31, 2017
Messages
24
Motherboard
Z370-G
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
Yes, DRM is working. I tested Amazon Prime videos and streaming Apple TV shows.

Mojave also worked without WhateverGreen, but you lose DisplayPort/HDMI audio and only one video out port will work.
The TV app does not work for me. No issues web streaming though. I noticed the shikivga param was removed from the latest EFI. So, I removed this to see if it was perhaps no longer needed. I suspect adding it back (I had it set to 1) will fix the DRM issue with TV.

Thanks again for the updates to the EFI, @pastrychef

Also, did you mention anywhere in this thread why you moved from Vega 56 to Radeon VII? Just better performance?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
The TV app does not work for me. No issues web streaming though. I noticed the shikivga param was removed from the latest EFI. So, I removed this to see if it was perhaps no longer needed. I suspect adding it back (I had it set to 1) will fix the DRM issue with TV.

Thanks again for the updates to the EFI, @pastrychef

Also, did you mention anywhere in this thread why you moved from Vega 56 to Radeon VII? Just better performance?
If you want full working DRM, use iMacPro1,1 system definition.

The sole reason why I switched to Radeon VII was for better gaming experience in Windows.
 
Joined
Dec 23, 2017
Messages
80
Motherboard
Gigabyte Z390 Designare
CPU
i7-8086 Delidded
Graphics
Radeon VII
Mac
iMac
Mobile Phone
Android
If you want full working DRM, use iMacPro1,1 system definition.

The sole reason why I switched to Radeon VII was for better gaming experience in Windows.
I seen numerous benchmarks where it goes head to head on 1080, 1080 ti, 2080 and even 2080 ti on a few titles.

I have the Sapphire Nitro Radeon VII and am building my system as we speak with a silicon lottery winner i7 8086 (binned 8700k's) which is delidded and leaves me with sweet temps such as 45-60 degrees celcius @ 5.4 ghz

I am installing on the gigabyte Z390 Designare Mb
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I seen numerous benchmarks where it goes head to head on 1080, 1080 ti, 2080 and even 2080 ti on a few titles.

I have the Sapphire Nitro Radeon VII and am building my system as we speak with a silicon lottery winner i7 8086 (binned 8700k's) which is delidded and leaves me with sweet temps such as 45-60 degrees celcius @ 5.4 ghz

I am installing on the gigabyte Z390 Designare Mb
Wow!!! 60C under full load??? Prime95?

I delidded my i9-9900K and get about 80C or so in Prime95 @ 5GHz on air cooling. I will probably test out 5.1GHz this coming week.
 
Joined
Dec 23, 2017
Messages
80
Motherboard
Gigabyte Z390 Designare
CPU
i7-8086 Delidded
Graphics
Radeon VII
Mac
iMac
Mobile Phone
Android
Ahh..I hear you have to tread carefully when delidding an i9-9900k?
I delidded and used cryonaut liquid metal . I have an ek velocity cpu block, and 2 Alphacool Nexus radiators . A 360 and a 280mm . Liquid is surging via a D5 with Bitspower Mod top, pump kit with a 250ml res up on top.

Prime 95 for 47 minutes. Lexmark, Real bench and HW monitor for cpu stressing.
I should have went with a z390 master or Extreme for OC'ing my 8086.
I feel that the Asrock Z370 Tai chi may have been a bottleneck for the 8086. I'm mostly in it for content creation so I chose the designare.

However with a good overclocking board and with Ram timings tightened right up, I have no doubt I can hit 5.6 ghz on liquid Pastrychef
 
Joined
Dec 23, 2017
Messages
80
Motherboard
Gigabyte Z390 Designare
CPU
i7-8086 Delidded
Graphics
Radeon VII
Mac
iMac
Mobile Phone
Android
The Hottest ever on Prime was 73 on 1 core than dropped back to Mid- 60's
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,423
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Ahh..I hear you have to tread carefully when delidding an i9-9900k?
I delidded and used cryonaut liquid metal . I have an ek velocity cpu block, and 2 Alphacool Nexus radiators . A 360 and a 280mm . Liquid is surging via a D5 with Bitspower Mod top, pump kit with a 250ml res up on top.

Prime 95 for 47 minutes. Lexmark, Real bench and HW monitor for cpu stressing.
I should have went with a z390 master or Extreme for OC'ing my 8086.
I feel that the Asrock Z370 Tai chi may have been a bottleneck for the 8086. I'm mostly in it for content creation so I chose the designare.

However with a good overclocking board and with Ram timings tightened right up, I have no doubt I can hit 5.6 ghz on liquid Pastrychef
The Hottest ever on Prime was 73 on 1 core than dropped back to Mid- 60's
Geez. That's a crazy elaborate cooling system. I'm just on a Noctua NH-D15S. Lol

I get approx 80C or so in Prime95. When I run Prime95, I try to leave it running for at least 2 hours.

I've booted to 5.2GHz on 1.35v but backed it back down to 5.0GHz on 1.270v and "Turbo" LLC for 24/7 use. I'm going to see if I can get 5.1GHz stable on 1.30v or less and monitor temps. If it's in the mid-80s on Prime95, I'll keep it.

This is on my Gigabyte Z390 M Gaming. On my Z370-G, I needed 1.330v for a stable 5.0GHz.

The superior VRM of my Z390 over my Z370 is clearly evident. However, I have found my Gigabyte Z390 to be extremely finicky about RAM. My G.Skill RAM would not run reliably at it's XMP profile and I had to loosen timings slightly. The same kit of RAM runs perfectly on my Asus Z370... I wish there were more mATX choices with good VRM.
 
Top