Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD Vega 56

Joined
Dec 1, 2018
Messages
38
Motherboard
ASUS ROG STRIX Z370F
CPU
i7-8700K
Graphics
UHD630
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
Here's a test with Launchpad.
Thanks for your input. Really appreciated. A few others people including CorpNewt confirmed that choppy/stuttering animation on UHD 630 on 4k monitor.
 
Joined
Oct 26, 2010
Messages
12
Motherboard
Asus ROG STRIX Z370-F GAMING
CPU
i7-8700K
Graphics
UHD 630
Thanks very much for your support on this thread. I have always had screen flickering using your EFI folder on Mojave with iGPU on a Mojave Z370 8700K system. I have always needed to apply a patch to the IOPCIPrimaryMatch key of AppleIntelKBLGraphicsFramebuffer.kext to overcome this when using iMac18,1 or iMac18,3. Moving to iMacPro1,1 has completely solved this. It's nice to have an untouched system now.
 
Joined
Dec 1, 2018
Messages
38
Motherboard
ASUS ROG STRIX Z370F
CPU
i7-8700K
Graphics
UHD630
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
Thanks very much for your support on this thread. I have always had screen flickering using your EFI folder on Mojave with iGPU on a Mojave Z370 8700K system. I have always needed to apply a patch to the IOPCIPrimaryMatch key of AppleIntelKBLGraphicsFramebuffer.kext to overcome this when using iMac18,1 or iMac18,3. Moving to iMacPro1,1 has completely solved this. It's nice to have an untouched system now.
This is weird, we have the same systems but I've never had this problem.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,444
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Thanks very much for your support on this thread. I have always had screen flickering using your EFI folder on Mojave with iGPU on a Mojave Z370 8700K system. I have always needed to apply a patch to the IOPCIPrimaryMatch key of AppleIntelKBLGraphicsFramebuffer.kext to overcome this when using iMac18,1 or iMac18,3. Moving to iMacPro1,1 has completely solved this. It's nice to have an untouched system now.
What patch did you use?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,444
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Add 0x3E918086 0x3E928086 to <key>IOPCIPrimaryMatch</key>
What version of macOS were you using? Those should be in there already. UHD 630 has native support.
 
Joined
Oct 26, 2010
Messages
12
Motherboard
Asus ROG STRIX Z370-F GAMING
CPU
i7-8700K
Graphics
UHD 630
What version of macOS were you using? Those should be in there already. UHD 630 has native support.
These keys were not there in any version I tried. After applying the 10.14.5 update they are gone again:
<key>IOPCIPrimaryMatch</key>
<string>0x59128086 0x59168086 0x591B8086 0x591C8086 0x591E8086 0x59268086 0x59278086 0x59238086 0x87C08086</string>

I was not exactly sure what these were doing, but they always stopped the flickering after applying a system update. I have always used your EFI folders unaltered (apart from serials & SmUUID).

Anyway, it's all working smoothly with iMacPro1,1
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,444
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Hi @pastrychef : congrat to your build.
I also have i9-9900K and getting too hot with CPU full load (HandBreak, 7zip,...) with Cooler Master Master Liquid ML240L.
Did you have any issue with hot CPU? your Noctua NH-D15S cooling CPU to how many degree while full load.
Thank you.
Under Prime95, my CPU tops out at about 82C and system remains extremely quiet. With Handbrake, it's usually 80C or lower.

Please keep in mind that I'm overclocked and my CPU has been delidded.
 
Joined
Jun 13, 2015
Messages
11
Motherboard
Asus ROG Strix Z370-H Gaming WIFI AC
CPU
I7-8700K
Graphics
Vega 56
Mac
MacBook Pro
If the system is stable in Windows, we have to assume it's just macOS.

The only app that I know of to check SSD health is SSDReporter but I don't own it and have never personally tried it...
I haven't really managed to get any crash logs, but I expect something with Window manager. I removed whatevergreen kext, and since then no crash. With whatevergreen I used two U2715H 2440p monitors with DP, but, after the change, I'm only able to use one with DP and the other one with HDMI.

I'm using iMacPro 1.1 definition with my VEGA 56 and IGPU disabled.
Guess it was something with whatervergreen and my VEGA. Hope it stays OK now. :)

EDIT: It crashed just a few minutes after writing this. Managed to get a log this time.
I can't understand where the problem could be from this.
 
Last edited:
Top