Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD Vega 56

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,659
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Ok so I use overclocking the cpu is out of question at this point ?
Make sure everything is stable before attempting to overclock. If the system is unstable and you overclock, you won't know if the problem is the overclock or with your hackintosh configuration when you experience problems.



Should IGPU be enabled or disabled with your new EFI and MP 1.1 sys def
Leave it disabled for now.
 
Joined
Mar 4, 2017
Messages
121
Motherboard
Asus ROG Strix Z370-G
CPU
i7 8700K
Graphics
Asus RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hey Pastrychef, everything has been working fine for me on the latest EFI for the past few months, but something odd happened yesterday and I've been having issues since. I got a popup from an app requesting access to monitor system events, which I granted. For some reason, my computer spontaneously rebooted and ever since, I've been having bouts of lag and odd lines on my monitors. Could it be a video card issue or is it likely software-related?

Edit: Nevermind, I think I found the issue. I forgot to plug in one of my fans after a recent cleaning, everything was likely running a few degrees warmer, causing the issues.

Edit 2: Happened even after plugging in the fan, memory usage got close to 99% and the whole thing just froze up, had to force reboot. I think it could be an app I installed recently, any other ideas on what could be causing it?
 
Last edited:
Joined
Jan 28, 2014
Messages
134
Motherboard
Asus Rog Strix Z370-G Gaming (WI-FI AC)
CPU
i7-9700K OC'd @ 5.0GHz
Graphics
Vega 56
Mobile Phone
Android
macOS 10.15.6 (19G73) Catalina updated fine. Took 20 minutes and 2 reboots.
2020-07-15 alle 21.53.00 PM.png
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,659
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Yup. Took me ~20 minutes and two restarts too.

Screen Shot 2020-07-15 at 5.22.18 PM.png

Btw, guys, don't try this with the Big Sur Public Beta. The bootloaders need updating. Currently, the only way to get Big Sur on a hackintosh is through a convoluted installation process.
 
Joined
Nov 8, 2015
Messages
10
Motherboard
ASUS ROG STRIX Z370 G GAMING (WI-FI AC)
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Lisa, Power Mac
Mobile Phone
iOS
Hi, I am - finally - planning to update my "ROG STRIX Z370-G GAMING (WI-FI AC)" machine to Catalina (currently I am still running Mojave) with a fresh install (based on the latest available 10.15.6 installer package). Would you recommend to use the "EFI Clover r5117 Z370G (Catalina).zip" for this purpose (using UniBeast 10.3.0 and Clover EFI bootloader v5.0 r5119?). Thank you for your insights in advance!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,659
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Hi, I am - finally - planning to update my "ROG STRIX Z370-G GAMING (WI-FI AC)" machine to Catalina (currently I am still running Mojave) with a fresh install (based on the latest available 10.15.6 installer package). Would you recommend to use the "EFI Clover r5117 Z370G (Catalina).zip" for this purpose (using UniBeast 10.3.0 and Clover EFI bootloader v5.0 r5119?). Thank you for your insights in advance!
Yes, just use that EFI. Copy/paste the System Definition, Serial, Board Serial, and UUID from your existing config.plist to the included config.plist.
 
Joined
Nov 8, 2015
Messages
10
Motherboard
ASUS ROG STRIX Z370 G GAMING (WI-FI AC)
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Lisa, Power Mac
Mobile Phone
iOS
Thank you for the quick answer, yes, I'll use my current Serial, Board Serial, and UUID (as I did before when updating to Mojave). I hope that the current EFI (posted in the first page of this thread - truly appreciated by the way!) may also be used in case there'll be any supplemental update to 10.15.6. (in a way i am a bit hesitating to perform the update to Catalina now / or perhaps to postpone it to the fall).
 
Top