Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

Joined
Jan 9, 2011
Messages
90
Motherboard
Asus Strix Z370-F Gaming
CPU
i7-8700K
Graphics
HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hmmm, tried to boot again. It boots but, after few second,s the screen goes black. Do you know if I need to select any kexts or flags during boot? Thanks again.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hmmm, tried to boot again. It boots but, after few second,s the screen goes black. Do you know if I need to select any kexts or flags during boot? Thanks again.

Use DisplayPort. If you must use HDMI, try lowering refresh to 30Hz.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I am using DisplayPort , I just used your efi and changed to iMac 18.1 maybe I need to do anything else?

There are no configurations in my config.plist for IGPU. It's all auto detected by macOS.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I tried to boot from HDMI, and I get the black screen again. It works only if I boot, for example, with DisplayPort and the change to HDMI.

Check to see if your motherboard requires connectors to be patched.
 
Joined
Jun 20, 2016
Messages
12
Motherboard
Asus Z370G Gaming
CPU
i7-8700K
Graphics
UHD 630
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hey man! I used your EFI Opencore 0.5.7 Z370G build and it works pretty good!
The WiFi from the fenviT919 works out of the box. But the Bluetooth just looks disabled.
I read that I need the brcmPatch kexts to fix that. I can not figure out how to add them in a OpenCore build.
Would you like to explain me how I can add it?
Thanks!
 
Joined
Jan 9, 2011
Messages
90
Motherboard
Asus Strix Z370-F Gaming
CPU
i7-8700K
Graphics
HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Check to see if your motherboard requires connectors to be patched.

Thanks, I will check.

I am lost with this new install. It seems nothing are more hard to do for people that aren't experienced.

I can't make this to boot from disk, only with USB. I checked BIOS, and the drive where OS X is installed isn't detected as UEFI. So I can't select to boot. Any idea how I can do it?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thank will check.

I am lost with this new install, seem no things are more hard to do for people that aren't experienced.

I can't make this to boot from disk, only with USB, I checked BIOS and the drive where OS X is installed isn't detected as UEFI so I can't select to boot, any idea how I can do it?

If you can boot from USB, there's no reason why you can't boot from your SSD. Just make sure you copy the EFI folder from the EFI partition of your USB flash drive to the EFI partition of your SSD.
 
Top