Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,552
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I already tried with HDMI and DisplayPort. Here is how it looks after install.

The pink with HDMI, and the other with DisplayPort.

That's normal with IGPU at the beginning of the boot process. I believe it was improved with newer versions of WhateverGreen.

Where does it get stuck? Please post a picture of the verbose screen were it gets stuck.
 
Joined
Apr 24, 2018
Messages
68
Motherboard
Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU
i7-8700K
Graphics
RX580
After a few more tries, I'm sure it's not a (pure) USB issue. When the machine comes back from sleep, I can move the mouse cursor around for a few seconds, and then the whole machine freezes until reset (clock is stuck etc.). So it seems like something related to waking from sleep is different than before, given that it worked perfectly with 10.15.3 and the previous (pre-5107) EFI.

I'm not sure if you fixed this yet but I solved it by removing AppleALC. Pastry did it by removing WhaterverGreen.

So choose whichever option works best for your situation.
 
Joined
Jan 9, 2011
Messages
90
Motherboard
Asus Strix Z370-F Gaming
CPU
i7-8700K
Graphics
HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
That's normal with IGPU at the beginning of the boot process. I believe it was improved with newer versions of WhateverGreen.

Where does it get stuck? Please post a picture of the verbose screen were it gets stuck.

Going to check that

I'm not sure if you fixed this yet but I solved it by removing AppleALC. Pastry did it by removing WhaterverGreen.

So choose whichever option works best for your situation.

Thanks. Can you tell me the main differences of using one and another?
 
Joined
Apr 24, 2018
Messages
68
Motherboard
Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU
i7-8700K
Graphics
RX580
Thanks. Can you tell me the main differences of using one and another?

As I understand it...

Removing WhateverGreen, you'll lose a couple of the ports on your GPU. (Someone posted a possible patch to restore them but I don't know if it actually works)

Removing AppleALC, you'll lose onboard audio (3.5mm jack outputs & iGPU audio)

EDIT: To clarify, if you need audio from inbuilt components, you need AppleALC. If you are using a USB interface then that will work without AppleALC.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,621
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
As I understand it...

Removing WhateverGreen, you'll lose a couple of the ports on your GPU. (Someone posted a possible patch to restore them but I don't know if it actually works)

Removing AppleALC, you'll lose onboard audio (3.5mm jack outputs & iGPU audio)
AppleALC is needed for audio, don't remove it
 
Joined
Apr 24, 2018
Messages
68
Motherboard
Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU
i7-8700K
Graphics
RX580
AppleALC is needed for audio, don't remove it

Erm, I said it is needed for inbuilt audio... which is correct. I use a USB interface and as such do not require inbuilt audio.

Removing AppleALC means I can take advantage of WhateverGreen and not have panics after sleep.


It is perfectly acceptable to suggest both options, as both options solve the panic. It is up to the user to decide which route they want to take based on the side-effects of each option and how that works with their set up.
 
Joined
Jan 9, 2011
Messages
90
Motherboard
Asus Strix Z370-F Gaming
CPU
i7-8700K
Graphics
HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I think the problem was related to my old EFI it was still there, so I completely clean the partitions and now I see the proper clover version loading but I am still stuck on install I can’t get it to the install screen, it stuck on this part (attachment).

do I need any special kext or flag?
 

Attachments

  • 0695FAF0-5C91-4050-B798-8BAB23F30924.jpeg
    0695FAF0-5C91-4050-B798-8BAB23F30924.jpeg
    3.8 MB · Views: 37

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,552
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I think the problem was related to my old EFI it was still there, so I completely clean the partitions and now I see the proper clover version loading but I am still stuck on install I can’t get it to the install screen, it stuck on this part (attachment).

do I need any special kext or flag?

Did you do a BIOS update? I think the last time I saw someone encounter this, he/she ended up downgrading BIOS.

Please try the following fix:
 
Joined
Jan 9, 2011
Messages
90
Motherboard
Asus Strix Z370-F Gaming
CPU
i7-8700K
Graphics
HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Yeah, I did update the BIOS. But I just tested adding your EFI to the USB and change to 18.1 as I have Intel he 630. I was able to install and boot. Now I need to see if I can boot without the pen drive. :)
 
Top