Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

Joined
May 27, 2011
Messages
221
Motherboard
Asus Z370-A Prime
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
  1. 512K
Mobile Phone
  1. iOS
Yes, every time it’s switched on, it crashes. When off, either definition works.
I had the same issue when using latest LILU & WEG. Try LILU 1.3.9 + 1.3.5 + CLOVER R5104
I solved it by precisely check pastry's config and aligned my config with his config. Over time the config was changed and I was somewhat behind. So you can also start immediately with that config comparrison and try if it works with latest LILU / WEG / CLOVER. (I have same mainboard).
 
Joined
Jan 22, 2019
Messages
27
Motherboard
MSI H370 Bazooka
CPU
i5-8600K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi mates, I just tried to update my Hackintosh Mojave to Catalina but it crashed. Now I am trying to install from 0 but all my tries end with no success.
I used UniBeast 10.0 to create a USB bootable, I used the EFI version that it worked from first installation, the NEJI EFI optioned the one that creates UniBeast) but i have 2 problems:
- The install option is doesn't appear, just REINSTALL (see the picture one)
- I do not know why after some tries, I cannot choose my Samsung M2 Evo SSD to format in Disk Utility; I don't know what did I do wrong.

Please any help???
 

Attachments

  • HKVEycs9R3erpV3HEBqL2A.jpg
    HKVEycs9R3erpV3HEBqL2A.jpg
    3.7 MB · Views: 52
  • A15ozswORg26zLj01xNVSw.jpg
    A15ozswORg26zLj01xNVSw.jpg
    4.2 MB · Views: 51

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,353
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi mates, I just tried to update my Hackintosh Mojave to Catalina but it crashed. Now I am trying to install from 0 but all my tries end with no success.
I used UniBeast 10.0 to create a USB bootable, I used the EFI version that it worked from first installation, the NEJI EFI optioned the one that creates UniBeast) but i have 2 problems:
- The install option is doesn't appear, just REINSTALL (see the picture one)
- I do not know why after some tries, I cannot choose my Samsung M2 Evo SSD to format in Disk Utility; I don't know what did I do wrong.

Please any help???

Try formatting your SSD in Windows to NTFS first.

Choose Reinstall. It should work fine.
 
Joined
Jan 22, 2019
Messages
27
Motherboard
MSI H370 Bazooka
CPU
i5-8600K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Try formatting your SSD in Windows to NTFS first.

Choose Reinstall. It should work fine.

Thank you a lot pastrychef, you have been always so nice with me.

I formatted the SSD and now is recognised! The next problem that I have is, when I am installing and I have to choose disk utility and other options, all my USB doesn't recognise mouse and keyboard, the only one that is working is the one is the USB boot installation, then, I take it off, change everything but, when I choose reinstall it appears an error message "To install macOS, it is required to have an internet connection" (I have my ethernet connected like always without any problem), I do not know if can be a problem related to usb issue?

Any other suggestion?

Thank you so much!
 

Attachments

  • ILjuGV8gQHSAx1mxJqD9Hg.jpg
    ILjuGV8gQHSAx1mxJqD9Hg.jpg
    4 MB · Views: 56
Joined
Jan 22, 2019
Messages
27
Motherboard
MSI H370 Bazooka
CPU
i5-8600K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I changed some BIOS options, and I could continue with installation. I choose language. When it reboots, I choose again boot from USB. But I choose Boot macOS Install from Catalina(the new option), and, when it is in mid installation, it reboots again, and this is a bucle. What do you think?

Thank you.
 

Attachments

  • ciF4lOfjQZ6Dc+0vlbRqGA.jpg
    ciF4lOfjQZ6Dc+0vlbRqGA.jpg
    395.1 KB · Views: 52
  • jvkZ8FkDQeaA73xOvHvNDA.jpg
    jvkZ8FkDQeaA73xOvHvNDA.jpg
    3.8 MB · Views: 47

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,353
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thank you a lot pastrychef, you have been always so nice with me.

I formatted the SSD and now is recognised! The next problem that I have is, when I am installing and I have to choose disk utility and other options, all my USB doesn't recognise mouse and keyboard, the only one that is working is the one is the USB boot installation, then, I take it off, change everything but, when I choose reinstall it appears an error message "To install macOS, it is required to have an internet connection" (I have my ethernet connected like always without any problem), I do not know if can be a problem related to usb issue?

Any other suggestion?

Thank you so much!

Your motherboard uses a Realtek ethernet controller. You must install the Realtek driver to /EFI/CLOVER/kexts/Other/.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,353
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I changed some BIOS options, and I could continue with installation. I choose language. When it reboots, I choose again boot from USB. But I choose Boot macOS Install from Catalina(the new option), and, when it is in mid installation, it reboots again, and this is a bucle. What do you think?

Thank you.

The system will reboot several times during the installation process. This is normal.

Yes, you are selecting the correct boot option.
 
Joined
Jan 22, 2019
Messages
27
Motherboard
MSI H370 Bazooka
CPU
i5-8600K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
As you said, it worked! Now the problem I have is that when I enter to my BIOS to choose the Boot priority to M2 SSD with catalina it doesn't appear so, the only choice to do this is using the bootable usb installer i wait until clover upload the information and then, I can choose Boot macOS from Catalina. What do you think?

If I try to start without USB bootable, It appears the second image

Thank you so much!
 

Attachments

  • AIMpsNgBTu+djkpj%xZQXg.jpg
    AIMpsNgBTu+djkpj%xZQXg.jpg
    2.4 MB · Views: 51
  • bs%bUqHqRTK0y7FliTYpUA.jpg
    bs%bUqHqRTK0y7FliTYpUA.jpg
    1.8 MB · Views: 58

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,353
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
As you said, it worked! Now the problem I have is that when I enter to my BIOS to choose the Boot priority to M2 SSD with catalina it doesn't appear so, the only choice to do this is using the bootable usb installer i wait until clover upload the information and then, I can choose Boot macOS from Catalina. What do you think?

Thank you so much!

You need to copy your EFI folder to the EFI partition of your SSD.
 
Joined
Jan 22, 2019
Messages
27
Motherboard
MSI H370 Bazooka
CPU
i5-8600K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
You need to copy your EFI folder to the EFI partition of your SSD.

Thank you so much again! It worked fine!
I used my EFI folder but, I did some benchmarks and they are quite lower than before, I don't know if this is right but I would like u tell me what do you think and if I could do something wrong.
Maybe some wrong BIOS configuration?
 

Attachments

  • Captura de pantalla 2020-03-20 a las 10.02.28.png
    Captura de pantalla 2020-03-20 a las 10.02.28.png
    62.7 KB · Views: 69
  • Captura de pantalla 2020-03-20 a las 10.08.26.png
    Captura de pantalla 2020-03-20 a las 10.08.26.png
    122.1 KB · Views: 56
  • Captura de pantalla 2019-01-23 a las 23.39.42.png
    Captura de pantalla 2019-01-23 a las 23.39.42.png
    100.2 KB · Views: 59
  • Captura de pantalla 2019-01-23 a las 23.40.06.png
    Captura de pantalla 2019-01-23 a las 23.40.06.png
    121.1 KB · Views: 64
Top