Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hey man first of all wanna say using your info helped me get my hack together/ I'm just having an issue with wifi Fenvi Desktop PC Dual Band Wireless WIFI PCI Express PCI-E Adapter Card 2.4Ghz-150Mbps/5Ghz-300Mbps and it's not reading the wifi set up ( mine is a dual boot so on the windows wide it reads the wifi ) I just want to know if you recommend anything

Which Fenvi model did you get? Not all of their adaptors are Mac compatible. The ones that are Mac compatible are basically plug-n-play.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Ever wonder if the USB3.1 gen 2 ports are really working at USB3.1 gen 2 speeds on this build? Well, here's some proof that they do...

USB3:
USB3 System Info.png USB3 Speed Test.png

USB3.1 gen 2:
USB3.1 System Info.png USB3.1 Speed Test.png
 
Joined
Aug 11, 2012
Messages
332
Motherboard
ASRock Z370M-ITX/ac
CPU
i7-8700K
Graphics
630
If you use iMac17,1 or iMac18,3 system definitions (depending on whether you are using Skylake or Kaby Lake CPU), your Energy Saver system preference pane should change.

The IORegistryExplorer output you attached is corrupt and can not be opened. Please use the version from the following link:
https://www.tonymacx86.com/threads/guide-how-to-make-a-copy-of-ioreg.58368/
Well, I had sleep with one of my many SSDs and no video card installed. When I added the video card back, I couldn't boot without resetting the CMOS. At that point everything went south. I have a feeling that some of my settings in bios are giving me grief because 2 of the SSDs that used to boot the computer now crash. Luckily the Z370 G Gaming still runs fine.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Well, I had sleep with one of my many SSDs and no video card installed. When I added the video card back, I couldn't boot without resetting the CMOS. At that point everything went south. I have a feeling that some of my settings in bios are giving me grief because 2 of the SSDs that used to boot the computer now crash. Luckily the Z370 G Gaming still runs fine.

Are you saying that your ASRock ITX build is not booting?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
At this point I'm beginning to doubt my own sanity.

It seems that the problems began about the time that I upgraded to OsxAptioFix3Drv-64.efi. But I could easily be wrong.

It's possible... If OsxAptioFix3Drv-64.efi doesn't work well for you, you can try AptioMemoryFix.efi instead.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I just tested FileVault with an Apple Wireless Keyboard an it worked fine. So, I think it's safe to say that if your Bluetooth keyboard works in BIOS, it will work with FileVault.
 
Joined
Feb 25, 2018
Messages
7
Motherboard
ASUS ROG STRIX Z370-E
CPU
i5-8600K
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hey pastrychef, thanks for the guide, currently typing this on my hackintosh!

Seems like everything I need is working.

Just a note about 2 sticks of memory. You can use A2 and B2 on the mobo to go with ASUS's recommendations, you just have to specify slots 1 and 3 in your config.plist.

Question about your memory, I noticed you have 3400 mhz ram, do you use XMP to run at 3400 mhz?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,362
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hey pastrychef, thanks for the guide, currently typing this on my hackintosh!

Seems like everything I need is working.

Just a note about 2 sticks of memory. You can use A2 and B2 on the mobo to go with ASUS's recommendations, you just have to specify slots 1 and 3 in your config.plist.

Question about your memory, I noticed you have 3400 mhz ram, do you use XMP to run at 3400 mhz?

Hi.

Yes. I enabled XMP in BIOS to use it at 3466MHz (slightly overclocked).
 
Top