Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,839
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
@pastrychef great work on the delidding! :0 Makes me want to try it myself lol... I see you bought a copper lid. would you recommend against running with no lid at all?

If you have a CPU cooler that can be used without the lid, that would be great. I was forced to use a lid because the Noctua cooler doesn't sit low enough to make contact with the CPU die. If it did, I would have gone without a lid too.
 
Joined
Apr 27, 2015
Messages
78
Motherboard
Asus Maximus X Hero
CPU
i9-9900K
Graphics
Vega 64
Thanks for the info. I'll update post #1 with the info later.

Edit:
If you have time, can you please try shikigva=61? Thanks.

@pastrychef, I gave shikigva=61 a try, and it breaks both DRM and h.264 hardware encoding. So only shikigva=1 succesfully enabled DRM for me. Flags 57 and 61 result in both DRM and hardware encoding being broken, and Flag 60 or removing all boot arguments result in working hardware encoding with broken DRM. I'll try some of the intermediary codes between 1 and 57, but from what I understand of the shiki flags, there's probably not much likelihood of success of enabling both DRM and hardware encoding with the 9900k, at least with the current builds of Mojave and WEG.
 
Joined
Jul 29, 2018
Messages
119
Motherboard
ASUS Z370-G WIFI
CPU
i7-8700K
Graphics
UHD630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
So, I did a bit internet digging and I found that post on https://egpu.io/ where user theitsage found a kext for Radeon VII

"Public Beta of 10.14.4 [18E174f] has slightly newer drivers than developer beta. There's a new PCI ID 66af that identifies as Radeon VII in AMD10000Controller.kext and AMDRadeonX5000HWServices.kext."

384916
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,839
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
@pastrychef, I gave shikigva=61 a try, and it breaks both DRM and h.264 hardware encoding. So only shikigva=1 succesfully enabled DRM for me. Flags 57 and 61 result in both DRM and hardware encoding being broken, and Flag 60 or removing all boot arguments result in working hardware encoding with broken DRM. I'll try some of the intermediary codes between 1 and 57, but from what I understand of the shiki flags, there's probably not much likelihood of success of enabling both DRM and hardware encoding with the 9900k, at least with the current builds of Mojave and WEG.

I'm using shikigva=1 with my 9900K and it seems that hardware encoding is working.
384936384937
 
Joined
Feb 13, 2018
Messages
53
Motherboard
ASUS ROG Strix Z370-G Gaming
CPU
i7-8700K
Graphics
HD 630
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Try searching for info on "Windows UEFI installation".

All of the following are KextsToPatches to address the 15 port limit. There are so many because the patches broke with many new macOS releases and a new patch was necessary. So, we end up with this mess...
View attachment 384831
You can either (1) check the disabled boxes to disable them or (2) click the minus (-) sign to delete them.

Fantastic, thank you!

Please consider also adding this very helpful image on page 1 :)
 
Joined
Jan 25, 2019
Messages
23
Motherboard
Z370-G
CPU
I7 9700K
Graphics
GTX1060
Please try booting in to Verbose mode and post a picture of where it gets stuck.

I boot in verbose mode with GPU off the PC. I got "Attempting system restart... MACH Reboot"
I used the efi 4.3.2 (high Sierra). My board is z370-g + 9700k.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,839
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I boot in verbose mode with GPU off the PC. I got "Attempting system restart... MACH Reboot"
I used the efi 4.3.2 (high Sierra). My board is z370-g + 9700k.

That's not enough. I need more info. Please take a picture of the verbose screen.
 
Joined
Jan 25, 2019
Messages
23
Motherboard
Z370-G
CPU
I7 9700K
Graphics
GTX1060
That's not enough. I need more info. Please take a picture of the verbose screen.
384999

Thanks again in such fast response. Here is the screenshot of where its stuck at.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,839
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Top