Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,559
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
You are welcome! I am very grateful that you helped us with our Hackintosh build, so I am willing to help anytime. If you want, I could make some custom kexts that fit your need or more testing.
For my personal experience, I was using the RadeonVegaLowFansSpeed.kext, which works fine, but I did notice some terrible scroll lag on applications like IOregistryExplore. The scroll was very laggy. After using the Chinese kexts, it fixes the scroll lag issue for me. I am not sure it is the new kext that fix it or something else, i jsut want to share this with you. maybe you have some methods to test these kexts.

I think the best way to test is just to use it on a daily basis for a few days.

The RadeonVegaLowFansSpeed.kext worked very well for me except for one very old game that I played. It is an old game and graphics are very simple, but it caused the fan on my Vega to run at full speed. Not sure if it's just bad programming on the game or a driver issue or something else...
 
Joined
Nov 23, 2017
Messages
18
Motherboard
Asus z370i
CPU
I7 8700k
Graphics
Amd vega 64
I think the best way to test is just to use it on a daily basis for a few days.

The RadeonVegaLowFansSpeed.kext worked very well for me except for one very old game that I played. It is an old game and graphics are very simple, but it caused the fan on my Vega to run at full speed. Not sure if it's just bad programming on the game or a driver issue or something else...

Yea good point. I will try this kext for some time. BTW I made a mistake that the kexts I upload last time had max TDP set to 80%. I will attach one below with Max TDP set to 150%.
 

Attachments

  • VegaTab_56.kext.zip
    2.3 KB · Views: 586
Joined
Jul 4, 2018
Messages
30
Motherboard
Asus ROG Strix Z370-G Gaming-Clover
CPU
i5-8400
Graphics
Sapphire Pulse Radeon RX 570 4G GDDR5
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
Go to System Information>Memory to see how your memory is shown. If incorrect, make changes in your config.plist.
Use the Idiot's Guide iMessage for instructions on how to set up Serial, Board Serial, and UUID.

Thanks again, also for the guide. Memory is presented correct.

Another thing, I purchased a Samsung SSD T5 a while ago, when my primary computer began to inflate, for backup purposes. I placed your EFI (HD630) on it. I am working from it now, and both 1. gen. and 2. gen. 3.1 USB-ports performs with around 500MB/s read and write, giving the computer quite a snappy gefühl. That makes one wonder, whether we in reality needs internal drives or not. Ha ha ha, funny how things turns out.
 
Last edited:
Joined
Jun 13, 2012
Messages
55
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i5 8400
Graphics
UHD 630
Hi, everything was working, until I just made the update to : Clover 4617 + Lilu-1.2.5 + WhatEverGreen-1.2.0. There is a kernel panic during boot.
I've got an Asus Rog Strix Z370-E + i5 8400 + Evo 970. No dedicated graphic card, only iGPU.
Here is my Clover Folder.
What am I missing ?
Thanks.
 

Attachments

  • MyCLOVER.zip
    2.4 MB · Views: 126

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,559
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi, everything was working, until I just made the update to : Clover 4617 + Lilu-1.2.5 + WhatEverGreen-1.2.0. There is a kernel panic during boot.
I've got an Asus Rog Strix Z370-E + i5 8400 + Evo 970. No dedicated graphic card, only iGPU.
Here is my Clover Folder.
What am I missing ?
Thanks.

Your config.plist seems corrupt. Also, you don't need Inject Intel in graphics sections with new WhateverGreen.
 
Joined
Jun 13, 2012
Messages
55
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i5 8400
Graphics
UHD 630
For the Intel Inject, I've just copied from the config.plist from your EFI Unified r4.1. So I'll remove this section.
What do you mean by my corrupt config.plist ? So missing closing tag ?
 
Last edited:
Joined
Jun 13, 2012
Messages
55
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i5 8400
Graphics
UHD 630
So, I've removed the Intel Inject section, and it worked ;-) Thank you.
 
Last edited:
Joined
Apr 7, 2014
Messages
183
Motherboard
MSI Z370i Pro Gaming Carbon AC
CPU
i3-8100
Graphics
RX460
Mobile Phone
  1. iOS
Your config.plist seems corrupt. Also, you don't need Inject Intel in graphics sections with new WhateverGreen.

@pastrychef
First off, sorry if this is the wrong place to ask.
I have Intel 8100 + RX460. Updated Lilu + WEG. Should I remove the Inject Intel and ig-platform-id as well?

Thanks.
 
Joined
Jul 12, 2016
Messages
2,931
Motherboard
Gigabyte Z370 Gaming 5
CPU
i9-9900K
Graphics
RX 6900 XT
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Joined
Jul 12, 2016
Messages
2,931
Motherboard
Gigabyte Z370 Gaming 5
CPU
i9-9900K
Graphics
RX 6900 XT
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Hi, pastrychef,

I am a native Chinese speaker, and I was able to try out the Chinese app you mention about in the latest update. It is a very similar method to this
https://www.insanelymac.com/forum/t...n-high-sierra/?do=findComment&comment=2614653
The above method requires you to edit the powertable in windows and then copy the code to mac and then put in the kexts. The Chinese app is basically simplified all the steps above into one simple click. You first click on the app, and it will open an HTML, and you will able to set your desired frequency, voltage, fan speed, and power limit. On the bottom of the HTML, you can generate the kext automatically. I have generated two kexts by using this app.

vega64: stock frequency voltage, idle fan speed:800, max:4900, target temp:55c
vega56: stock frequency voltage, idle fan speed:800, max:4900, target temp:55c

I used the 56 one seems to work faster then the other one that I used to use. Fan spins up quickly when put under load and drops off as quickly as the load is removed. Seemed like it was within a few second. I will keep trying it out over the next few days.
 
Top