Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

corint1

Suspended
Joined
Aug 16, 2017
Messages
417
Motherboard
ASUS MAXIMUS X HERO WI-FI AC
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I did a build for a friend using a Sapphire RX 580 Pulse and it was extremely simple. Pretty much plug-n-play. She has also been very happy with performance.
Maybe she does not have big claims, I repeat, big problems in graphics and video editing programs .... To export in H264 format had to be made many changes and attempts ... A whole day ... Lost for nothing ... Tomorrow they are returning
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
That would be nice to try. Thank you. My plan hereafter is trying your Strix-G-specifik EFI, and custom port configuration for displayports, and doing the Toleda/CloverALC-rainmakerwaltz.

Remember to copy/paste your Serial, Board Serial, UUID, and memory settings to the new config.plist.
 

Attachments

  • EFI for Intel UHD630 r3.5.zip
    33.7 MB · Views: 109
Joined
Jul 4, 2018
Messages
30
Motherboard
Asus ROG Strix Z370-G Gaming-Clover
CPU
i5-8400
Graphics
Sapphire Pulse Radeon RX 570 4G GDDR5
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
Remember to copy/paste your Serial, Board Serial, UUID, and memory settings to the new config.plist.

Thank you. You got me there, I have not reached to the task to fix those items.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
work? have you tested? it seems to me that it's still in beta and does not work as it says

I've been on it for the last 2-3 days.
 
Joined
Jul 4, 2018
Messages
30
Motherboard
Asus ROG Strix Z370-G Gaming-Clover
CPU
i5-8400
Graphics
Sapphire Pulse Radeon RX 570 4G GDDR5
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
Remember to copy/paste your Serial, Board Serial, UUID, and memory settings to the new config.plist.

Oh, thats the generic one.
It would be interesting to in fact see some EFIs from completed and throughly tested computer configurations build on the Asus ROG Strix Z370-G Gaming, for instance to identify what is hardware failure and whats is failures of configuration.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Oh, thats the generic one.
It would be interesting to in fact see some EFIs from completed and throughly tested computer configurations build on the Asus ROG Strix Z370-G Gaming, for instance to identify what is hardware failure and whats is failures of configuration.

I can't test multi-monitor because I only have one monitor.
 
Joined
Apr 1, 2017
Messages
374
Motherboard
Asus Z370-I
CPU
i7-8700
Graphics
RX 5700
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
(removed)...Preview doesn't have good editing tools. :(
 
Joined
Jul 4, 2018
Messages
30
Motherboard
Asus ROG Strix Z370-G Gaming-Clover
CPU
i5-8400
Graphics
Sapphire Pulse Radeon RX 570 4G GDDR5
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
Remember to copy/paste your Serial, Board Serial, UUID, and memory settings to the new config.plist.

Sigh I been working on this project very very hard for two weeks, and I can not configure the build to be rock solid.
It renders my machine unstable trying to keep it floating with dual monitors.

When I configure USB ports, the audio disappears. It is realized that dual monitors probably needs custom configuration also.
I did not get to the point were I installed the audio ad modus Toleda, because it seems an obvious thing to clear problems away caused by the displays. I also had some cleaning after using Multibeast in front of me.

So I am glad, that I am back where I started thanks to you. I think I lost a little track under way, it would probably have been hard for me to settle what to do.
It is very comfortable to use your EFI for Intel UHD630 r3.5.zip , to hell with correct setting of USB ports for now.
I have a lot of work to be done.
The EFI for Intel UHD630 r3.5.zip gives me a working machine, with audio. It can not start with dual monitors. I have to wait to connect the HDMI-cable till after start-up. But it does not crash when I do that, as before.
I can wake the computer from the keyboard which also was broken.
It appears at that ASUS implementation of multiple monitors invokes some sort of changes in port routing given one of two monitors are used, because it is also pathways for both video and audio.

1. "Remember to copy/paste your Serial, Board Serial, UUID, and memory settings to the new config.plist."
I can not find the memory settings in the config.plist.
2. where can I read more about this issue?
3. I posted my EFI here, do I have to generate new serial, board serial and UUID?

Thank you.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,841
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Sigh I been working on this project very very hard for two weeks, and I can not configure the build to be rock solid.
It renders my machine unstable trying to keep it floating with dual monitors.

When I configure USB ports, the audio disappears. It is realized that dual monitors probably needs custom configuration also.
I did not get to the point were I installed the audio ad modus Toleda, because it seems an obvious thing to clear problems away caused by the displays. I also had some cleaning after using Multibeast in front of me.

So I am glad, that I am back where I started thanks to you. I think I lost a little track under way, it would probably have been hard for me to settle what to do.
It is very comfortable to use your EFI for Intel UHD630 r3.5.zip , to hell with correct setting of USB ports for now.
I have a lot of work to be done.
The EFI for Intel UHD630 r3.5.zip gives me a working machine, with audio. It can not start with dual monitors. I have to wait to connect the HDMI-cable till after start-up. But it does not crash when I do that, as before.
I can wake the computer from the keyboard which also was broken.
It appears at that ASUS implementation of multiple monitors invokes some sort of changes in port routing given one of two monitors are used, because it is also pathways for both video and audio.

1. "Remember to copy/paste your Serial, Board Serial, UUID, and memory settings to the new config.plist."
I can not find the memory settings in the config.plist.
2. where can I read more about this issue?
3. I posted my EFI here, do I have to generate new serial, board serial and UUID?

Thank you.

Go to System Information>Memory to see how your memory is shown. If incorrect, make changes in your config.plist.
Use the Idiot's Guide iMessage for instructions on how to set up Serial, Board Serial, and UUID.
 
Top