Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
If I have your config, but without dedicated graphic card, only iGPU, should I install these kexts NvidiaGraphicsFixup.kext and WhateverGreen.kext ?
Thanks.

They aren't needed if you are using IGPU, but having them there should not cause any problems either.
 
Joined
Jun 28, 2013
Messages
41
Motherboard
Asus Strix H370i
CPU
i7-8700K
Graphics
Red Devil 5600XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iBook
  2. iMac
  3. Power Mac
  4. PowerBook
Mobile Phone
  1. iOS
This is my results without changing anything for the Vega 56. It's a Sapphire Nitro RX Vega 56 (not limited edition). No Noise at all (in games or else) and I'm pretty picky with noises... My only problems is the temp on the 8700k with the NZXT 52 while doing an handbrake encoding : 85°C max. Also this is with a Samsung 960 Pro 512 Gb.

Edit : on macOS 10.13.5
Edit 2: The 8700k is running at stock (no overclocking and no delidding )

utG4U6s.png
c8gj7AY.png
5Iuj9rU.png
QqdQERp.png
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
This is my results without changing anything for the Vega 56. It's a Sapphire Nitro RX Vega 56 (not limited edition). No Noise at all (in games or else) and I'm pretty picky with noises... My only problems is the temp on the 8700k with the NZXT 52 while doing an handbrake encoding : 85°C max. Also this is with a Samsung 960 Pro 512 Gb.

Edit : on macOS 10.13.5
Edit 2: The 8700k is running at stock (no overclocking and no delidding )

utG4U6s.png
c8gj7AY.png
5Iuj9rU.png
QqdQERp.png

Unfortunately, a triple slot video card is not an option for me. I need the adjacent PCI-e slot. I'm also not a fan of open coolers on video cards. I had an open cooler GTX 680 in the past and by not pushing the heat out of the case, it contributed to hotter running CPU. I don't know if an open cooler would affect a water cooled CPU.

If your CPU is not overclocked, it should not be running that hot. My CPU has never hit 80C even with my overclock. I tested by queuing up a bunch of videos in Handbrake and left it running overnight. Maybe a different thermal compound will work better for you...
 
Joined
Apr 1, 2017
Messages
305
Motherboard
Asus Z370-G WiFi AC
CPU
i7-8700K
Graphics
RX 5700
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
OS: 10.13.5

Asus Z370-I (ITX) with DSDT from Asus Z370-G (Madone)
HP EX720 NVME with Asus heatsink on it
Radeon RX580

1672.8 MB/s write
2891.7 MB/s read

LuxMark 3.1 gives 15478, with a Radeon RX580, 36 @ 1366 mhz.

Heaven is a decade old, so I focused on Valley, running the same specs as the prior post, 1920x1080, 8xAA, Ultra:
FPS 47.4
Score: 1985
Min FPS: 28.2
Max FPS: 83.4

System: Darwin 17.6.0 X86_64
CPU Model: I7-8700 @ 3.2
GPU Model: RX580 (256MB) X1
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
OS: 10.13.5

Asus Z370-I (ITX) with DSDT from Asus Z370-G (Madone)
HP EX720 NVME with Asus heatsink on it
Radeon RX580

1672.8 MB/s write
2891.7 MB/s read

LuxMark 3.1 gives 15478, with a Radeon RX580, 36 @ 1366 mhz.

Heaven is a decade old, so I focused on Valley, running the same specs as the prior post, 1920x1080, 8xAA, Ultra:
FPS 47.4
Score: 1985
Min FPS: 28.2
Max FPS: 83.4

System: Darwin 17.6.0 X86_64
CPU Model: I7-8700 @ 3.2
GPU Model: RX580 (256MB) X1

What does the DSDT fix?
 
Joined
Apr 1, 2017
Messages
305
Motherboard
Asus Z370-G WiFi AC
CPU
i7-8700K
Graphics
RX 5700
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
PCI listings in System Report. Aside from that your EFI (nVidia was what I started with) was perfect.
 
Joined
Apr 1, 2017
Messages
305
Motherboard
Asus Z370-G WiFi AC
CPU
i7-8700K
Graphics
RX 5700
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Only thing I haven't gotten working yet is my Apple Watch (login). I know BT works because I can pair with a BT mouse, so something else is wrong. Time to log out of iCloud, log in, and see if that fixes it. :(
 
Joined
Apr 1, 2017
Messages
305
Motherboard
Asus Z370-G WiFi AC
CPU
i7-8700K
Graphics
RX 5700
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
...and the DSDT may have also cleaned up my audio output listings, because I just noticed (it might be 10.13.5 doing this too) that my speakers output is cleaned up:

1. My AppleTV
2. Digital Out
3. Internal Speakers
4. Line Out
5. Line Out
6. (HDMI) - MyMonitorBrandAndModel

Hmm...maybe this is what I had before. Don't remember the monitor being there.
 
Joined
Apr 1, 2017
Messages
305
Motherboard
Asus Z370-G WiFi AC
CPU
i7-8700K
Graphics
RX 5700
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Only thing I haven't gotten working yet is my Apple Watch (login). I know BT works because I can pair with a BT mouse, so something else is wrong. Time to log out of iCloud, log in, and see if that fixes it. :(

Sigh. Looks like per http://www.idownloadblog.com/2015/10/16/how-to-find-your-macs-bluetooth-version/ that my BT card (a 4360CS2, IIRC, that I got secondhand from Amazon for $20 or so) is LMP Version 4 (which means BT2.1) so ... I can't use it with my Apple watch.

:(

Putting this little thing into the motherboard was a PITA; it has the (even) smaller of the two tiny antenna standards. I don't relish replacing it. We'll see; I suspect I'll manage with this for a while. :(

Agh! Per https://support.apple.com/en-us/HT206995 I show (Wifi, granted, not BT - but shouldn't Apple have the smarts to figure that out, since it's all one device?) -- "Auto Unlock: Supported" so it _should_ work. Agghh.....
 
Top