Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,540
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Updating cause I just got home. But I tried the EFI, and I was greeted with this. Could be a couple problems because my drive isn’t partitioning right with an EFI and a regular partition, and I think it’s because I didn’t have the right setting or previous format. I’ll check it out, and let you know.

Just put the EFI on the EFI partition of a USB flash drive and boot from the USB flash drive.
 
Joined
Aug 25, 2019
Messages
77
Motherboard
ASUS ROG X MAXIMUS HERO (WIFI AC)
CPU
I7-8700K
Graphics
560
Mac
  1. iMac
Mobile Phone
  1. iOS
Just put the EFI on the EFI partition of a USB flash drive and boot from the USB flash drive.
Done, and I got the same message. I think I remember the problem with no idea how to fix it. During my try at getting Mojave, I had a problem when i couldn’t get the full installer, only a 6GB one. Same thing with Catalina although it’s 8GB. I was attempting a patcher, because the terminal commands didn’t work,. But there was an error. I used csrutil disable. I could get it started but it always failed right at the end. Any ideas on how I could get the full installer to make the boot?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,540
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Done, and I got the same message. I think I remember the problem with no idea how to fix it. During my try at getting Mojave, I had a problem when i couldn’t get the full installer, only a 6GB one. Same thing with Catalina although it’s 8GB. I was attempting a patcher, because the terminal commands didn’t work,. But there was an error. I used csrutil disable. I could get it started but it always failed right at the end. Any ideas on how I could get the full installer to make the boot?

 
Joined
Aug 25, 2019
Messages
77
Motherboard
ASUS ROG X MAXIMUS HERO (WIFI AC)
CPU
I7-8700K
Graphics
560
Mac
  1. iMac
Mobile Phone
  1. iOS
Very helpful, was just waiting for all the downloads. Currently creating my bootable drive now. I used Catalina just because I personally can't run some of the programs I use on Big Sur, as there isn't support. Should I still use the most recent refi (open core 0.6.7 Z370G)?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,540
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Alright. is there any specific MAC address to change it to, or how do I find one that's good for me

Use the MAC address of the built-in Ethernet of your motherboard. You can leave it until you boot in to macOS. Then look in System Preferences > Network > Ethernet > Advanced > Hardware to find your MAC address.
 
Joined
Aug 25, 2019
Messages
77
Motherboard
ASUS ROG X MAXIMUS HERO (WIFI AC)
CPU
I7-8700K
Graphics
560
Mac
  1. iMac
Mobile Phone
  1. iOS
Use the MAC address of the built-in Ethernet of your motherboard. You can leave it until you boot in to macOS. Then look in System Preferences > Network > Ethernet > Advanced > Hardware to find your MAC address.
perfect, just waiting for files to copy, and I should be good. Swear the stupidest things get me. Figured I would check all my steps, and the GUID partition... Thank you for putting up with my questions haha
 
Joined
Aug 25, 2019
Messages
77
Motherboard
ASUS ROG X MAXIMUS HERO (WIFI AC)
CPU
I7-8700K
Graphics
560
Mac
  1. iMac
Mobile Phone
  1. iOS
perfect, just waiting for files to copy, and I should be good. Swear the stupidest things get me. Figured I would check all my steps, and the GUID partition... Thank you for putting up with my questions haha
Currently on a black screen, it should be loading shortly. I chose it to boot of the EFI once loading in, I assume that’s what I should have done? Again, I have no experience with OpenCore. HaHa!
 
Joined
Jul 12, 2016
Messages
2,928
Motherboard
Gigabyte Z370 Gaming 5
CPU
i9-9900K
Graphics
RX 6900 XT
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Hey Everyone, I'm debating upgrading my CPU from the i7-8700K to the i9-9900K, and I can't really make up my mind about it. I'm sort of waiting to see what the desktop/iMac M1 comps are going to be, and I don't want to spend too much money because I have a feeling they're going to be pretty good. Did anyone do this upgrade and think that it was worth it? Looks like I have to spend around $350 to get the chip.

FYI, I use my hack for work. I do a lot of graphic design, editing, 2D & 3D motion graphics. I would say that I'm a power user.

Thank you!

Many users including myself have done that upgrade and I believe that Pastry even had it clocked @ 5.0ghz on all cores if you're into that kind of stuff.

Will you benefit from the extra 2 cores? Sure;
Will you notice a huge performance increase? probably not.

I notice very small reduction in the time it takes to encode stuff, or export rendering images. I also notice when looking at the % of the CPU used. Since I run a windows VM the extra few cores was helpful.
 
Top