Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Make sure everything is stable before attempting to overclock. If the system is unstable and you overclock, you won't know if the problem is the overclock or with your hackintosh configuration when you experience problems.

Leave it disabled for now.

Thanks Pastry My z-370 is more stable with the changes you had me do. I had projects to edit and finish but eventually will want to OC the processor and memory.

I received a "new" system yesterday: Asus z270 p prime and I7 7700k. I'll put and Rx 580 pulse in it for the install but I have ordered an rx 5700 xt, so I'd like ton install Catalina on that one.


Which of your efi folders, sys def and Clover build to create the install thumb drive would you reccommend ?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thanks Pastry My z-370 is more stable with the changes you had me do. I had projects to edit and finish but eventually will want to OC the processor and memory.

I received a "new" system yesterday: Asus z270 p prime and I7 7700k. I'll put and Rx 580 pulse in it for the install but I have ordered an rx 5700 xt, so I'd like ton install Catalina on that one.


Which of your efi folders, sys def and Clover build to create the install thumb drive would you reccommend ?

The Clover EFI from post #1 should work for Z270 with little to no changes. Just choose an appropriate system definition for Z270.
 
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
upon install, I get : an error occurred validating the installer data..download Is either damaged or incomplete...would that have anything to do with what you mentioned?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
upon install, I get : an error occurred validating the installer data..download Is either damaged or incomplete...would that have anything to do with what you mentioned?

It looks unrelated. Try redoing your USB installer.
 
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Which of these drivers are mandatory for the USB installer, because I tried with all of these I got a blank screen...when I only used APFSDriverloader, HFSplus and virtual SMC I got to the clover boot loader menu at least....
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Which of these drivers are mandatory for the USB installer, because I tried with all of these I got a blank screen...when I only used APFSDriverloader, HFSplus and virtual SMC I got to the clover boot loader menu at least....

None of those drivers should cause a black screen.

The only ones that are not essential are AppleGenericInput, AppleUISupport and VirtualSmc.
 
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
New USB installer did the trick. Post install ?... add 18.3 SMBIOS to EFI Clover r5120 Z370G (Catalina) v2 plist with serial - adjust other folder with the right and latest kexts - remove devices entries in the plist (there are still some in this one ?) - remove Z390 sub folders in OEM ? - Remove patched SSDT-EC-USBX in ACPI ? then...

Up and running, so far only wi-fi does not work....thankfully yours ;)
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,537
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
New USB installer did the trick. Post install ?... add 18.3 SMBIOS to EFI Clover r5120 Z370G (Catalina) v2 plist with serial - adjust other folder with the right and latest kexts - remove devices entries in the plist (there are still some in this one ?) - remove Z390 sub folders in OEM ? - Remove patched SSDT-EC-USBX in ACPI ? then...

Up and running, so far only wi-fi does not work....thankfully yours ;)

All the kexts should already be latest release versions.
You shouldn't need to remove SSDT-USBX.
You can delete the Z390 sub folder.
The only device property in config.plist is for audio. There's a very high likelihood that it's the same path as your Z270.

This really shows how similar Z270 and Z370 are. Z370 shares more in common with Z270 than with B360 or Z390.
 
Last edited:
Top