Contribute
Register

P9X79 Pro Guide (still a work in progress)

Status
Not open for further replies.
Joined
Jun 27, 2011
Messages
56
Motherboard
Asus P9X79 Pro-2104
CPU
i7-3930K
Graphics
2x GTX 680
P9X79 Pro OS X 10.9 Mavericks Install Guide

Quirks:
- Need a working OSX setup (Hackintosh preferred) even during execution of Multibeast
- Booting off the Unibeast USB is a hit and miss on my test (usually gets stuck with Spinning Beach Ball of Death but sometimes it shows the mouse arrow)

Specs:
P9X79 Pro (4502 BIOS)
- (BIOS Settings)
- VT Disabled
- Bluetooth/USB3.0/Marvell SATA storage disabled
- Secure Boot disabled
i7 3930K CPU @stock
GTX 470 @stock

Steps:
Create the Unibeast Mavericks USB as instructed
Override the /Extra/org.chameleon.Boot.plist file on the USB with the following changes
GraphicsEnabler - Yes
IGPEnabler - No
Kernel Flags:
-f cpus=1 npci=0x3000 darkwake=0

Install Mavericks by booting to the Unibeast USB
Select the Unibeast USB ignoring any arguments
Quirk #1:
- if on the white screen (way past apple logo), the cursor becomes a spinning wheel, restart it because it's stuck
- however, if it shows the mouse pointer arrow, JUST WAIT! It will eventually show the first install dialog box
From there, you can install OSX as you normally would
Quirk #2
Reboot from a working OSX setup to run Multibeast

Run Multibeast: Choose the following
- EasyBeast
- Build; Select the drive where you just Installed Mavericks and Click Install
Quit Multibeast
Run Multibeast: Choose to install the following
- Network > Intel - hnak...
- System > AppleACPIPlatform Rollback > 10.8.1
- Choose Build ; Select the drive where you just Installed Mavericks and Click Install
Quit Multibeast
Verify the Extra/org.chameleon.Boot.plist file on the drive where you installed Mavericks making sure it has the following
GraphicsEnabler - Yes
IGPEnabler - No
Kernel Flags:
-f npci=0x3000 darkwake=0

Reboot onto the drive where you installed Mavericks to finish off the installation

You can then enable the rest of the onboard devices
- Marvell and ASM SATA
- USB 3.0 Controllers

After which you can re-run Multibeast and install the drivers for the following:
- 3rd party SATA
- USB 3.0

What works:
- Graphics
- 6-core CPU without VoodooTSCSync
- LAN
- 3rd party SATA
- 3rd party USB 3.0 fixed via this http://www.tonymacx86.com/mavericks...pro-guide-still-work-progress.html#post713158

Untested yet:
- Sleep
- Sound
- Bluetooth
 
Joined
Nov 25, 2013
Messages
70
Motherboard
P9X79 Pro
CPU
Xeon > need model #E5-2697V2
Graphics
Radeon VII
Hello,

Can you confirm USB3 works well ? I've read ASMedia USB3 couldn't work for OS Montain Lion. It's OK now with Mavericks ?

Currently, i've got a GTX580 video card. If i plug later a second video card to get a second GPU, will it be recognized ? I plan to buy a GTX 780.

Thanks for your tutorial.
 
Joined
Nov 25, 2013
Messages
70
Motherboard
P9X79 Pro
CPU
Xeon > need model #E5-2697V2
Graphics
Radeon VII
Helpppp

The install is going fine until the disk utility where to install OS X. It can't see the SSD plugged on the SATA Port (Intel). Of course, i have AHCI enabled and only one drive connected.

Any ideas ?

Thank you.

EDIT : It has worked with "-v -f cpus=1 npci=0x2000 darkwake=0"
EDIT2 : Most of installation is done successfully except the USB3 for which i didn't understand your solution :(
EDIT3 : USB3 fixed with the method ! A bit hard to understand for a total newbie, but the forum helped a lot
 
Joined
Nov 21, 2013
Messages
1
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iBook
  2. iMac
  3. PowerBook
  4. Quadra
Mobile Phone
Everything is working like a charm, except audio which seems to be a tricky one.
Tried ALC898 with HDAEnabler1 with Multibeast6, both with and without DSDT.

Sleep and power management just seems to work without any special requirement.
Haven't tried bluetooth so far.
 
Joined
Jun 27, 2011
Messages
56
Motherboard
Asus P9X79 Pro-2104
CPU
i7-3930K
Graphics
2x GTX 680
@Lucius: glad that it worked. :) im sorry but im worried that by posting the USB 3.0 download link might be risky here. for the benfit of others, once you downloaded the necessary KEXT file, all you need to download is a KEXT loader (kext utility or something similar).

it happened in my case also when the installer did not detect any HDD. i just rebooted and restarted the installation.

@motorfregna: wow that's glad to hear! may i know the specs of your rig?
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,782
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
The USB 3.0 Universal driver has been updated in MultiBeast 6.01.
 
Joined
Jun 27, 2011
Messages
56
Motherboard
Asus P9X79 Pro-2104
CPU
i7-3930K
Graphics
2x GTX 680
The USB 3.0 Universal driver has been updated in MultiBeast 6.01.
@Stork: I have used that updated one. The device was detected but I am having problems reading off from the USB 3.0 NTFS-formatted HDD.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,782
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
@Stork: I have used that updated one. The device was detected but I am having problems reading off from the USB 3.0 NTFS-formatted HDD.
Aha! IIRC, Apple hasn't supported NTFS formatted drives since...Leopard (10.5)? You'll probably have to look into Tuxera or Paragon NTFS. (Disclaimer: I only use OS X, no other OS.)
 
Joined
Jun 27, 2011
Messages
56
Motherboard
Asus P9X79 Pro-2104
CPU
i7-3930K
Graphics
2x GTX 680
Aha! IIRC, Apple hasn't supported NTFS formatted drives since...Leopard (10.5)? You'll probably have to look into Tuxera or Paragon NTFS. (Disclaimer: I only use OS X, no other OS.)

That, i have not tried yet though: hfs formatted usb 3.0 drive plugged into a non-intel usb 3.0 port
 
Joined
Nov 25, 2013
Messages
70
Motherboard
P9X79 Pro
CPU
Xeon > need model #E5-2697V2
Graphics
Radeon VII
Hi all,

I plan to move from my GTX580 to the GTX Titan, on the same slot. Should i do something before this hardware upgrade ? I've got the same hardware and software configuration as edmoncu.

Thanks
 
Status
Not open for further replies.
Top