Contribute
Register

OSX Sierra - Got AtherosL1cEthernet.kext to work with Z77-MX-D3H

Status
Not open for further replies.
Joined
Mar 16, 2011
Messages
38
Motherboard
GA-Z77MX-D3H
CPU
i7-3770
Graphics
Asus GTX 970
Hi Guys, i need your help !
I installed Sierry right now, and everything is running great, even patched AppleHDA for VIA VT 2021 - except Ethernet !
I have a GA-Z77-MX-D3H and up to El Capitan i used AtherosL1cEthernet.kext, which always worked for me.

But now i can't get it to work. In System Preferences he shows me Ethernet, but tells me, i am not connected. But i am.
So what i am doing wrong ? Is there a better kext for me ? Btw, it is the Atheros GbE LAN chip (10/100/1000 Mbit).

Thanx in advance.

Jazzman
 
Joined
Mar 16, 2011
Messages
38
Motherboard
GA-Z77MX-D3H
CPU
i7-3770
Graphics
Asus GTX 970
Ah, just read in this forum, someone got a z77 ds5h to work with ALXEthernet. Tried that and voila- got it :clap:!
So, I assume, everyone who used AtherosL1c should give ALXEthernet a chance.
 
Joined
Jan 13, 2010
Messages
362
Motherboard
Aorus X570 Elite
CPU
Ryzen 7 3700X
Graphics
Vega 64
Mac
  1. iMac
Classic Mac
  1. Apple
  2. eMac
  3. iMac
  4. LC
  5. Power Mac
Mobile Phone
  1. iOS
Ah, just read in this forum, someone got a z77 ds5h to work with ALXEthernet. Tried that and voila- got it :clap:!
So, I assume, everyone who used AtherosL1c should give ALXEthernet a chance.

However, ALXEthernet causes a kernel panic restart when I sleep. :banghead:

How is sleep for you?
 
Joined
Mar 16, 2011
Messages
38
Motherboard
GA-Z77MX-D3H
CPU
i7-3770
Graphics
Asus GTX 970
Bansaku, my sleep (and restart or shutdown !!!) doesnt work too :(, he neither goes to sleep nor shuts down or restarts. No solution till now. Anyone out there with Atheros Lan Chip who got a solution for us ?
 
Joined
Mar 16, 2011
Messages
38
Motherboard
GA-Z77MX-D3H
CPU
i7-3770
Graphics
Asus GTX 970
Bansaku, I got it now (sleep works now !), if u have the AR 8151 Atheros, u can do this:
- delete ALXEthernet
- open IONetworkingFamily.kext in S/L/E
- put the attached file to plugins
- repair, rebuild etc. (I added EthernetBuiltIn=Yes to my boot.plist)
- restart

For me, it works like a charm, everything, really everything is working with only FakeSMC, AppleHDA (for VIA VT 2021), and AtherosL1CEthernet !
By the way, I am using enoch boot loader (I am not a fan of clover, sorry)

If anyone is interested in a tutorial for z77-mx-d3h, i7-3770, GTX 970, let me know I would write it !
 

Attachments

  • AtherosL1cEthernet.kext.zip
    73.8 KB · Views: 1,339
Last edited:
Joined
Mar 9, 2013
Messages
4
Motherboard
mac
CPU
2ghz
Graphics
nv
Mac
Classic Mac
Mobile Phone
hi, i have a z77mx-d3h.
Could you give me the instructions on how you manage to get the audio+ethernet working (vt2021)?
gtx 660 works fine with the nvidia web drivers, and i could fix ethernet with an pci-e card, but sound is an issue.
voodoohda from multibeast didn't work as loading apple alc 1.6

btw, the atheros is working now thanks to your kext! al that remains is the vt2021
 
Last edited:
Joined
Mar 16, 2011
Messages
38
Motherboard
GA-Z77MX-D3H
CPU
i7-3770
Graphics
Asus GTX 970
Ok, here is my apple hda approach. Put my attached DSDT.aml (it is for z77-mx-d3h) in your extra (if chameleon) or your efi/clover/acpi/patched (hope the path is right for clover).
And then install this kext with for example kext wizard. Repair, rebuild, reboot...and tadaa, you're finished.
 

Attachments

  • DSDT.aml
    38.8 KB · Views: 440
  • AppleHDA.kext.zip
    1.7 MB · Views: 315
Joined
Mar 9, 2013
Messages
4
Motherboard
mac
CPU
2ghz
Graphics
nv
Mac
Classic Mac
Mobile Phone
Ok, here is my apple hda approach. Put my attached DSDT.aml (it is for z77-mx-d3h) in your extra (if chameleon) or your efi/clover/acpi/patched (hope the path is right for clover).
And then install this kext with for example kext wizard. Repair, rebuild, reboot...and tadaa, you're finished.

Thanks!
Your my saviour. My personal Jesus Christ. Everything works now.

just for others who found this topic, vooodoohda does work, but you'll need the new kext(2.8.9) not included in 2.8.8. However, sleep breaks with voodoohda.
The patched applehda from jazzman1969 works fine!

I did a fresh installation and all of the sudden my gtx 660 worked without the Nvidia web drivers. strange, but I'm happy with it :)
 
Joined
Jan 13, 2010
Messages
362
Motherboard
Aorus X570 Elite
CPU
Ryzen 7 3700X
Graphics
Vega 64
Mac
  1. iMac
Classic Mac
  1. Apple
  2. eMac
  3. iMac
  4. LC
  5. Power Mac
Mobile Phone
  1. iOS
Bansaku, I got it now ...AppleHDA (for VIA VT 2021), and AtherosL1CEthernet !
By the way, I am using enoch boot loader (I am not a fan of clover, sorry)

I will try this, thanks!

Edit: Works great!!
Edit 2: My friend has the same mobo as you and I could never get the sound to work. Will give it a shot when he is over next.

:headbang:
 
Last edited:
Joined
Oct 1, 2012
Messages
7
Motherboard
GA-Z77-DS3H
CPU
i7-3770k
Graphics
GeForce GT 640 2GB
Mac
  1. MacBook
Classic Mac
  1. Performa
Mobile Phone
  1. Android
- delete ALXEthernet
- open IONetworkingFamily.kext in S/L/E
- put the attached file to plugins
- repair, rebuild etc. (I added EthernetBuiltIn=Yes to my boot.plist)
- restart

This works on a Gigabyte GA-Z77-DS3H build (audio was fixed with standard multibeast). Thanks
 
Status
Not open for further replies.
Top