Contribute
Register

OSX Mavericks / ASUS G750JX - INSTALLATION GUIDE

Joined
Jul 14, 2015
Messages
1
CPU
i5
Graphics
intel 4000 hd
Mac
Classic Mac
Mobile Phone
hello can any please help me and tell me if i can install OSX-Mavericks in my asus laptop
[h=1]ASUS X550CA 15.6" 4GB 750GB Core i5 Laptop[/h]

  • Intel Core i5 3337U 1.8GHz CPU
  • 4GB Memory
  • Intel HD 4000 Graphics
  • Optical Drive: DVD
  • 500GB Hard Drive
  • Windows 8
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Oct 24, 2013
Messages
4
Motherboard
OSX
CPU
i7
Graphics
GE780M
Mac
MacBook Pro
Classic Mac
iMac, PowerBook
Mobile Phone
Hello,

I am about to install El Capitan Beta on my G750JH laptop.

For now I have a USB key with clover and a base system with the installer. Clover is booting but the base system not. I know I need some kext and config.plist update. I have been reading the whole thread here and I am pretty sure it will work, but many information refers to Mavericks and I am sure it is updated. In previous posts it was mentioned that a patched kernel was needed but then you told that with clover and new config.plist it should work. This thread is very long and amazingly rich in information, but a bit confusing to me.

Can you explain to me as of today what should be needed:

1/ In clover partition
2/ In base installation system on USB
3/ In installed system once installed on disk

If I understand correctly, I should install Macos first, and then windows 8 and Ubuntu, all of the later being recognized by clover.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello,

I am about to install El Capitan Beta on my G750JH laptop.

For now I have a USB key with clover and a base system with the installer. Clover is booting but the base system not. I know I need some kext and config.plist update. I have been reading the whole thread here and I am pretty sure it will work, but many information refers to Mavericks and I am sure it is updated. In previous posts it was mentioned that a patched kernel was needed but then you told that with clover and new config.plist it should work. This thread is very long and amazingly rich in information, but a bit confusing to me.

Can you explain to me as of today what should be needed:

1/ In clover partition
2/ In base installation system on USB
3/ In installed system once installed on disk

If I understand correctly, I should install Macos first, and then windows 8 and Ubuntu, all of the later being recognized by clover.
Post EFI/Clover folder.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
No. Not a file listing. Actual folder as ZIP, attached to your reply.
 
Joined
Sep 12, 2015
Messages
1
Motherboard
Asus ROG G750JX-DB71
CPU
Intel Core-i7 4700HQ
Graphics
Nvidia Geforce GTX770 3GB GDDR5
Mac
MacBook Air
Classic Mac
Mobile Phone
iOS
HDMI-audio on Haswell has several requirements:
- the device at address 0x00030000, usually called B0D3, must be renamed to HDAU
- the resulting HDAU device must be recognized by AppleHDAController (config.plist patches required if not natively recognized... or you can use FakePCIID_Intel_HDMI_Audio.kext)
- your framebuffer must be patched for HDMI-audio (there are patches in my default config.plist (disabled) files: https://github.com/RehabMan/OS-X-Clover-Laptop-Config). It is trial/error to determine which port your HDMI is connected (actually, they are positional and you can tell by looking at ioreg).
- patched AppleHDA is required (sometimes VoodooHDA works, but my experience has been not good)
- you have to inject "hda-gfx"="onboard-1" for IGPU/HDEF/HDAU objects. This is usually done with DSDT/SSDT edits (_DSM methods)
Hi RehabMan - I have tried all the above methods but no success in having sound from my inbuilt subwoofer. I have 10.10.5 on Asus ROG G750JX-DB71, and sound is working through the front speakers only.
I'm using Vanilla AppleHDA patched via DSDT (layout-3), CodecCommander(Yours), and I'm booting from clover. If you have time, please look at the files extracted from my system in the attachment below.
Much Thanks in advance

https://www.dropbox.com/s/xivx806q8c...Files.zip?dl=0
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi RehabMan - I have tried all the above methods but no success in having sound from my inbuilt subwoofer. I have 10.10.5 on Asus ROG G750JX-DB71, and sound is working through the front speakers only.
I'm using Vanilla AppleHDA patched via DSDT (layout-3), CodecCommander(Yours), and I'm booting from clover. If you have time, please look at the files extracted from my system in the attachment below.
Much Thanks in advance

https://www.dropbox.com/s/xivx806q8c...Files.zip?dl=0
It looks like maybe your HDMI is dedicated to the Nvidia. Different scenario than Intel only...

Refer to toleda's guides in the audio forum for details.
 
Top