Contribute
Register

OSX freeze after installing official nVidia Fermi drivers

Status
Not open for further replies.
Joined
Dec 17, 2010
Messages
12
Mac
Classic Mac
Mobile Phone
Hi all! :wave:

Few days ago i installed Snow Leopard.

Using:

BIOS Version: 1807
iBoot 2.6 (with PciRoot=1)
Snow Leopard 10.6.0 Retail
10.6.6 Combo Update
Multibeast 3.1
User DSDT (using beelzebozo's bios:1807 ASUS P7P55D DSDT)
System Utilities
Jmicron SATA and eSATA
Realtek R1000 for network
All of OSX softwares
Tonymac's Nvidia Update 1.0.1
I installed original osx driver for my Focusrite Saffire Pro 24 Firewire sound card

All works perfectly, but sometimes my system is freezes. :banghead: Sometimes i got this picture: Please hold the power button and restart your computer etc... :banghead:

What do i do now? :( Please help me... :oops:

Thanks ;)
 
Joined
Dec 17, 2010
Messages
12
Mac
Classic Mac
Mobile Phone
Thanks xD

I see your system...:D

Does not work for you too?
How can i fix it?
 
Joined
Nov 6, 2010
Messages
5
Mac
Classic Mac
Mobile Phone
I think it doesn't work for all of us, who have lucky nvidia cards series 4xx, 5xx.. :beachball:
still no good solutions
 
Joined
Mar 4, 2010
Messages
4,016
Motherboard
ASUS ROG Strix Z270E-Gaming
CPU
i5-7600K
Graphics
Vega 64
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
rtbas said:
Thank you for the input on your system. A question, though: what kind of uptimes do you get if you leave your system on without sleeping?
The longest uptime was about 2 days. I don't switch them completly off, i'll sent him to sleep only, and even i don't reboot much often...maybe 2-3 times per month for updating my ubuntu and win7. Exceptions from that only if i'll do testing things out to help other users.
 
Joined
Jan 16, 2011
Messages
14
Mac
Classic Mac
Mobile Phone
As some people have noticed, the wallpaper screensaver dies periodically (due to Little Snitch connection dialogs or for other reasons), so I thought I'd share my take at a solution. Basically, I created a simple LaunchAgent to keep the screensaver alive.

Create a new plain-text file in TextEdit and save it as ~/Library/LaunchAgents/myscreensaver.plist. Paste the following code into that file (and save it):
Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>KeepAlive</key>
	<true/>
	<key>Label</key>
	<string>myscreensaver</string>
	<key>ProgramArguments</key>
	<array>
		<string>/usr/bin/open</string>
		<string>-W</string>
		<string>-g</string>
		<string>/System/Library/Frameworks/ScreenSaver.framework/Resources/ScreenSaverEngine.app</string>
		<string>--args</string>
		<string>-background</string>
	</array>
	<key>RunAtLoad</key>
	<true/>
</dict>
</plist>

Then make sure any existing methods of getting a screensaver wallpaper are disabled (and any running screensavers are dead) and type the following into a terminal (no need for sudo):
Code:
launchctl load -w ~/Library/LaunchAgents/myscreensaver.plist

Now whenever the screensaver gets killed it should reappear automatically within a second or two (and it doesn't leak memory like Mach Desktop :) ).

If you want to disable this, simply type
Code:
launchctl unload -w ~/Library/LaunchAgents/myscreensaver.plist
into a terminal.
 
Joined
Mar 4, 2010
Messages
4,016
Motherboard
ASUS ROG Strix Z270E-Gaming
CPU
i5-7600K
Graphics
Vega 64
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
rtbas said:
As some people have noticed, the wallpaper screensaver dies periodically (due to Little Snitch connection dialogs or for other reasons), so I thought I'd share my take at a solution. Basically, I created a simple LaunchAgent to keep the screensaver alive.

Create a new plain-text file in TextEdit and save it as ~/Library/LaunchAgents/myscreensaver.plist. Paste the following code into that file (and save it):
Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>KeepAlive</key>
	<true/>
	<key>Label</key>
	<string>myscreensaver</string>
	<key>ProgramArguments</key>
	<array>
		<string>/usr/bin/open</string>
		<string>-W</string>
		<string>-g</string>
		<string>/System/Library/Frameworks/ScreenSaver.framework/Resources/ScreenSaverEngine.app</string>
		<string>--args</string>
		<string>-background</string>
	</array>
	<key>RunAtLoad</key>
	<true/>
</dict>
</plist>

Then make sure any existing methods of getting a screensaver wallpaper are disabled (and any running screensavers are dead) and type the following into a terminal (no need for sudo):
Code:
launchctl load -w ~/Library/LaunchAgents/myscreensaver.plist

Now whenever the screensaver gets killed it should reappear automatically within a second or two (and it doesn't leak memory like Mach Desktop :) ).

If you want to disable this, simply type
Code:
launchctl unload -w ~/Library/LaunchAgents/myscreensaver.plist
into a terminal.
Good idea, this might help some users with that little snitch behavior :thumbup:
 
M

momavujisic

Guest
Have a Hackintosh running here, (almost) perfectly...

Gigabyte p55aud3 motherboard
evga gtx 460 1gb
6gb corsair xms3 1600
intel i5 760 2.8ghz
Mac OS X 10.6.5 from retail DVD
used multibeast 2.6.3
tonymac's nvidia drivers


I experience the "fermi freeze" randomly as well. However it usually occurs either when I leave the computer for a long time, then go back and click on something in an application, or randomly (and most often) when I am using a web browser and opening up a new tab or something of the sort. Thankfully my system has been up for a good couple hours before something like this happens and sometimes I wont get a KP for a week or two but it's still annoying.

So, I'm coming to you guys for some advice, obviously, the existance of this thread means the problem is unsolved however, are there any working "semi" fixes for this problem yet? Also, I am planning to update my iboot, and update to the new 10.6.6, does updating solve the problem at all, or a bit?

More information can be provided, just ask what you want to know! ;)
 
Joined
Dec 12, 2010
Messages
40
Motherboard
Gigabyte x58a-ud7
CPU
Intel 980x
Graphics
EVGA GeForce GTX 780
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. Apple
  2. iMac
Mobile Phone
  1. Android
  2. iOS
rickette said:
and it's like only two solution works after all :
- the use of wallsaver, but it's not really a "solution"
- a bios flash of the GC under windows

i'll stick with the bios flash, easy to do and proven long term solution for avoiding the freezes.
Did you mean flashing the GC's bios (in Windows) to only use the two highest power levels? If yes, has that stopped your freezes? The last post from DrJohnnyFever says he's been freeze-free. I'll give it a shot too, if it's worked for others.

Anyone else had any experiences with that possible solution?
 
Joined
Mar 28, 2010
Messages
51
Motherboard
MSI Z97 Gaming 7
CPU
Intel i7 4790
Graphics
Dual Geforce GTX 770 4GB
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Results still look promising. Refuse to use my pc 24x7 these days when I don't need to, but so far I had about 11 hours uptime doing various tasks (and then KP) and 9 hours (without KP). Boinc is crunching in the background, by now it has picked up some GPU tasks but for the most part it was running on the CPU only.

Booted without -v the first time, so all I can say is there was a KP (screen turning black and then powerbutton logo). Will boot with -v from now on so I can say a bit more.

Strange thing is there was a KP almost instant, before it would just lockup. Can this be related to me putting my hw id in AppleGraphicsPowerManagement.kext?

What I can say is this: apart from some hw related problems that are fixed now, the system is and was completely stable outside OSX. Not a single lockup in about 3 weeks now. Only one BSOD in Win7 during shutdown, but that looked like a storage related driver issue.
 
Status
Not open for further replies.
Top