Contribute
Register

OS X 10.8.5 Update

Status
Not open for further replies.
Joined
Jun 10, 2012
Messages
3
Motherboard
Dell Precision M4500
CPU
I5-540M/QM57
Graphics
NVIDIA Quadro FX 880M, 1920x1080
Mac
Classic Mac
Mobile Phone
It didn't work for me on a DELL Precision M4500. I had Black screen, but if I am lucky to see the login screen, then keyboard and mouse doesn't work.
I have to reinstall 10.8.4 unibeast.
 
Joined
May 20, 2013
Messages
2
Motherboard
Macbook Pro
CPU
2.53 Core2
Graphics
NVIDIA 9600m
Mac
Classic Mac
Mobile Phone
Article: OS X 10.8.5 Update

I am running a MacBook Pro which I used multibeast on to get USB 3 drivers for my pci express card. I too am getting the install failed on 10.8.5 update like the rest of you. From what I can gather in the posts it has something to do with the GenericUSB kext file. It appears that some have simply deleted this file and then had success. I think this file is supposed to be in the S/L/E folder but I do not know what S, L, and E stand for. Can anyone point me to where this file is supposed to be?
 
Joined
Nov 12, 2011
Messages
129
Motherboard
ASUS P8Z77-V PRO/Thunderbolt
CPU
Core i7 3770K @4.20GHz
Graphics
ASUS GT640-2GD3
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Article: OS X 10.8.5 Update

1st. System: No problem at all (but USB3) - P8Z77-V/PRO TH

2st. System: USB3 don't work, ALC887 don't work, Marvell 9123 SATA-6Gb controller don't work - P7H55M/USB3

BOTH systems: GenericUSBXHCI.kext v1.2.5 does the trick!! ;)


UPDATE:
Deleted npci=0x3000 from kernel flags. Audio came back again. SATA-6Gb Marvell controller came back again!

Now I can use my SSD at full speed :mrgreen:
 
Joined
Nov 1, 2012
Messages
1
Motherboard
win
CPU
intel
Graphics
ati
Mac
Classic Mac
Mobile Phone
Article: OS X 10.8.5 Update

I find the solution for the Bluetoothproblem (Jabra, etc.) somewhere in another forum:

First you need to find your bluetooth adapter's info, so open Applications/Utilities/System Information, then scroll to the USB section and check your bluetooth adapter's Product and Vendor ID.
For example:
Product ID: 0x2153
Vendor ID: 0x0a5c

Convert the hexadecimal values to decimal with searching in google. e.g. '0x2153 in decimal'. In this case it's:

Product ID: 8531
Vendor ID: 2652

Now open Finder, choose Go/Go to Folder and paste this location:
/System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHostControllerUSBTransport.kext/Contents/

Then open the file 'Info.plist' in TextWrangler (https://www.macupdate.com/app/mac/11009/textwrangler) and scroll down to the bottom of the file. I duplicated this block by copy and paste it back to the file:

<key>BroadcomUSBBluetoothHCIController - Targus</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.iokit.BroadcomBluetoothHostContr ollerUSBTransport</string>
<key>IOClass</key>
<string>BroadcomBluetoothHostControllerUSBTranspor t</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>idProduct</key>
<integer>8532</integer>
<key>idVendor</key>
<integer>2652</integer>
</dict>

Just by replacing idProduct from 8532 to 8531 and if you want replace the name of the controller (for example Target into Jabra), save the Info.plist

After saving the file you will need to delete the kernel extension cache and reboot.

Using the Terminal: sudo rm -R /System/Library/Caches/com.apple.kext.caches

Then you will need to reboot your Mac.
 
Joined
Nov 10, 2011
Messages
351
Motherboard
Gigabyte X79-UD5
CPU
i7-3930K
Graphics
GTX 960 and RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Article: OS X 10.8.5 Update

Thanks guys!!


Used latest uni beast 2.1.0 with 10.8.5

bootflag:

-v -x GraphicsEnabler=No npci=0x3000 cpus=1

Gets me to the OSX Installer but then installer then it crashes 5 minutes says "OSX cant be installed on this machine"


Screen shot attached

: (


Never had this problem before 10.8.5 - any suggestions? So close...
Managed to get the installer log - fingers crossed this will help nail it down:

Sep 18 10:22:23 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:22:23 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:22:23 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:23:15 localhost OSInstaller[303]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=110 "An error occurred while extracting files from the package “Essentials.pkg”." UserInfo=0x7fa539090730 {NSUnderlyingError=0x7fa53c6ae300 "The operation couldn’t be completed. cpio read error: bad file format", NSFilePath=/Volumes/Untitled 1/.OSInstallSandbox-tmp/Root, NSURL=Essentials.pkg -- file://localhost/System/Installation/Packages/OSInstall.mpkg, PKInstallPackageIdentifier=com.apple.pkg.Essential s, NSLocalizedDescription=An error occurred while extracting files from the package “Essentials.pkg”.} {
NSFilePath = "/Volumes/Untitled 1/.OSInstallSandbox-tmp/Root";
NSLocalizedDescription = "An error occurred while extracting files from the package \U201cEssentials.pkg\U201d.";
NSURL = "Essentials.pkg -- file://localhost/System/Installation/Packages/OSInstall.mpkg";
NSUnderlyingError = "Error Domain=BOMCopierFatalError Code=1 \"The operation couldn\U2019t be completed. cpio read error: bad file format\" UserInfo=0x7fa53c6ab5f0 {destinationPath=/Volumes/Untitled 1/.OSInstallSandbox-tmp/Root, offset=11044855, type=BOMCopierFatalError, sourcePath=/System/Installation/Packages/Essentials.pkg, NSLocalizedFailureReason=cpio read error: bad file format}";
PKInstallPackageIdentifier = "com.apple.pkg.Essentials";
}
Sep 18 10:23:15 localhost OSInstaller[303]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=110 "An error occurred while extracting files from the package “Essentials.pkg”." UserInfo=0x7fa539090730 {NSUnderlyingError=0x7fa53c6ae300 "The operation couldn’t be completed. cpio read error: bad file format", NSFilePath=/Volumes/Untitled 1/.OSInstallSandbox-tmp/Root, NSURL=Essentials.pkg -- file://localhost/System/Installation/Packages/OSInstall.mpkg, PKInstallPackageIdentifier=com.apple.pkg.Essential s, NSLocalizedDescription=An error occurred while extracting files from the package “Essentials.pkg”.}
Sep 18 10:23:16 localhost OSInstaller[303]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Sep 18 10:23:17 localhost OSInstaller[303]: No system on disk Untitled 1 to revert bless
Sep 18 10:23:17 localhost OSInstaller[303]: Unable to revert bless to target or imgsrc.
Sep 18 10:23:17 localhost OSInstaller[303]: Allowing machine sleep.
Sep 18 10:23:17 localhost OSInstaller[303]: Memory statistics for 'Install Failed' pane:
Sep 18 10:23:17 localhost OSInstaller[303]: Physical Memory Allocation: 13635 MB wired, 2 MB trapped, 440 MB active, 117 MB inactive, 2190 MB free, 2747 MB usable, 16384 MB total
Sep 18 10:23:23 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:23 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:23:23 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:23:23 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:23 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:31 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:23:31 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:23:31 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:31 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:31 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:39 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:39 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:39 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:23:39 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:23:39 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:23:54 localhost Unknown[283]: 2013-09-18 10:23:54.107 Terminal[336:707] NSSoftLinking - The Librarian framework's library couldn't be loaded from (null).
Sep 18 10:23:54 localhost Unknown[283]: 2013-09-18 10:23:54.108 Terminal[336:707] NSSoftLinking - The function 'LBCurrentProcessHasUbiquityContainer' can't be found in the Librarian framework.
Sep 18 10:24:36 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:24:36 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:24:36 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:24:36 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:24:36 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:24:46 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:24:46 localhost OSInstaller[303]: Folder Manager is being asked to create a folder (docs) while running as uid 0
Sep 18 10:24:46 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:24:46 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
Sep 18 10:24:46 localhost OSInstaller[303]: Connection to NetworkBrowserAgent became invalid
 

Attachments

  • Installer Log 18-Sep-2013.txt
    37.8 KB · Views: 79
Joined
Jul 15, 2012
Messages
9
Motherboard
ga-z97x-ud3h bios 10b
CPU
4690k
Graphics
gtx650ti
Article: OS X 10.8.5 Update

Sound not working after update here, GA-P35-DS3P. I get the message that HDAEnabler1.kext is improperly installed and can't be used. Tried reinstalling it using Multibeast with and without the DSDT option but still the same.
 
Joined
Nov 24, 2010
Messages
196
Motherboard
Gigabyte Z490 Vision D
CPU
i7-11700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Article: OS X 10.8.5 Update

I'm running off GA Z77 UP5 TH and am concerned about losing my system with this update. Can anyone offer experience or a precise method particular to this board? My thanks extended,

It was a nightmare for me. I had a PERFECT build. USB 3, reliable sleep, a real MAC. The update broke sleep and USB 3. The usb and sleep seem to be interconnected. I got sleep to work again but no USB 3. The sleep would cycle on and off. If you tried to wake from sleep you lose all USB ports. If I use any USB 3.0 drivers I get crashes on the use o f a USB 3 device and lose sleep.About MAC does show the usb 3 ports but not anything connected. That which is connected to a USB 3 port displays under Hi-Speed usb 2.

Sleep takes for ever to sleep and wake up.
 
Joined
Oct 8, 2010
Messages
569
Motherboard
Z77E-ITX
CPU
Intel® Core™ i7-3770
Graphics
GTX650Ti
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Article: OS X 10.8.5 Update

@lightmanrt

Try to add
<key>Kernel Flags</key>
<string>-gux_defer_usb2</string>

to your org.chameleon.Boot.plist
 
Status
Not open for further replies.
Top