Contribute
Register

OS X 10.8.5 Update

Joined
Apr 6, 2013
Messages
7
CPU
i5 3470
Graphics
gtx 660ti
Mac
Classic Mac
Mobile Phone
Do not install this update!
It has killed my audio.
I have had activated both integrated and discrete graphics. After update I had to disable integrated graphics due to kp on AppleIntelFramebufferCapri.
I have also errors while loading AppleHDA, which killed my sound. I am running now on voodoo.
 
Joined
Nov 6, 2012
Messages
154
Motherboard
Asus Rampage IV gene Bios 4802 OSX 10.10.5
CPU
i7-3930k 3.8ghz
Graphics
Galaxy GTX 670 GC 2gb Heaven BM 979
Mac
iMac
Classic Mac
Performa, Power Mac
Mobile Phone
iOS
Followed Stork's instructions on my Asus Rampage IV Gene and the update completes. On reboot however i get stuck on Still waiting for root device. I made another partition and did a fresh install of 10.8.3 and upgraded to 10.8.5 via the combo update and still get stuck on Still waiting for root device on start up. System runs smoothly on 10.8.4. I'm just gonna hang out with 10.8.4 for a while I guess.
 
Joined
Sep 3, 2011
Messages
146
Motherboard
HP dv7 6154ea (Clover Legacy)
CPU
i7-2630QM/HM65
Graphics
HD3000, 1600x900(HD+)
Mac
Classic Mac
Mobile Phone
iOS
i don't know why, but after 10.8.5 update i can boot only without npci=0x3000. if i boot with it i stuck at "still waiting for root device". so if you can't boot, try with -v -F, then remove npci=0x3000 flag from org.chameleon.Boot.plist.
i hope to help someone else!
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,075
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Article: OS X 10.8.5 Update

Do not install this update!
It has killed my audio.
I have had activated both integrated and discrete graphics. After update I had to disable integrated graphics due to kp on AppleIntelFramebufferCapri.
I have also errors while loading AppleHDA, which killed my sound. I am running now on voodoo.
What is your motherboard? (should be put in your Profile's System definition.)
 
Joined
Nov 6, 2012
Messages
154
Motherboard
Asus Rampage IV gene Bios 4802 OSX 10.10.5
CPU
i7-3930k 3.8ghz
Graphics
Galaxy GTX 670 GC 2gb Heaven BM 979
Mac
iMac
Classic Mac
Performa, Power Mac
Mobile Phone
iOS
Article: OS X 10.8.5 Update

i don't know why, but after 10.8.5 update i can boot only without npci=0x3000. if i boot with it i stuck at "still waiting for root device". so if you can't boot, try with -v -F, then remove npci=0x3000 flag from org.chameleon.Boot.plist.
i hope to help someone else!
tried to boot without npci=0x3000 and it didn't work instead of getting stuck on waiting for root device my monitor went blank and stated no signal.
 

nobodynose

Moderator
Joined
Sep 30, 2012
Messages
4,210
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Quadra
Mobile Phone
Android, iOS
At first my USB 3.0 didn't work after installing the Combo Update. I tried removing GenericUSBXHCI.kext and reinstalling it via MultiBeast, but it still didn't work. Then I found an updated version (v1.2.5) of GenericUSBXHCI.kext at http://sourceforge.net/projects/genericusbxhci/?source=recommended and installed that (using KextBeast). That solved the problem.
 
Joined
Jan 1, 2011
Messages
114
Motherboard
Asus P8p67 deluxe
CPU
xeon E1230
Graphics
zotac GT240
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Article: OS X 10.8.5 Update

Fixed Jabra A320S Bluetooth by editing Info.plist in /System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHostControllerUSBTransport.kext/Contents.

From the Terminal, I did sudo -s and edited the file with vim. I copy and pasted the <key> and <dict> sections where the key was BroadcomUSBBluetoothHCIController_Dongle and changed idProduct from 8448 to 8449.
Thanks for the info. i can confirm that it worked, i now have functional Bluetooth.
ALC889 is still a no go and the trim is not enabled any more.


Edit: changing ID from 8448 to 8449 works but it prevents sleep, however i reverted back to 8448 and now it is functioning as it did before the update. i think what is happening here is that the dongle is turned OFF after the update to 10.8.5 and all you need to do is turning it back ON


Edit2: Back to 10.8.4
lost Bluetooth again, will sit this one out for now
 
Joined
Oct 18, 2010
Messages
66
Motherboard
GA-B250N-Phoenix WiFi
CPU
i7-7700
Graphics
GT 730
Classic Mac
Quadra
Mobile Phone
iOS
Moin,
after update can not login to App-Store. Deleting /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and rebooting help. Everything works well.
 
Joined
Jan 14, 2010
Messages
349
Motherboard
GA-Z77X-UD5H
CPU
i7 3770K
Graphics
Vega 64
Mac
iMac
Classic Mac
Apple, eMac, iMac, LC, Power Mac
Mobile Phone
iOS
Like some of you, I too have had a few snags while updating. First off, the Combo AND App Store update will NOT complete the install properly; It will install everything but it will stop when the System needs to set/repair permissions and cache. Reinstalling the audio drivers from Multibeast proved to be no different. The AppleHDA.kext will install, but will come up with a warning saying that you need to re-install the software.

The simple solution is that the System Update and Multibeast did in fact install properly, however once the install(s) are complete, YOU must set/repair permissions and rebuild the system cache MANUALLY! Use Kext Wizard, Disk Utility or terminal command; it does not matter which. Then you can restart and all will be ok.

I spent hours last night on 2 systems. I finally opened up the extensions folder and the console and watched as the Kexts are being installed via Software Update and Multibeast, that's how I know all went well. Lack of any log regarding permissions essentially screamed out the solution to me.
 
Top