Contribute
Register

OS X 10.8.5 Update

Status
Not open for further replies.
Joined
Oct 23, 2010
Messages
11
Motherboard
Asus Z370-E strix motherboard
CPU
i7-8770K
Graphics
AMD RX570 -Sapphire Pulse
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
Article: OS X 10.8.5 Update

Got mine working finally on 10.8.5. Couple of issues, Asus Rampage II extreme, i7 920 processor, NVIDIA GeForce GTX 650 Ti 1024 MB setup.

1. AppleACPIPlatform.kext creates the slowboot issue and so need to restore it from a previous version
2. GraphicsEnabler=No was my setup with NVDIA drivers from the web (latest). Rolled them back and waiting for the 10.8.5 drivers to be available.
3. Strangely, the kernel flag, npci=0x3000 created issues and could not boot. So used the -F (uppercase) flag to boot without kernel flags and then got rid of npci=0x3000 in org.chameleon.plist and i am all set.
 
Joined
Jul 25, 2013
Messages
3
Motherboard
Mountain Lion 10.8.4
CPU
Xeon E3-1230 v2
Graphics
Palit GeForce GTS 250 1024MB
Mac
Classic Mac
Mobile Phone
ALC887 Front Earphone Port do not work...
USB 3.0 do not work...
Bluetooth adapter do not work...
 
Joined
Mar 7, 2010
Messages
31
Motherboard
Gigabyte P55A-4P
CPU
i5-750
Graphics
GTX 660
Mac
  1. iMac
Classic Mac
  1. 128K
  2. Apple
  3. Classic
  4. iBook
  5. iMac
  6. Power Mac
  7. PowerBook
  8. SE
Mobile Phone
  1. iOS
  2. Other
Ran combo update, repaired permissions, reboot, reinstalled AppleHDA from multibeast, repaired permissions, reboot. All good.

P55A-4P, i5-750.
 
Joined
Jul 25, 2012
Messages
66
Motherboard
Gigabyte Z68X-UD3H-B3
CPU
i7 2600K
Graphics
HD 6870
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. iOS
Did install with Combo, had to do audio and trim again. Strange thing, I now have to use dart=0 or tun off Visualization in Bios to be able to boot at all. No big thing, but I'm glad for the Internet to find a solution.

Gigabyte Z68X-UD3H-B3 / i7-2600K
 
Joined
Mar 9, 2011
Messages
693
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Article: OS X 10.8.5 Update

I have an official apple bluetooth, it's the BLUETOOTH USB +EDR ADAPTER v2.1 UHE: Product ID: 0x016a Vendor ID:0x050d (Belkin Corporation). This one works fine, not a problem at all and gives you access to the bios. This means it doesn't need an OS to run.
Mine 's not working either.


During startup and in the Console I see the following message:

9/13/13 7:47:31.000 PM kernel[0]: [IOBluetoothHCIController][ProcessEventDataWL] -- kBluetoothHCIEventHardwareError occurred -- status = 0x0037 (kBluetoothHCIErrorSecureSimplePairingNotSupportedByHost or kBluetoothHCIErrorMax) -- mNumberOfCommandsAllowedByHardware is 0, processing -- opCode = 0x0000 (UNKNOWN), requestPtr = 0

9/13/13 7:47:31.000 PM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][setPowerStateWL] -- PerformPowerStateChange() failed: 0xE00002BC (kIOReturnError) -- powerStateOrdinal = OFF, mCurrentInternalPowerState = ON -> mPendingInternalPowerState = OFF -- this = 0xffffff8016551c00 ****

I also see that the following bluetooth kexts have been updated:
IOBluetoothFamily.kex
IOBluetoothHIDDriver.kext

maybe putting back the 10.8.4 ones fixes the problem
 
Joined
Oct 5, 2011
Messages
17
Motherboard
Asus P8Z77-V
CPU
Intel 3570
Graphics
MSI RX470 Gaming X 4GB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Article: OS X 10.8.5 Update

Hi all,

Got a panic after updating thought the store. See attached picture.
Any tips on how to get things running again?

Greetings
 

Attachments

  • Panic.jpg
    Panic.jpg
    1.1 MB · Views: 181
Joined
Sep 16, 2012
Messages
12
Motherboard
GA-Z77-DS3H rev. 1.0
CPU
i5-3570K
Graphics
HD 4000
Mac
  1. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Article: OS X 10.8.5 Update

Same board and Revision not so lucky. Won't Boot

Same board and revision. Had to kextunload GenericUSBXHCI.kext prior to successful upgrade using combo. Reinstalled sound using Multibeast 5.4.3. Downloaded and installed GenericUSBXHCI ver 1.2.5.
Booting took longer time than 10.8.4. Got 10.8.5 to work somehow, but no still no sound, no back USB3. Reinstalling sound didn't help. Safari flickers on animated contents. Apparently Multibeast 5.4.3 is not ready for 10.8.5.
Returned to 10.8.4 using Time Machine. Will try again when a newer version of Multibeast becomes available.
 
Joined
Oct 2, 2010
Messages
22
Motherboard
ASRock Z690 Steel Steel Legend WiFi 6E
CPU
i9-12900K
Graphics
RX 580
Mac
  1. iMac
Article: OS X 10.8.5 Update

Right explanation about my issues.
Tried this method but no success. Rollback to 10.8.4.
Macman found the solution for reboot loop in his modded kernel. I really hope that will be possible to create a tool to solve it.
in many countries is very difficult to find recommended boards to buy. This limits friendly hackintosh builds.

Also the same with me. I have a Intel DH87MC with Haswell i5-4670k which has been running as an OSX server on 10.8.4. (http://www.insanelymac.com/forum/to...5-4670k-haswell-installation-with-108-server/) When I upgraded to 10.8.5, it also went into reboot hell. I am now back on 10.8.4.

Interesting note, however, was that I was running from a fusion drive on 10.8.4, and 10.8.5 hosed the fusion set-up as well, as others have pointed out.

Haswell and Fusion are clearly stress points for 10.8.5.
 
Joined
Jan 6, 2011
Messages
19
Motherboard
GA-Z77X-UP5-TH
CPU
i5 3570K
Graphics
RX 560
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Anyone tried to do a fresh install and see if that fixes Bluetooth?
 
Joined
Nov 12, 2011
Messages
129
Motherboard
ASUS P8Z77-V PRO/Thunderbolt
CPU
Core i7 3770K @4.20GHz
Graphics
ASUS GT640-2GD3
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Article: OS X 10.8.5 Update

1st. System: No problem at all (but USB3) - P8Z77-V/PRO TH

2st. System: USB3 don't work, ALC887 don't work, Marvell 9123 SATA-6Gb controller don't work - P7H55M/USB3

BOTH systems: GenericUSBXHCI.kext v1.2.5 does the trick!! ;)
 
Status
Not open for further replies.
Top