Contribute
Register

OS X 10.8.2 Update

Status
Not open for further replies.
Joined
Jul 17, 2011
Messages
8
Motherboard
GA-Z77P-D3 (rev. 1.1)
CPU
Core i7 3770
Graphics
Gigabyte NVIDIA GeForce GT 640
Mac
Classic Mac
Mobile Phone
  1. iOS
  2. Other
After reading many comments, I knew that it would have some problems when updating alone. Also, I had to know idea how to look what caused error in booting with verbose mode. Therefore, I decided to do this and it worked.

After installing 10.8.2 update, I reinstalled by running Multibeast and ONLY select ALC887/888B CURRENT Without DSDT because of lost sound. Then, restart the computer. I changed my bios setting in VT from Enabled to be Disabled as some people mentioned in here to solve spinning logo on boot screen. That is all.

Anyway, I could not find OemSMBIOS.kext which most people mention in /System/Library/Extensions/FakeSMC.kext/Contents/PlugIns/. It did not even have PlugIns folder.

Core i7 3770
Gigabyte GT 640
Gigabyte Z77P-D3
 
Joined
Jul 17, 2011
Messages
8
Motherboard
GA-Z77P-D3 (rev. 1.1)
CPU
Core i7 3770
Graphics
Gigabyte NVIDIA GeForce GT 640
Mac
Classic Mac
Mobile Phone
  1. iOS
  2. Other
Article: OS X 10.8.2 Update

After reading many comments, I knew that it would have some problems when updating alone. Therefore, I decided to do this and it worked.

After installing 10.8.2 update, I reinstalled by running Multibeast and ONLY select ALC887/888B CURRENT Without DSDT. Then restart the computer. I changed my bios setting in VT from Enabled to be Disabled as some people mentioned in here to solve spinning logo on boot screen. That is all.

Anyway, I could not find OemSMBIOS.kext which most people mention in /System/Library/Extensions/FakeSMC.kext/Contents/PlugIns/. It did not even have PlugIns folder.

Core i7 3770
Gigabyte GT 640
Gigabyte Z77P-D3
 
Joined
Aug 21, 2011
Messages
2
Motherboard
10.8.2 lion mountain
CPU
intel dual core e5200
Graphics
asus n210 512
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. Other
Article: OS X 10.8.2 Update

Updated From 10.8.1 to 10.8.2 combo Update
Running everything great on my Asus p5kpl-cm , Nvidia 8400Gs
No need to update any sound or Ethernet driver just reeboted with nv_disable=1 flag and updated Graphics driver.
Running Excellent..

Updated From 10.8.1 to 10.8.2 Combo Update
I need help to sound driver for Asus P5KPL-CM.
thank
Google Translator Portuguese to English
 
Joined
Aug 27, 2012
Messages
75
Motherboard
GA-Z77-DS3H
CPU
i5-3570K
Graphics
GT 640
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. Android
Another successful update via App Store software update. Re-installed Sound driver and ethernet drive. Only issue is that LAN says it's connected although there is no cable connected. ANyone know how to resolve....
 
Joined
Jun 20, 2011
Messages
18
Motherboard
Gigabyte Z77X-UD3H
CPU
i7-2600K OC 4,5
Graphics
R9 270x
Mac
  1. MacBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
Article: OS X 10.8.2 Update

Originally Posted by micr0shaft
You should download the edited AppleACPIPlatform.kext from my previous post boot up with -f -x put it on the desktop with Kextbeast and run it then reboot with -f.

::::FOR EVERYBODY::::

THIS METHOD HAS WORKED THROUGH ALL THE 10.8.2 BETAS AND WORKS 100% NOW

THIS FIXES THE OemSMBIOS PROBLEM WITHOUT HAVING TO DELETE IT FROM FAKESMC.kext

THIS MEANS YOU WON'T LOOSE YOUR SYSTEM DEFINITION AND SERIAL NUMBER WHICH WILL CAUSE PROBLEMS WITH SOME APPLE SOFTWARE AND ACTIVATED 3RD PARTY SOFTWARE.

IF YOU HAVE CONSTANT SPINNING WHEEL OR ARE RECEIVING ERRORS ABOUT OemSMBIOS.kext THIS WILL LIKELY FIX IT.

SOURCE:
http://www.insanlynac.com/forum/inde...post&p=1852962




For me this works as well, i just installed the combo update. When the update was done, (before rebooting) i used kextbeast with this AppleACPIPlatform.kext and did a system repair with Multibeast Lion edition. After this i reinstalled the Realtek 889 audio driver with the Multibeast Mountain Lion edition and rebooted my system without any other modifications without any problems! (have to reinstall my other hackintosh because of stupid store update without reading the post (RTFM?:p) but its not my priority hack, so that would be a reinstall....

specs:
GA-PH67A-D3-B3 (F4)
Core i5 2500k
Radeon HD6850

Me too, download and install combo update (For 10.8.1 to 10.8.2).

MySpes:
Z68A-GD80(G3)
Core i7 2600k
MSI R6870 Hawk

I just need to install my sound driver using multibeast for Mountain lion.
 
Joined
Nov 9, 2011
Messages
3
Motherboard
Z68X-UD3H-B3; 8 GB XMS3 Corsair Ram
CPU
i7-2700k @ 4Ghz
Graphics
GTX 560 ti 1GB
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
Since 10.8.2 I have gotten this strange error "pthread support aborts when sync kernel primitives misused" where it just hangs afterwards can't find any answers on the interwebs. Can't even make a clean install of 10.8.2. Actually never had any problems with updating or anything. Got a Z68X-UD3H-B3 F12, 8GB Corsair XMS3 Ram and a GTX 560 TI 1GB, any help out there?
 
Joined
May 26, 2011
Messages
25
Motherboard
GIGABYTE GA-Z77-DS3H
CPU
Intel Core i7-3770S
Graphics
GV-R685OC-1GD Radeon HD 6850 1GB
Mac
Classic Mac
Mobile Phone
  1. iOS
Article: OS X 10.8.2 Update

Typical boot failture after 10.8.2. update troubleshooting.

Boot in to safe mode (-x), your system should boot this way if you're having this crash
Open Terminal, and type "sudo mv /System/Library/Extensions/FakeSMC.kext/Contents/PlugIns/OemSMBIOS.kext /Users/youraccountname/" (replacing youraccountname with the appropriate account name )
Still in Terminal, type "sudo diskutil repairpermissions /" followed by "sudo kextcache -system-caches" (or repair permissions and update kext caches in any other way you prefer)
Reboot.

For Radeon 6xxx users.
-x
- We see a white screen. Turn sleep mode, wake up.
- Move OemSMBIOS.kext as above
- Profit!

How to restore the sound, see the upper thread.

How do you enable Sleep Mode?
 
Joined
Mar 9, 2012
Messages
4
Motherboard
Asus P8z68-V Pro
CPU
Intel 3.4 GHz Core i7 2600K
Graphics
AMD Radeon HD 6870 1024 MB
Mac
  1. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Article: OS X 10.8.2 Update

After 24 hours of debugging, i am up and running on 10.8.2. The issue seems for me atleast was in installing the HW monitoring applications last time when i was at 10.8.1 using Mutlibeast 5.0.2. I had installed the following and so had to remove the following kexts (depending on what you installed using Multibeast) from S/L/E

if you have installed motherboard plugins from Mutlibeast delete:

ACPISensors.kext, IntelCPUMonitor.kext, OemSMBIOS.kext, ITEIT87x.kext, WinbondW836x.kext, FintekF718x.kext, NSCPC8739x.kext and NuvotonNCT677x.kext

If you have installed Nviidia GEForce Plugin please delete:

Installs NVClockX.kext FakeSMC plugin in /System/Library/Extensions/FakeSMC.kext/Contents/PlugIns

If you have installed HWmonitor application please delete HWMonitor application from the app folder

I think it will be a good idea to reinstall Fakesmc from multibeast to avoid any plugins the monitors may have installed within fakesmc.kext in the past

I am not sure AppleACPIPlatform.kext is the issue as the 10.8.2 update does not seem to have touched that kext.

Rebuild kernelcache using kext utility and you should be set.


I found success with these steps. Stable for 24 + hours

ASUS P68Z68 - V Pro Gen3
i7 2600K
XFX 6870 1 GB
 
Joined
Dec 19, 2010
Messages
270
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
OK, I finally got it working again.

Since I couldn't boot into OS X, I removed the SSD then manually deleted (moved) "nvclockx.kext" and just to be sure "OemSMBIOS.kext". After reinstalling the SSD I was able to boot into OS X.

Audio isn't working but that was to be expected. I should be able to fix that without much issue. The only reason I didn't try to fix audio right away was that I was copying files off the system so it wouldn't matter as much if it gets bricked again.
 
Status
Not open for further replies.
Top