Contribute
Register

OS X 10.10.3 Update

Status
Not open for further replies.
Joined
May 14, 2014
Messages
2
CPU
Intel Core i7-4790K (8M Cache, up to 4.40 GHz)
Graphics
Asus GeForce GTX 760 DirectCU II
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Joined
Mar 13, 2015
Messages
53
Motherboard
Gigabyte GA-Z170MX-Gaming 5
CPU
i7-6700K
Graphics
GTX 970
Mobile Phone
  1. iOS
Successfully updated to 10.10.3 using MAS, on my i3 GA B85-D3H, although still can't get my AMD R9 280 to work so running off on-board GFX :D

Screen Shot 2015-04-11 at 15.58.24.png
 
Joined
Jun 17, 2012
Messages
72
Motherboard
Z370 Gigabyte Gaming 7
CPU
i7-8700K
Graphics
RX 590
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. iMac
  2. Performa
  3. Power Mac
  4. Quadra
Mobile Phone
  1. iOS
My hackintosh automatically updated lol.. Seems fine!!! Z68 UD3 with Nv GTX570 HD Pheww!!! Im looking to build a new mackintosh soon, mainly for PC gaming since the mac side is fast enough for what I do.
 
Joined
May 13, 2011
Messages
57
Motherboard
ASUS P8P67 Deluxe
CPU
i7 2600K
Graphics
XFX ATI HD 6870 2GB
Mac
Classic Mac
Mobile Phone
  1. iOS
Update on both rigs went without issue from App Store.

Both Clover builds, just updated clover prior to following Stork's guide (meaning the standard process). My Clover confit.plist in each case includes kept patches for TRIM and audio already and therefore had no additional work - audio and TRIM both still supported following reboot with no KEXTs or patches being re-installed.

As an observation I made a while back though when doing a Clean install of Yosemite was that Clover does only seem to inject FakeSMC.Kext, although that may just be related to where it injects them doesn't happen to support the other Kexts I'd placed in the folder (at the time a patched audio Kext and Realtek Ethernet). That was when I sorted out the Kext patches section of the config.plist. I mention this for those that have said they had to reinstall audio even though they use Clover. Here is a guide that I followed from Giacomoleopardo:(just amend the instructions based on your audio codec)

Audio Configuration​

Now we have to take care about Audio.
Until now, each one of us had to patch AppleHDA.kext (if you have dsdt edits) or get HDAEnabler (without edited dsdt), and every system update we had to repatch it.
Now it's time to try a different method. Thanks to the Clover so called "Patch on the fly", and to the great support of Forum Moderator Toleda, here's a simple method to patch Audio that would (hopefully) survive to the System Updates (already tested from 10.10 to 10.10.1).
- Open Terminal and type
Code:
defaults write com.apple.DiskUtility DUDebugMenuEnabled 1
- Open Applications/Utilities/Disk Utility, go to the menu bar find Debug and flag "Show Every Partition"
- Now in Disk Utility you'll see all the partitions, included EFI (greyed out, cause it's unmounted)
- Mount EFI partition from Disk Utility and close the window
- Download audio_CloverALC-master.zip from toleda's repo, unzip it and leave it in Downloads folder.
- Open Downloads/audio_CloverALC-master and unzip audio_cloverALC-100.command.zip.
- Double click on audio_cloverALC-100-v1.0.2.command, a Terminal window will open, type your password (even if you don't see anything) and press enter
Code:
Last login: Sun Nov 23 15:26:29 on console
Mac-mini:~ jack$ /Users/jack/Downloads/audio_CloverALC-master/audio_cloverALC-100-v1.0.2.command ; exit;
 
Agreement
The audio_cloverALC-100 script is for personal use only. Do not distribute
the patch, any or all of the files or the resulting patched AppleHDA.kext
for any reason without permission. The audio_cloverALC-100 script is
provided as is and without any kind of warranty.
 
File: audio_cloverALC-100.command_v1.0.2
Verify EFI partition mounted, Finder/Devices/EFI
Password:
rm: /Volumes/EFI/EFI/CLOVER/config-backup.plist: No such file or directory
Confirm Realtek ALC892 (y/n): [B][SIZE=4]y[/SIZE][/B]
Clover Audio ID Injection (y/n): [B][SIZE=4]y[/SIZE][/B]
Use Audio ID: 3 (y/n): [B][SIZE=4]y[/SIZE][/B]

Download ALC892 files ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 25585  100 25585    0     0  14443      0  0:00:01  0:00:01 --:--:-- 14438
Edit config.plist/Devices/Audio/Inject/3
Edit config.plist/SystemParameters/InjectKexts/YES
Edit config.plist/Boot/Arguments/kext-dev-mode=1
Download kext patches
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1335  100  1335    0     0    667      0  0:00:02  0:00:01  0:00:01   667
Install /Volumes/EFI/EFI/CLOVER/kexts/10.10/realtekALC.kext
Download config kext and install ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  3451  100  3451    0     0   3348      0  0:00:01  0:00:01 --:--:--  3350
/Volumes/EFI/EFI/CLOVER/kexts/10.10/realtekALC.kext deleted
Install System/Library/Extensions/AppleHDA.kext/ALC892 zml files
Fix permissions ...
Kernel cache...
rebuilding //System/Library/Caches/com.apple.kext.caches/Startup/kernelcache
kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext

Install finished, restart required.
To save a Copy to this Terminal session: Terminal/Shell/Export Text As ...
logout

[Processo completato]
- Type three times Y for yes (in black up here) and the process will be completed, the command file will install realtekALC.kext in /EFI/EFI/CLOVER/kexts/10.10 and will insert some hex codes to /EFI/EFI/CLOVER/config.plist
- Reboot
- Check Audio Devices (including HDMI Audio devices)​
 
Joined
Mar 2, 2014
Messages
1,593
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Using Chimera etc, updated using the "delta" update (not "combo.") As predicted, lost audio and TRIM capability. Regained audio with HDA enabler and TRIM with tonymacx86's Terminal command.

After playing with 10.10.3 for a while, decided to clone it from my #1 SSD ("Yosemite") to my backup "SSD2." Using Carbon Copy Cloner, the procedure seemed to go normally as usual. However, when I attempted to boot on SSD2, The icon for SSD2 did not show up on the initial boot screen, so no boot on SSD2. It would only choose (and boot on) Yosemite.

I solved the above problem by using the "Volume Clone" function of TechTool Pro 7. It works differently from CCC in that where CCC leaves "unchanged" files on the destination disk and replaces only the changed ones, TTP erases the destination disk and then copies everything from source to destination. That worked perfectly. I can now boot on either SSD.

I am just guessing here, but maybe some of the changed Apple files are not recognized as changed by CCC, so it leaves the old files in place, which causes the disk not to be recognized by Chimera.

Just a heads-up here; no expert. :!:
 
Joined
May 29, 2014
Messages
67
Motherboard
GA-Z97M-DS3H
CPU
i3 4360
Graphics
GTX 950
Mobile Phone
  1. iOS
Anyone here with an R9 270X update yet?
 
Joined
Jul 28, 2012
Messages
200
Motherboard
Asus RoG Strix Gaming z370e
CPU
i5-8600K
Graphics
RX 580
Fixed quite a few issues for me... Don't know if the the following behaviour persists....

Using Finder Search... finder would frequently crash or hang when viewing search results... very randomly.

i find also that where before the update I could wake from sleep using the mouse, now there is absolutely no response... I have to use the power button instead...
 
Joined
Nov 13, 2014
Messages
120
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i5-9600K
Graphics
Radeon VII
Mac
  1. iMac
Updated my system this morning. Everything went smoothly.

1. Updated Clover
May not be necessary. But it seems like a good time to update.
Reboot

2. Updated to OS X 10.10.3 via App Store
Rebboot

3. Updated nVidia graphics via System Preferences > NVIDIA Driver Manager
Reboot

4. Updated CUDA via System Preferences > CUDA
Reboot

5. Enable TRIM support: Post #55
Reboot.

6. Patch native AppleHDA following this guide. Used method 3.1 cloverALC/Clover patched.
 
Status
Not open for further replies.
Top