Contribute
Register

OS stopped loading after installing kexts for BT. Possible to remove L/E kexts from Clover bootloader?

Status
Not open for further replies.
Joined
Dec 11, 2019
Messages
10
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Catalina 10.15.2 (before this happened, at least).

My Fenvi T919 was working fine for WiFi but not at all for BT. Nothing was happening when putting the kexts in the EFI Clover kexts folder, but I was finally able to use Hackintool to install the 3 required kexts to S/L (BrcmRamPatch3, BrcmFirmwareRepo, BrcmBluetoothInjector). I also installed Lilu and VirtualSMC into S/L (but not WhateverGreen). All those kexts are still in my EFI>Clover>kexts>other folder.

Upon restart, around 3/4 through the Apple loading screen, pink horizontal lines suddenly appear on the top half of the screen. When the loading screen is finished, the lines disappear and the screen stays black (however when I hit the space bar, the screen flashes). When I boot with -v, it goes all the way through until the black screen (but not pink lines).

I have tried quite a few combinations of Clover bootloading options: recovery, safe mode, block all injected kexts, block certain kexts (the above 3 mentioned +/- Lilu +/- VirtualSMC +/- WhateverGreen). Nothing changes. I have also flashed the BIOS (F8) and switched up the graphics from PCIe Slot 1 (was working just fine) to internal graphics--same issue but much scarier with the graphic glitches that show up onscreen.

So as a beginner, I am looking for advice. This appears to be some kind of graphics issue? But I am not quite sure what caused it. My only hunch is this could do with not having WhateverGreen in S/L, so my first step would be to remove the Lilu and VirtualSMC (I also tried booting without injecting those--nothing), but I have no luck booting off an Ubuntu startup disk nor my own Catalina backup disk, and I do not know how to use the shell that Clover gives me access to.

Any thoughts? Much appreciated. Sorry I can't offer more data of the error but I can't do much on the machine just now.
 
Status
Not open for further replies.
Top