Contribute
Register

Opening App Store freezes Catalina

Joined
Jul 21, 2019
Messages
11
Motherboard
Intel Q87
CPU
i5-4570T/Q87
Graphics
HD 4600
Mac
MacBook Pro
Mobile Phone
iOS
I finally got Catalina up and running on my Thinkcentre m93p and I only have a couple issues. Opening the App Store causes the system to freeze, requiring a force reset.

I read a forum thread regarding a similar problem on Mojave and I can confirm that Lilu and Whatevergreen are installed and updated.

Has anyone experienced something similar? Any help would be greatly appreciated. Thanks!
 
Joined
Oct 25, 2015
Messages
1
Mac
Classic Mac
Mobile Phone
I have exactly the same issue on desktop (motherboard Z97-G43 + i5-4690K).
I can confirm that Lilu and WhateverGreen don't change anything.

In my case opening the "App Store" causes immediate system crash, or system freeze after few seconds.

I didn't find any solution till now.
 
Last edited:
Joined
Jan 9, 2019
Messages
2
Motherboard
Lenovo ThinkCentre m93p Tiny
CPU
i5-4570T/Q87
Graphics
HD 4600
Mac
MacBook Pro
Mobile Phone
iOS
I finally got Catalina up and running on my Thinkcentre m93p and I only have a couple issues. Opening the App Store causes the system to freeze, requiring a force reset.

I read a forum thread regarding a similar problem on Mojave and I can confirm that Lilu and Whatevergreen are installed and updated.

Has anyone experienced something similar? Any help would be greatly appreciated. Thanks!
Same machine and same issue (m93p Tiny i5-4570T HD460 macOS Catalina version 10.15.1).
 
Joined
Jan 9, 2019
Messages
2
Motherboard
Lenovo ThinkCentre m93p Tiny
CPU
i5-4570T/Q87
Graphics
HD 4600
Mac
MacBook Pro
Mobile Phone
iOS
I was able to fix the issue. I had Intel Graphics injection on and FakePCIID_Intel_HD_Graphics.kext. Those should not be used with WhateverGreen.kext in the most recent versions.

I updated Clover to 5098. Kept the following kexts in Clover with the latest version available for each: AppleALC.kext, FakeSMC.kext, InetlMausiEthernet.kext, Lilu.kext, and WhateverGreen.kext.

I removed in the config file the Intel Graphics injection, and removed FakePCIID*.kext, from Clover.
I used KextBeast to install the same kexts in Clover to S/L/E and L/E.

I do not have any freezing issues, and fixed some graphics corruption I had before the upgrade to Catalina.

The only remaining issue I have now, and might be unrelated to the graphics configuration, is that when rebooting, turning on/off the ThinkCentre m93p Tiny, it is stuck in the Lenovo logo. I had to replace my Hackintosh SSD with a Windows HDD for the m93p to boot once, and then I can replace back to my Hackintosh SSD to be able to boot Catalina or access the BIOS menu.

I followed the information from:
and used Hackintool to check the latest kext versions and superseded kexts.
 
Joined
Oct 7, 2018
Messages
3
Motherboard
Dell Opitplex 9020
CPU
i5-4570
Graphics
HD 4600
I'm still having the same issue. Every time I open App Store or embedded videos in Safari the system freezes completely. I'm running a Dell Optiplex 9020 i5 with Intel HD 4600. I've updated Lilu and WhateverGreen Kext to the latest version and I tried every suggestion I found in this Forum and elsewhere without success. Lilu and WhateverGreen seems to NOT load.

Does anyone have a suggestion? What I'm doing wrong?

Thanks!
 
Joined
Jul 21, 2019
Messages
11
Motherboard
Intel Q87
CPU
i5-4570T/Q87
Graphics
HD 4600
Mac
MacBook Pro
Mobile Phone
iOS
I fixed it! I added the -wegbeta boot flag to clover, and it works!!

-wegbeta enables whatevergreen on unsupported OS's
 
Joined
Oct 7, 2018
Messages
3
Motherboard
Dell Opitplex 9020
CPU
i5-4570
Graphics
HD 4600
I fixed it! I added the -wegbeta boot flag to clover, and it works!!

-wegbeta enables whatevergreen on unsupported OS's
Thank you so much @riverLethe !!! You're the best!!! Your fix works!!! When everything else I tried failed, and after spending a couple of days trying to fix it, I did what you suggested and added -wegbeta to my config.plist file and everything works like a charm! I'm so happy! Thank you!
 
Joined
May 3, 2017
Messages
34
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
Mac
Mac Pro
Hi, I'm still getting this problem, I have added the -wegbeta but nothing from the app store will download.
 
Joined
Nov 2, 2019
Messages
5
Motherboard
Lenovo
CPU
Intel i7
Graphics
Onboard
Can someone zip up there EFI config for the Lenovo M93p OR explain how to add the -wegbeta string to config
 
Top