Contribute
Register

OpenCore z390 Aorus Pro WIFI?

Joined
Feb 22, 2011
Messages
196
Motherboard
Z390 Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Hi guys, sorry to ask, but can one of you share the EFI Folder with Opencore 0.7.5 ? I'll try to install Monterey too.

I read that cabal2000 left everything it as is, but I think some tweak will be more productive no ? On the usb ports for example.
My USB port config is completely different. Never could get the USB on the board to work properly other than the back USB2 ports. So I have a USB 3 PCI card and a front powered USB-c with 3 usb ports on it. But the EFI folder that esafeddie has uploaded will do you good. Works on 0.7.5 and 0.7.6.
 
Joined
Sep 20, 2016
Messages
4
Motherboard
z390
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
Ok.
By the way thanks esafeddie, works like a charm. I just have to make SecureBootModel in disabled to boot correctly.`

What's the software you advise the most to use in Mac, for the cleaning, manage the power, the fan, etc. What is the most underrated for you ?

Thanks again !
 
Joined
Feb 22, 2011
Messages
196
Motherboard
Z390 Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Ok.
By the way thanks esafeddie, works like a charm. I just have to make SecureBootModel in disabled to boot correctly.`

What's the software you advise the most to use in Mac, for the cleaning, manage the power, the fan, etc. What is the most underrated for you ?

Thanks again !
i've been using iStatistica Pro for cpu sensors fan speeds etc.. Nice little program. For cleaning, CleanMyMac, seems to work. If anyone knows a better program, I'm all ears.
 
Joined
Nov 26, 2020
Messages
3
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
Intel Core i5-9600K 3.7 GHz
Graphics
Sapphire Radeon RX 580 8 GB PULSE
Mac
  1. iMac
  2. MacBook Pro
Hi - Try this EFI Folder, all files and kexts updated.

First of all thanks for what you do. This so far works perfect upgrading from 0.6.4 > 0.7.5, Catalina > Monterey. Only issue I get is an error before opencore boot picker I can not figure out.

OCS: NO Schema for UIScale at 12 index, context <output> !


UPDATE:
Removing UIScale -1 from UEFI > Output resolved the schema error.
 
Last edited:
Joined
Mar 9, 2012
Messages
2,606
Motherboard
Gigabyte Z590 AORUS MASTER
CPU
i7-11700k
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Was there much on a change from .7.8 to .7.9? Really finding my system sluggish.
Hiya - In reality one should always at least update to the latest official released OC version as quite a lot of changes would be implemented as well as some aspects would be taken out or amended. Me my self, I use the Nightly Versions as soon as they come out and so far haven't had any problems with them such as you described.

One should update all the files within the EFI Folder and should not reuse old files from the previous version, as well as updating to latest kexts version. The only files that should be kept from previous should be your SSDT files.
If you like, remove your personal data from your config.plist, compress and zip the entire EFI Folder and post it and I'll take a look at it for you.
 
Joined
Feb 22, 2011
Messages
196
Motherboard
Z390 Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Hiya - In reality one should always at least update to the latest official released OC version as quite a lot of changes would be implemented as well as some aspects would be taken out or amended. Me my self, I use the Nightly Versions as soon as they come out and so far haven't had any problems with them such as you described.

One should update all the files within the EFI Folder and should not reuse old files from the previous version, as well as updating to latest kexts version. The only files that should be kept from previous should be your SSDT files.
If you like, remove your personal data from your config.plist, compress and zip the entire EFI Folder and post it and I'll take a look at it for you.
Thanks brother!!!
 

Attachments

  • EFI.zip
    54.2 MB · Views: 38
Joined
Mar 9, 2012
Messages
2,606
Motherboard
Gigabyte Z590 AORUS MASTER
CPU
i7-11700k
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
@cabal2000 - Hi Bro, before you commit this revised EFI Folder, I suggest you try it on the EFI Partition of a test USB drive just incase things goes sideways. There were quite a few anomalies that needed correcting, as shown in the attached pics, which I've done for you.

I have removed some unnecessary entries from the Drivers folder as they are more pertaining to a Legacy Install so not needed. I am wondering why you have the RtcRw.efi File Enabled in the config.plist and in the Tools Folder, I am certain we don't need it for our system as it can inhibit the BIOS Clock but I did not remove it just incase.

Like I said, test my corrections first and let me know if any improvement in performance. Any problems let me know so I can make further adjustments or suggestions. Good luck.
 

Attachments

  • Screenshot 2022-04-18 at 11.22.35 am.png
    Screenshot 2022-04-18 at 11.22.35 am.png
    126.1 KB · Views: 37
  • Screenshot 2022-04-18 at 11.23.37 am.png
    Screenshot 2022-04-18 at 11.23.37 am.png
    116.4 KB · Views: 38
  • Screenshot 2022-04-18 at 11.25.28 am.png
    Screenshot 2022-04-18 at 11.25.28 am.png
    260.7 KB · Views: 37
  • Screenshot 2022-04-18 at 11.53.39 am.png
    Screenshot 2022-04-18 at 11.53.39 am.png
    143 KB · Views: 35
  • Screenshot 2022-04-18 at 11.54.07 am.png
    Screenshot 2022-04-18 at 11.54.07 am.png
    253.4 KB · Views: 35
  • Revised EFI.zip
    54.2 MB · Views: 48
Joined
Jan 21, 2014
Messages
11
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX Vega 56
Mac
  1. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
@esafeddie
thank you for the last EFI.
With this one I was able to update from Clover/Catalina (iMac19,1) directly to OC/Monterey (iMacPro1,1) without any problems.
I delayed an update for a long time because I got along excellently with Clover and OC was a closed book for me.

Only the USB ports did not work properly.
But thanks to @UtterDisbelief and his "The New Beginner's Guide to USB Port Configuration" I was able to create a new USB map and all ports now work either in USB 3 or USB 2 mode.
 

Attachments

  • Z390-Pro Wifi_USB-Ports.jpg
    Z390-Pro Wifi_USB-Ports.jpg
    639.2 KB · Views: 14
Top