Contribute
Register

OpenCore stuck on bridges 3 : devices 14

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,793
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Is there anything wrong with my efi?
this doesn't look right:
Code:
<key> </key>
                <string>keepsyms=1   debug=0x100     alcid=11</string>

or:
Code:
<key>Memory</key>
        <dict>
            <key>DataWidth</key>
            <integer>64</integer>
            <key>Devices</key>
            <array>
                <dict/>
            </array>
            <key>ErrorCorrection</key>
            <integer>3</integer>
            <key>FormFactor</key>
            <integer>9</integer>
            <key>MaxCapacity</key>
            <integer>68719476736</integer>
            <key>TotalWidth</key>
            <integer>64</integer>
            <key>Type</key>
            <integer>26</integer>
            <key>TypeDetail</key>
            <integer>128</integer>
        </dict>

you should check with the sample.plist and also run ocvalidate on your config.plist
 
Joined
Jun 27, 2021
Messages
97
Motherboard
HP ProDesk 600 G1
CPU
i5-4570T
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
this doesn't look right:
Code:
<key> </key>
                <string>keepsyms=1   debug=0x100     alcid=11</string>

or:
Code:
<key>Memory</key>
        <dict>
            <key>DataWidth</key>
            <integer>64</integer>
            <key>Devices</key>
            <array>
                <dict/>
            </array>
            <key>ErrorCorrection</key>
            <integer>3</integer>
            <key>FormFactor</key>
            <integer>9</integer>
            <key>MaxCapacity</key>
            <integer>68719476736</integer>
            <key>TotalWidth</key>
            <integer>64</integer>
            <key>Type</key>
            <integer>26</integer>
            <key>TypeDetail</key>
            <integer>128</integer>
        </dict>

you should check with the sample.plist and also run ocvalidate on your config.plist
When I boot with iMac 14,4 it boots fine with Big Sur, when I changed the EFI to 16,2 when it boots to the Apple logo, it crashes and restarts
 
Joined
Jun 27, 2021
Messages
97
Motherboard
HP ProDesk 600 G1
CPU
i5-4570T
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
When I boot with iMac 14,4 it boots fine with Big Sur, when I changed the EFI to 16,2 when it boots to the Apple logo, it crashes and restarts
I'm also trying to upgrade to Monterey by the way.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,267
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I'm also trying to upgrade to Monterey by the way.
The 2014 Mac mini still has Monterey support, if you can believe that. It uses an iGPU closest to HD4600. Give that a try and see what happens.
 
Joined
Jun 27, 2021
Messages
97
Motherboard
HP ProDesk 600 G1
CPU
i5-4570T
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
I don't see on OC-Gen X that it shows Mac Mini
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,267
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I don't see on OC-Gen X that it shows Mac Mini
Just open your config.plist with an editor and change it that way. Use iMac7,1 with no spaces.
 
Joined
Jun 27, 2021
Messages
97
Motherboard
HP ProDesk 600 G1
CPU
i5-4570T
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
Just open your config.plist with an editor and change it that way. Use iMac7,1 with no spaces.
Does it matter if the System UUID is unchanged?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,267
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Does it matter if the System UUID is unchanged?
Not sure. I would generate new serials and SMUUID and add those to the .plist too.

 
Joined
Jun 27, 2021
Messages
97
Motherboard
HP ProDesk 600 G1
CPU
i5-4570T
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
Not sure. I would generate new serials and SMUUID and add those to the .plist too.

I got the Monterey to work but now I can't get the AppleALC I want to work. When I inserted the kext and restarted, It's stuck on the Apple logo, I tried using alcid=11, 15 & 88 but none of them worked.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,267
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
It's stuck on the Apple logo
When this happens you'll always need to boot verbose and take a screen pic of where it stops.
Also, when you add a new kext, you must define it in your config.plist too.
 
Top