Contribute
Register

<< Solved >> OpenCore battery patch

Joined
Aug 12, 2020
Messages
25
Motherboard
HP Elitebook 850 g3-OC
CPU
i5-6200U
Graphics
HD 520
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@kvmKillerman

Exactly, I would also first of all try to get the battery working, until we clean up other areas. BTW, prepare to loose some functionality while battery is being worked on, only goal now is to get a percentage displayed, everything else will come back later on.

If it doesn't boot, please attach an image of the last output form verbose boot.
Wow, finally i can see my battery percentage and if its charging or not. At first boot i couldnt type or click but that happens sometimes, i booted again and now i get to log in. Everything else seems to work except i lost functionality to change brightness so the slider and fn is unusable. Audio fn keys work just fine :) Ima head to bed now bc its 1:43 am in finland so brb.
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@kvmKillerman

Great, I will continue to help you tomorrow, since it's 0:45 here in austria already too, and I desperately need sleep, :p. Till soon!
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@kvmKillerman

I now greatly simplified your setup, please test it once again and see if it still works as it did before. I *think* brightness should be back. Regarding the clicking: You mean your trackpad doesn't work on some boots? You load a lot of PS2 / I2C stuff, I can offer you to look into that next.
 

Attachments

  • EFI.zip
    31 MB · Views: 49
Joined
Aug 12, 2020
Messages
25
Motherboard
HP Elitebook 850 g3-OC
CPU
i5-6200U
Graphics
HD 520
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@kvmKillerman

I now greatly simplified your setup, please test it once again and see if it still works as it did before. I *think* brightness should be back. Regarding the clicking: You mean your trackpad doesn't work on some boots? You load a lot of PS2 / I2C stuff, I can offer you to look into that next.
Thank you so much, seems like that everything works! Havent tested the imessage or facetime yet but i personally dont see much need to change anything because all works and it boots pretty fast. Do you see anything that might be problematic in the future, should i post my verbose boot?
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@kvmKillerman

Awesome! Happy to hear that. You stated in the past that you got facetime and imessage working with your generated serial and such, after we're done here I would just put that back in, since it has no effect on the functionality, feel free to do so.

Only thing I think is problematic is the fact that your trackpad doesn't work 100% of the time. I'd like to fix that, tbh.
 
Joined
Aug 12, 2020
Messages
25
Motherboard
HP Elitebook 850 g3-OC
CPU
i5-6200U
Graphics
HD 520
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@kvmKillerman

Awesome! Happy to hear that. You stated in the past that you got facetime and imessage working with your generated serial and such, after we're done here I would just put that back in, since it has no effect on the functionality, feel free to do so.

Only thing I think is problematic is the fact that your trackpad doesn't work 100% of the time. I'd like to fix that, tbh.
Everything seems to work now, including facetime and imessage. I would rather not make any changes now since everything seems to work with no issues, so is it okay that i just message if i see something that doesnt work?

Huge thanks to you for all your help!!
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@kvmKillerman

Sure thing, it's your machine! :). Just hit me up if you encounter any further issues. No problem, btw, I always love to help.
 
Joined
Jan 19, 2021
Messages
12
Motherboard
Funhouse F10 MPro (OpenCore)
CPU
i5-10110U
Graphics
UHD 620, 2256x1504
Mobile Phone
  1. Android
Hello BlvckBytes,I'm running Monterey on my Laptop
Hardware Specification:
CPU: Intel Core i3 10110U
Memory: LPDDR3
GPU: Intel UHD Graphics 620
Ports: 1xDC 2xUSB3.0 1xType-C 1xHDMI 1x3.5mm
Now the battery indicator and power supply status are not working, battery percentage always stuck at 1%
When checking hackintool , I found these errors:
ACPI Error: No handler for region [ECF2]
ACPI Error: Region EmbeddedControl (ID=3) has no handler
ACPI Error: Method parse/execution failed [\__SB.PCI0.LPCB.EC.BAT0._STA]
Can you help me?Thanks...
Following are my EFI and DSDT
 

Attachments

  • acpi_dsdt.dsl
    1.9 MB · Views: 25
  • EFI-SSD.zip
    32 MB · Views: 27
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@tingyichen

Have you already had a look at ECEnabler.kext, did that not work in your case?
 
Joined
Jan 19, 2021
Messages
12
Motherboard
Funhouse F10 MPro (OpenCore)
CPU
i5-10110U
Graphics
UHD 620, 2256x1504
Mobile Phone
  1. Android
@BlvckBytes
I already have ECEnabler, it doesn't work
Also, I tried split EC fields bigger than 1byte into multiple fields, still same result
 
Top