Contribute
Register

OpenCL Crash in Photoshop CC using a GTX 960

Joined
Nov 25, 2015
Messages
6
Motherboard
GA-Z97X-UD5H-BK
CPU
Intel Core i7-4790k
Graphics
GTX 960 SuperSC
Mac
Classic Mac
Mobile Phone
Certain processes in Photoshop CC (2014) cause a CTD when OpenCL is turned on, and I'm having a tough time figuring out why.

Examples of these processes are : Smart Sharpen, Image Resize

They all work when OpenCL box is unchecked, but obviously I'd rather have it, than not have it.

Here's some information about my system:CPU :
Intel Core i7-4790K 4.0GHz Quad-Core Processor
Mobo : Gigabyte GA-Z97X-UD5H-BK ATX LGA1150 Motherboard
RAM : Crucial Ballistix Tactical 32GB (4 x 8GB) DDR3-1600 Memory
GPU : EVGA GeForce GTX 960 2GB SuperSC ACX 2.0+ Video Card

I used the latest Clover installation, iMac 14,2 running 10.11.2, and I have the nvda_drv=1 boot flag. I'm also using the NVIDIA web driver 346.03.04f02
In the Graphics tab of Clover Configurator, Inject Intel is ticked whilst everything else is unchecked

I've attached a screenshot of a LuxMark benchmark, which as I understand checks OpenCL, in case it might aid you aiding me :)
 

Attachments

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,108
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
GTX 970
Mac
MacBook Pro
Classic Mac
PowerBook
Mobile Phone
iOS
Unfortunately this is pretty common. The only way to fix it until Nvidia releases a new driver is to disable it.
 
Joined
Nov 25, 2015
Messages
6
Motherboard
GA-Z97X-UD5H-BK
CPU
Intel Core i7-4790k
Graphics
GTX 960 SuperSC
Mac
Classic Mac
Mobile Phone
Shame :( Thanks for letting me know, and sorry for posting something that has probably been posted 845648756 times already.Well fingers crossed for a new Nvidia driver soon (that works)
 
Top