Contribute
Register

Open Core fresh installation to boot with iGPU HD 4600 and RX 580

Status
Not open for further replies.
Joined
Jun 13, 2014
Messages
25
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hello Hackintosh community, I am currently trying to install Catalina using Open Core 0.6.4 on the following hardware:

CPU Intel(R) Core(TM) i7-4790K (iGPU Intell HD 4600)
Motherboard: GIGABYTE GA-Z97X-UD7
GPU: SAPHIRE Radeon RX580 Pulse

I've strictly followed this guide https://dortania.github.io/OpenCore-Install-Guide/config.plist/haswell.html
Also, I've read these guides as well to configure a headless iGPU properly:

I've created an installer USB stick and is capable to get to the Open Core Boot Menu and select 'Install macOS Catalina (external)'
After that, I get the following error, and the boot process fails:

Code:
18:658 00:025 OC: Prelinked status - Success
19:079 00:420 AAPL: [EB|#SB:HW] j137ap\0
19:102 00:022 AAPL: [EB|#SB:MF] (System\\Library\\PrelinkedKernels\\immutablekernel.j137ap.im4m)
19:124 00:021 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: System\\Library\\PrelinkedKernels\\immutablekernel.j137ap.im4m, DP: 0
19:153 00:029 OCI4: Verifying digest 48 (EEA7F868) override 1 48 (EEA7F868)
19:564 00:411 OCI4: Matching override CBF5B35E with CBF5B35E - success
19:587 00:022 AAPL: [EB|#SB:MKRN]
19:615 00:028 AAPL: [EB|`LD:LKFS] } Ok(0)
19:636 00:021 AAPL: [EB|`LD:LKC] } Ok(0)
19:671 00:034 AAPL: [EB|#FWFM] 0xFF1FFF3F
19:766 00:095 AAPL: [EB|#FWFT] 0xF80FE137
19:787 00:021 AAPL: [EB|#CSR:OUT] 0x00000040
19:810 00:022 AAPL: [EB|`BST:FBS] {
19:832 00:022 AAPL: [EB|#GIP:PHS.1] Boot 1
19:855 00:022 AAPL: [EB|#GIP:PCT] 0x0
19:877 00:021 AAPL: [EB|#GIP:PHS.2] Boot 1
19:899 00:022 AAPL: [EB|`BST:FBS] BA.ADSZ: 0
19:921 00:021 AAPL: [EB|`BST:FBS] BA.KSDSZ: 0
19:944 00:022 OCSMC: SmcReadValue Key 4D535463 Size 1
19:965 00:021 OCSMC: SmcReadValue Key 4D534163 Size 2
19:988 00:022 AAPL: [EB|`B:WFDW] Err(0xE), 0 @ LocHB 71B4903C-14EC-42C4-BDC6-CE1449930E49
20:021 00:033 AAPL: [EB|#LOG:DT] 2020-12-28T20:07:18
20:044 00:022 AAPL: [EB|#STOP|`BST:FBS] ! @ MM:AKM 443944960 @ 'RT
20:065 00:021 AAPL: [EB|#WL|6] 0x01 0x03  23 0x0E
20:088 00:022 AAPL: Exiting efiboot...
20:110 00:021 AAPL: [EB|#WL|7] 0x01 0x03  23 0x0E
20:132 00:022 AAPL: [EB|#LOG:EXIT] 2020-12-28T20:07:18

BIOS config:
Intell Process Graphics: Enabled
Intell Process Graphics Memory Allocation: 64M (also tried with 32M)
DVMT Total Memory Size: MAX (also tried 128M and 256M)

In the open core config, I've put a headless device for my iGPU (I've tried both 0x04120004 and 0x0412000B).
OC_DeviceProperties.png

Also, attached my EFI folder.

IMPORTANT: When I replace RX 580 with my old GTX 770 I can successfully boot with Open Core and get to the installer UI. This makes me think there some issue with configuration related to the iGPU 4600 and RX580 but I cannot figure out what exactly.

Please advise how to troubleshoot or resolve this issue.

Thank you
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,303
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Please advise how to troubleshoot or resolve this issue.
I would remove the graphics card and do the install using HD4600 via the onboard HDMI output. Makes everything easier. Change your platform ID and BIOS to use the integrated graphics. See the dortania guide for the platform ID info. After that run you config.plist through the online sanity checker for a Haswell CPU system.
 
Joined
Jun 13, 2014
Messages
25
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I would remove the graphics card and do the install using HD4600 via the onboard HDMI output. Makes everything easier. Change your platform ID and BIOS to use the integrated graphics. See the dortania guide for the platform ID info. After that run you config.plist through the online sanity checker for a Haswell CPU system.
Thank you for your reply, basically, you are recommending to do the installation with iGPU only (desktop platform id), and after success insert RX 580 and adjust Open Core config with a headless iGPU platfrom id.
Is it correct?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,303
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Thank you for your reply, basically, you are recommending to do the installation with iGPU only (desktop platform id), and after success insert RX 580 and adjust Open Core config with a headless iGPU platfrom id.
Is it correct?
:thumbup:
 
Joined
Jun 13, 2014
Messages
25
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Ok, so I just did that, successfully installed Catalina so I can boot from my SSD with iGPU only, however, when I inserted RX 580, changed BIOS to use dGPU for display, and set Platform ID to 04001204 (headless) it failed to boot with the same error as before.

Any other suggestions?
 

Attachments

  • IMG_0066.jpg
    IMG_0066.jpg
    3 MB · Views: 52
  • IMG_0068.jpg
    IMG_0068.jpg
    3.8 MB · Views: 52

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,303
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Ok, so I just did that, successfully installed Catalina so I can boot from my SSD with iGPU only, however, when I inserted RX 580, changed BIOS to use dGPU for display, and set Platform ID to 04001204 (headless) it failed to boot with the same error as before.

Any other suggestions?
Sure you have all of the latest kexts in your EFI kexts folder ?
 
Joined
Jun 13, 2014
Messages
25
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Status
Not open for further replies.
Top